Bootloop when installing 23.05.2 on RB951Ui-2HnD

Hi,
So I get my RB951Ui-2HnD router today and wanted to install OpenWRT for the first time on it.
After loading initramfs and installing sysupgrade file in LuCI, my device goes into an infinite boot loop.
I tried to install OpenWRT 19.07.10 and it was successful, but I need some packages which requires OpenWRT >= 23.
Unfortunately, this is my first time using OpenWrt so I really don't know how can I provide any logs regarding this bootloop.

Any idea how can I fix this issue?
Thanks

(sys)upgrade your way up to 23.05.3 from 19.07 ? reset settings with every upgrade.

I tried both ways:

  1. Installing OpenWrt 23.05.3 (even 23.05.02) on top of RouterOS 6.49.15
  2. Upgrading from 19.07.10 to 23.05.3 without retaining any settings
    but both ways ended up in boot looping

did you do this in one step, or release by release ?

upgrading from 19.07.10 to 23.05.3?
I just did it in one step, downloaded 23.05.3 sysupgrade file and flashed it in LuCI

unfortunately it didn't help
i tried to install the upgrade release by release but after installing version 23, the device goes to bootloop

then we'll probably need serial to figure out why, or you can stay on 22.03,
for now, but it won't help us solve the issue at hand, unless it's a known
problem (I haven't checked at github).

Unfortunately, support for RB951Ui-2HnD start with version 23 (based on the data on https://firmware-selector.openwrt.org/)

can you explain this more? i don't have much experience with routers

ah, I misunderstood your reply, I'll remove my post, must have mixed up your device with some other Mikrotik product.

https://openwrt.org/docs/techref/hardware/port.serial
https://openwrt.org/docs/techref/hardware/port.serial.cables

image

1 Like

Would you be able to try the 23.05.0 initramfs and sysupgrade:
https://archive.openwrt.org/releases/23.05.0/targets/ath79/mikrotik/

There's been a significant file size increase.

There is a note on the device page about a design change to recent production units which breaks OpenWrt.
https://openwrt.org/toh/mikrotik/rb951g_2hnd

3 Likes