Blueendless Kimax BS-U35-WF

Hello, I do not know how to perform the original firmware backup, I tried many openwrt firmware and the only thing that worked for me was this firmware:


1 Like

Can this be uploaded thru kimax interface or not

Thank you very much for your answer servas, I'll try this firmware, but before I'll try find out how to backup.

There is back up for kimax u35wf

Hi ClaudioPoa,
I had problems with firmware (1.7.5 version) - KIMAX-H1-1.7.5-37-986a298da9147478c40c73a1f37e9690-R.bin) for this router then I request it from Blueendless. It`s shared at this link It works!

Did anyone have this problem?

does not enter the password, any way to recover?

I've picked up a Kimax U35NF. Which from what I can tell is very similar to the U35WF and U25AWF-H1. I've followed the guide and ran into the same issue with the device. And here's what I've learned.

The reason why this happens is that the OEM GUI flash method preserves the unix user configuration in the /etc/passwd and /etc/shadow files from the Kimax firmware and copies them over to OpenWrt.





The problem with these configurations is that the "root" account is disabled for login and the password for the other admin (which is: kimax) and guest (which is: guest) will not help because these accounts have no shell (/bin/false). So the old configuration has to be wiped in order to get to the device.

Luckily, there is a easy way to do this without opening the device:

1. Power on the device and wait for the status led to stop flashing (or go in Failsafe Mode above).

2. Press and keep pushed the Reset button for 10 seconds.

3. Release the Reset button

Then let it reboot and once the LEDs stop flashing, you can enter it via
ssh root@ and go from there.

Now, I did make the mistake of flashing the wrong image at first. I loaded the U35WF Image instead of the U25AWF-H1 and as a result the reset button wasn't working (I was getting the same "wrong password" error like you). So I had to wire-up the uart (as shown in Blueendless Kimax BS-U35-WF I can confirm that it works! ) and then I was able to flash my my U35NF with the U25AWF-H1 image on through the bootloader menu.

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP. <---
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.

Final thought: This would have been much easier if I had flashed the right image from the beginning. So I guess for anybody who is wondering which image to take: Please take a close look of the SoC and the WIFI/Connect LED color. If you have a MT7620A (v2 board?) and the Wifi-LED is red then I would go with U25AWF-H1. If you have a MT7620N (v3 board?) and the Wifi LED is blue then the U35WF is probably the right board.
I think the HDD LED seems to be blue in both cases? (can somebody confirm that?)


I want to thank you for the help, I really appreciate it.

I have no way of doing Failsafe Mode, Factory Reset, and Recovery Mode, since I have seen where pressing the reset button does not respond.

Please help me once again, are you sure that this method works with the Blueendless U35WF?

Thank you!!

The Factory Reset method should work all devices running OpenWrt that have a reset switch.

The main difference between the U35WF and U25AWF-H1 image in the device's devicetree definitions is the GPIO of the reset button. Can you take a Phillips screwdriver and disassemble your Kimax and make a picture of the daugtherboard with the SoC (Should be either the MT7620N or MT7620A).


I want to thank you for the help, MT7620A 2.0


HSEN-300M-MT7620A-V2.0 is this silkscreened on the SoC board?

1 Like

It is what it says, it would be easier with the adapter?
I think I can get one.


ic have the u35 Wf and update it to openwrt from here

but now i can not log in i try root, admin, 1234 and the original kombination and any of these as kombination.

it is strange i had no ask to enter a password.
ssh doesnt work because it will have the password.

what can i do?

the soldering would be easy with a r232 USB adapter that i have but what after that?

Hiya, first post here.
probably bricked the thing, but before attempting de-bricking procedures, lemme say what I did to it and see if perhaps I didn't brick it.
I went to the device listing, downloaded the SNAPSHOT file (yes, I didn't stick around to double check--that's going to be a theme), and flashed that file (which has "sysupgrade" in it, but does not say factory) via the GUI method provided by Blueendless.
in other words, I did not follow instructions and may have messed up a $50 device. meh.
What it does now: I have LED's. Hard drive one blinks a bit on boot, then stays solid. Wifi (which is red) blinks very rapidly non stop beginning a few seconds after boot. I have not managed to get any connection to the device (no wifi network appears, and plugging in can't find anything on the original IP address, or the Open WRT ip address). Plugging in a USB cable does work for accessing files.
any guidance, or should I try de-bricking it or buying a new one (to then actually follow the instructions)?

Hola tengo el problema que despues de actualizar (openwrt-19.07.2-ramips-mt7620-kimax_u35wf-squashfs-sysupgrade) no tengo acceso por no tener el password, ni me funciona el boton reset, he visto que el problema se repite, ¿Alguien lo ha solucionado? muchas gracias .
Hello I have the problem that after updating (openwrt-19.07.2-ramips-mt7620-kimax_u35wf-squashfs-sysupgrade) I do not have access because I do not have the password, nor does the reset button work for me, I have seen that the problem repeats, ¿ Has anyone fixed it? Thanks a lot

Hi. I have the same problem as you. If you have solved it, could you help me?
Thank you very much in advance.

I didn't decide

Hi. I have the same problem as you. If you have solved it, could you help me?
Thank you very much in advance.

hi there for me thats the case, have the same issue on password not able to login.