Blueendless Kimax BS-U35-WF No IP or Wifi

Hello every one I just installed this Firmware OpenWrt snapshot Upgrade URL from here and I now I can't access my device the WiFi doesn't show up and the the LAN connection is not receiving an IP.
How do I reset everything ?

WiFi is disabled by default, so you’ll need to connect using Ethernet.

Why are you using a snapshot? It is best to use a stable release version.

@psherman thank you for replying. I thought I would give it a try (I learned my lesson). Now my device is bricked is there any way to restore it ?

Try failsafe mode (you will need to connect by Ethernet and set your ip address manually):

Could you elaborate more please? should I connect it to my laptop or to my home router? (till now it was connected to my router with Ethernet)
I tried to enter Failsafe but it talks about pressing a button and my the device has no button to press or a power LED indicator I just got HDD and Wifi lighting up.

Plug it into your computer by Ethernet. Make sure nothing else is connected to your computer or this router. Turn off WiFi on your computer, too.

1 Like

Alright I will try and report back

Connect wires for serial port ...

If UBoot good you have this:

This is what I got right now what is the next step?
should I just run firstboot && reboot now ?

It's good the firmware starts , normally it should work

run ifconfig & see what happens

for wifi it is disabled by default

uci set wireless.@wifi-device[0].disabled=0
uci commit wireless
exit 0

1 Like

This is ifconfig:

Nice to see it still work. At this point, I would like to redo everything and this time flash a stable firmware or better yet if you could tell me how to get back to stock firmware so that I know what to do next time I mess up.

Address ip is but possible conflict if your router use same address !!!

For the firmware you can use a stable firmware

choise version > -> target -> ramips -> mt7620 -> kimax-u35

1 Like

My router is so it should be fine. Anyways, I tried the looking through your link but couldn't find anything kimax related isn't that the same as the one here ?
I still don't know how to flash it though. I will be thankful if you could link a guide or something.

You cannot view files ??

And in this folder, file :kimax_u35wf-squashfs-sysupgrade.bin ?

use WINSCP protocol SCP , connect
login : root
password : nothink
copy firmware file in tmp/tmp

With serial consoçle
cd /tmp/tmp
cat /proc/mtd , look for mtdxxx firmware

Write firmware:

mtd write file.bin firmware

reboot -f


after the reboot I think you will not have luci web page

in network file

ipaddr : 192.168.0.x
gateway :
dns :

opkg update
opkg install luci

in explorer : 192.168.0.x you will have luci's web page

1 Like

Thank you very much I didn't understand this part:

but I went with it and this is what I got. should I be worried ?


Normally it should work as it should

For start WIfi use this command:
uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi

1 Like

thanks a lot I actually used the UI to do it

The settings looks different from the tutorial. I cant find mount points mentioned here

i use this:

opkg update
opkg install ntfs-3g
opkg install e2fsprogs fstools fwtool block-mount blkid lsblk
opkg install kmod-fs-exfat kmod-fs-exportfs kmod-fs-ext4
kmod-fs-reiserfs kmod-fs-vfat
opkg install kmod-scsi-core
opkg install kmod-usb-core kmod-usb-storage kmod-usb-storage-extras
opkg install kmod-usb-storage-uas kmod-usb-printer kmod-usb-xhci-mtk
opkg install kmod-usb-wdm kmod-usb-xhci-hcd
opkg install kmod-usb3
opkg install kmod-mtd-rw
opkg install luci-app-ksmbd kmod-fs-ksmbd ksmbd-server
opkg install luci luci-app-opkg luci-theme-bootstrap luci-theme-material
opkg install luci-app-p910nd luci-app-minidlna
opkg install luci-proto-relay

for ntfs problems use this command & reboot
ln -s /usr/bin/ntfs-3g /sbin/mount.ntfs

1 Like

I run these commands only the two below failed:

opkg install kmod-usb-storage-uas kmod-usb-printer kmod-usb-xhci-mtk

opkg install kmod-usb-wdm kmod-usb-xhci-hcd

but now I get a white screen after login

Weird ...

Test with:
opkg remove luci
opkg install luci