Blocking bad SSID name

I have an SSID with a ‘ in it that’s making Luci (travelmate) fail with System Error 500. I’ve tried blocking the Mac with iptables and also denying it in my wireless configuration:

/user/sbin/iptables -A INPUT -m mac —mac-source XX:XX:XX:XX:XX:XX -j DROP

And

config wifi-iface .....
option macfilter ‘deny’
list maclist ‘XX:XX:XX:XX:XX:XX’

And the initial packet still gets through. How do I tell iwscan to ignore a specific Mac/SSID?

Sounds like a LuCI bug, as that is a valid character. It’s probably that the “quoting” being done isn’t aware that a single quote in the SSID breaks 'Joe's Wireless' or the like.

Edit: In UCI for creating an SSID with a single quote in it, I represented this as

option ssid 'Joe'\''s SSID'

the travelmate maintainer is pretty active.... try posting on the travelmate support thread.... ( nb: it is really surprising this has not already occured so i wonder if there isn't something unique to your setup.... wifichipset??? )

better to block where the error is.... or better yet... fix support.... you never know what hotel is going to advertise "wifi's" :wink:

This bug has already been fixed a while ago, please try latest snapshot version (1.4.8). Thanks!

2 Likes