Block mount ntfs - not a tty

daemon.err block: mounting /dev/sda1 (ntfs) as /mnt/sda1 failed (22) - Not a tty

what's not a tty?

Can you describe more in detail the procedure or guide you have followed?

1 Like

thanks for replying

so, what i did were:

  1. hdd didn't mount.
  2. Checked sys log and saw the entry "... Not a TTY".

Automount also doesn't work.

I'm using davidc602's latest build on my wrt1900acs. I'm pretty sure all packages one can *reasonably expect to be necessary for what I was trying to do have been installed.

I'm actually able to mount it manually and by configuring the manual mount command to run on startup I have no problem using the hdd.

I hope to understand the log entry in question because over the past week by trying out for the very first time a custom router firmware i.e. openwrt, I ended up with an intense interest in openwrt and linux and simply want to learn more about how openwrt/linux works.

Any answers/troubleshoot suggestions would be appreciated.

From mount:

block info cannot detect btrfs (added r43868), xfs , jfs, ntfs, exfat, and some other FS. Use manual scripting to mount them.

So read here and setup a way to mount it on boot or hotplug.

1 Like

So is this a bug or just not supported?

cheers

Looks like no support.

1 Like

alternate guide

2 Likes

Thanks, I'll add a note in the wiki when @anchorwall confirms that it works.

1 Like

ok, so tried it... seems it's calling block mount which complains ( with ntfs-3g only );

block: No "mount.ntfs" utility available
block: mounting /dev/sdc1 (ntfs) as /mnt/sdc1 failed (2) - No such file or directory

something then wanted mount.ntfs3g in the script ... I think raw mount... but it could not find it by that name... some kind of alias to ntfs-3g...

so workaround for block mount + ntfs-3g is (based on fstab from above guide)

ln -s /usr/bin/ntfs-3g /sbin/mount.ntfs
direct test ammendum use block mount fix above no hotplug needed
			#######dev_mounted"mount -l | awk '{print $1}'"
			flag=0
			mount | while read dev_mounted therest; do
				if [ "/dev/${device}" == $dev_mounted ]; then
					flag=1
				fi
			done

			[ $flag != 1 ] && {

				logger -t Auto-Mount "Block /dev/${device} added."
				logger -t Auto-Mount "UUID=$get_uuid"
				
				have_uuid=$(uci show fstab | grep -c "$get_uuid")
				##### flag is 1 just mount from here[ "$have_uuid" = "0" ] && {
					mkdir -p /mnt/$device
					chmod 777 /mnt/$device
					set_fstab
					#NOPE(well with ln -s will work now) block mount >> /dev/null 2>&1
					#NOPE mount.ntfs3g /dev/$device /mnt/$device
					ntfs-3g /dev/$device /mnt/$device  >> /dev/null 2>&1
				#########}
1 Like

hi @trendy , looks like @wulfy23 has already tested it. do you still need me to?

Anyone is free to fix or update the wiki pages. I added the link to this topic for a week already, so that should do it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.