Block mount does not mount by label

Hi,

in my previous setup in /etc/config/fstab I had the label option instead of the uuid and it was working ok.

In the current openwrt 22.03.05 it does not.

What it works:

  • lsusb shows the device
  • blkid shows the device
  • block info shows the device
  • mount /dev/sda1 /mnt/ works

What it doesn't work

  • block mount

If I add the uuid in the disk fstab section block mount works.

If you think that is ok I don't mind creating a proper bug report.

Thanks

post your fstab ?

1 Like

Not a topic expert, but let me try to help presort it:

My suggestion would be, you provide more details:

  • post the actual config fstab file, reduct secrets if necessary
  • post the full set of parameters you used for the commands
  • which version does the „previous setup“ mean?

Also, please confirm that both current and previous version is about the real OpenWRT, downloaded from openwrt.org (and not a 3rd party modification of OpenWRT downloaded elsewhere).

it would also be a very good idea, to verify your bug with 23.05rc3 of the real OpenWRT.

2 Likes

The OpenWRT is from FriendlyElec for nanopi R5C. Right now I can't find a OpenWRT release for that hardware. If that disqualifies my report I understand...

My previous setup was a linksys 1200AC that got busted. It had openwrt 19.07.3 on it.

root@OpenWRT:~# cat /etc/openwrt_release 
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='22.03.5'
DISTRIB_REVISION='r20134-5f15225c1e'
DISTRIB_TARGET='rockchip/armv8'
DISTRIB_ARCH='aarch64_generic'
DISTRIB_DESCRIPTION='OpenWrt 22.03.5 r20134-5f15225c1e'
DISTRIB_TAINTS='busybox'
root@OpenWRT:~# cat /etc/openwrt_version 
r20134-5f15225c1e

Here are the commands that succeed

root@OpenWRT:~# lsusb 
...
Bus 006 Device 053: ID 174c:55aa Intenso USB 3.0 device
...

root@OpenWRT:~# block info | grep sda
/dev/sda1: UUID="6ffd67a2-4965-4e06-9e30-2ca294758ffa" LABEL="intenso-4t-usb3-/" VERSION="1.0" MOUNT="/mnt/intenso-4t-usb3-sata" TYPE="ext4"

root@OpenWRT:~# blkid | grep sda
/dev/sda1: LABEL="intenso-4t-usb3-" UUID="6ffd67a2-4965-4e06-9e30-2ca294758ffa" BLOCK_SIZE="4096" TYPE="ext4"

So here is the /etc/config/fstab

config global
        option anon_swap '0'
        option anon_mount '0'
        option auto_swap '1'
        option auto_mount '1'
        option delay_root '5'
        option check_fs '0'

config mount
        option target '/mnt/intenso-4t-usb3-sata'
        #option label 'intenso-4t-usb3-'
        option uuid 6ffd67a2-4965-4e06-9e30-2ca294758ffa
        option enabled '1'

If I enable "option label" and comment out "uuid" block mount does not work. With uuid it works as expected.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

2 Likes

The builds looks very OpenWRT ly... to me but of course I can't be sure what the hardware provider has actually done.

Right now I can't find an image for nanopi R5C but if I read the forum correctly there is hope that the next OpenWRT (major) version will support it. I will retest then.