Block-mount cannot detect exFAT disks

I've already installed libblkid according to this post Mounting USB: block info block detect not able to see exFAT [solved] @jow but it does not solve the problem

Output of block info:

/dev/mtdblock5: UUID="537144626" VERSION="1" TYPE="ubi"
/dev/mtdblock7: UUID="1769583533" VERSION="1" TYPE="ubi"
/dev/mtdblock8: UUID="1473943039" VERSION="1" TYPE="ubi"
/dev/ubiblock0_0: UUID="b2d29059-66415dec-f6a5f122-3b4ce6a5" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"
/dev/ubi0_1: UUID="72778d7b-84f6-4837-b39a-753c6cbb7dad" VERSION="w4r0" MOUNT="/overlay" TYPE="ubifs"
/dev/ubi1_0: UUID="3326cc5b-0861-4cbd-8d2b-622514b6b605" VERSION="w4r0" TYPE="ubifs"

Output of blkid:

/dev/ubi1_0: UUID="3326cc5b-0861-4cbd-8d2b-622514b6b605" TYPE="ubifs"
/dev/ubi0_1: UUID="72778d7b-84f6-4837-b39a-753c6cbb7dad" TYPE="ubifs"
/dev/ubi0_0: TYPE="squashfs"
/dev/mtdblock5: UUID="537144626" TYPE="ubi"
/dev/mtdblock7: UUID="1769583533" TYPE="ubi"
/dev/mtdblock8: UUID="1473943039" TYPE="ubi"
/dev/ubiblock0_0: TYPE="squashfs"
/dev/sda1: UUID="267B-F202" TYPE="exfat" PARTLABEL="Basic data partition" PARTUUID="066c0f59-4f3d-4d51-98aa-21622acf19c4"

I've tried manually add UUID or device path to block-mount config, but it just states that the disk is not present.

Have you installed the main exfat support? (not just this detection)

Can you mount the exfat disk manually?

Of course.

Just asking because the supporting kmod is pretty well hideen behind the "build patented" setting.

I posted it to bug tracker
Would someone take a look?

Fixed in commit;a=commit;h=517cb0b70bebdc283965c7873521f7bf9b4fe736

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.