Block IPv6 from ISP

I have a PPPoE connection and I can change the IPv4 DNS, but I cannot block and change the IPv6 DNS. I need help to change

You want to block just IPv6 DNS, or do you want to halt all IPv6? For what purpose?

The reason I ask is that you may want to just disable IPv6 on your device.

Please do not start new threads about the same problem.

The original thread suggests that a bug may exist.

I want to block IPv6 DNS from ISP and use another DNS address

But, that's another topic, because it's another question

Add your preferred DNS servers to the WAN6 interface in LuCI and then run these uci commands over ssh:

uci set network.wan6.peerdns='0'
uci commit network
ifup wan6

When authenticating with PPPoE, an automatic IPv6 interface is created that cannot be edited.

OpenWrt needs to implement ISP IPv6 DNS blocking in a future update. This is not possible at the moment

Can you post your /etc/config/network file? I don’t use pppoe so I would like to understand your current config.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fde7:9d17:304b::/48'
config device
        option name 'br-lan'
        option type 'bridge'
        option igmp_snooping '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.4.4.1'
config device
        option type 'bridge'
        option name 'br-vlan'
        list ports 'lan4'
        option igmp_snooping '1'
config bridge-vlan
        option device 'br-vlan'
        option vlan '10'
        list ports 'lan4'
config interface 'vlan10'
        option proto 'static'
        option device 'br-vlan.10'
        option ipaddr '10.5.5.1'
        option netmask '255.255.255.0'
config device
        option type 'bridge'
        option name 'br-nonassign'
        option igmp_snooping '1'
        option mtu '1500'
config bridge-vlan
        option device 'br-nonassign'
        option vlan '10'
config bridge-vlan
        option device 'br-nonassign'
        option vlan '20'
config interface 'guest'
        option proto 'static'
        option device 'br-nonassign.10'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'
        option type 'bridge'
config interface 'vpn'
        option proto 'static'
        option device 'br-nonassign.20'
        option netmask '255.255.255.0'
        option ipaddr '192.168.7.1'
        option type 'bridge'
config rule
        option in 'vpn'
        option lookup 'wireguard'
        option priority '32765'
        option dest '0.0.0.0/0'
config interface 'wan'
        option proto 'pppoe'
        option device 'wan.120'
        option username 'xxxxx'
        option password 'zxxx'
        option ipv6 'auto'
        option keepalive '10 5'
config interface 'wg0'
        option proto 'wireguard'
        list addresses '10.2.0.2/32'
        option private_key 'xxxxxxxxxxxxx'
config wireguard_wg0
        option description 'US-FREE#840005'
        list allowed_ips '0.0.0.0/0'
        option endpoint_host '217.138.206.82'
        option endpoint_port '51820'
        option persistent_keepalive '25'
        option public_key 'XXXXXXXX'
config route
        option interface 'wg0'
        option table 'wireguard'
        option target '0.0.0.0/0'
config interface 'sqm'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option device 'br-sqm.10'
config device
        option type 'bridge'
        option name 'br-sqm'
config bridge-vlan
        option device 'br-sqm'
        option vlan '10'
config interface 'wan_6'
        option proto 'dhcpv6'
        option device 'pppoe-wan'
        option reqaddress 'try'
        option reqprefix 'auto'

You can run:

uci set network.wan.ipv6='1'
uci commit network

This should disable ppp auto-creating wan_6, at least as far as I can tell from historical posts.

1 Like

Yes, that is possible, however we cannot block IPv6 from the ISP in OpenWrt. Hope they release it in a future update

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.