Block domain not update after dnsmasq restart

Dear experts,
I'm follow the instruction from this link to block some domain: How to block particular Web sites - #7 by vgaetera
I found that can work perfect only after reboot my router TP-Link Archer C50 Openwrt Version 21.
However, when I restart "dnsmasq" it is not updated to block domains.
Based on your expertise, could you please help me how can I solve this issue without reboot my router?
Warmly thank you so much~

I understand you are following the instructions at DNS Filtering? Restarting dnsmasq should enable the block; could you explain exactly what are you doing, and how are you testing it, please?


dear @eduperez

my flow commands as below:
uci add_list dhcp.@dnsmasq[0].address="/"
uci commit dhcp
/etc/init.d/dnsmasq restart

=> if I don't reboot my router, it is can access from browser. When I reboot my router, it is working well for block
I don't know how can solve this issue, could you please advice to me~

Cashed DNS entries on client, tried rebooting the client, instead of the router ?

Also, use, not, 127 will make the client do a connection attempt, and time out, while will abort immediately.

By the sound of it, it's probably not an Openwrt issue.


Try list address '' to return or list address '' to return nxdomain in /etc/config/dhcp under config dnsmasq

1 Like

dear @frollic, thank for your advice, I tried that, it can run first time, however after that it can access again

Ok, are you sure your clients are using your DNS ?

Does it work when you try to ping ?

1 Like

yess, I'm sure to use this and this is below my list block as your recommendation in "/etc/config/dhcp"
option resolvfile '/tmp/resolv.conf.d/'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option leasefile '/etc/dhcp.leases'
list address '/'
list address '/'
list address '/'
list address '/'

when I test with nslookup, it seem not work, but when I use firefox browser to access, it can access
root@OpenWrt:/tmp/dnsmasq.d# nslookup

Address 1:
*** Can't find No answer

This is on the router, not a client, apples and bananas.

1 Like

on the client device, I used firefox to access these websites, it can access after dnsmasq restart from router

Like i said, does it block it on the client, if you try ping ?

Disabled DoH in the browser?


could you please instruct more about this?

Tried "Firefox disable DoH" at Google ?
Like I said, this is probably a client issue.


hmm, it seems from the client, that it can ping youtube

I think the router is not successfully blocking my target link, it seems not from the client issue

And what is the client OS?
Do an nslookup on the client.

1 Like

i'm using ubuntu 20 LTS

Is Ubuntu then using your DNS ?

1 Like

yess, it is connect with my router by ethernet cable

Answer the question instead.

1 Like