Block DoH and DoT dns on Android using banip

could be, but it'd rule out one possible source of error.

I read mostly through this thread, but I don't quite get what the problem is - what I've understood so far:

The OP wants to resolve a duckdns name. This has, in the first place, nothing to do with which DNS is used, it should resolve in any case.
Or does the OP want the duckdns name to resolve to a local IP address in case he is in the local WiFi?

@andyboeh this one,
it works on all my apple devices/ local PCs, etc...

Just doesnt work on android devices and i have no clue why.

I tried some howtos how to disable ipv6 but seems doesnt work.

strange, then why there are that many threads on the same topic claiming it doesnt work?

OK, got it. I never experienced DNS problems on any of my Android devices (no IPv6 in my case). I do resolve a lot of .lan domains on a regular basis without problems (no rebinding of domains; I access all services exclusively via Wireguard, hence the DNS name is only required for WG to work).

Any chance??

At a guess, PEBKAC.

same here, but I'm (also?) deliberately blocking all outgoing IPv6 traffic.

yet you have three users, right here, all saying it works just fine .... go figure.

@krazeh sorry for a delay, here are screenshots.

is there any way how can i debug that? thanks

How do one debug an error message saying (pretty much) "it doesn't work" ?

thats why i asked what should be provided....

It looks like it resolves the duckdns name into an internal address namely
Have you created any hostname binding in dnsmasq?

yes it does, but its not able to ping it.

This is not relevant to OpenWrt. All lan traffic is going directly from client to server without being processed by OpenWrt.

@trendy pls... just leave this thread...
the previous posts were not addressed to you. thanks

this thread here is to investigate/fix the issue and frankly noone is interested in statements without any evidence ie its not relevant to openwrt.

Gladly! Good luck in trying to blame OpenWrt for two lan devices not pinging each other.

EHM? Who is blaming openwrt? man what are you talking about ... just leave that thread. thanks

OK, so I'm taking the risk of being asked to leave the thread as well: Have you tried to ping by IP address? If it doesn't work (what I assume), then something is wrong with your network configuration that has nothing to do with the DNS resolution - and that has nothing to do with OpenWrt per se as it is not involved in a ping within the LAN (unless you screwed up the WiFi bridge or changed something else you didn't tell us).

Where's the picture of the ping page before you press start?

@andyboeh yes, pinging IP address works, and even shows the domain name... but at the end of the domain name is extra ".lan", ie

I tried to skip wifi bridge ... also same behavior.


  1. screen is pinging ip directly
  2. is ping page before i press start - pinging domain name...


Try adding a . to the end of the domain name so