Block does not list attached usb disk partitions

On my mi mini wifi router, I've passed from PandoraBox (which is an abandoned project with obsolete packages) to Lede (which allows torrents transmission).
Fortunately, contrary to what did happen with Pandorabox, the router led works properly.
But most unfortunately, since there is no out-of-the-box support for usb disks, I've followed the procedure described at without success.
The block info command only gives the following output:

root@LEDE:~# block info
/dev/mtdblock5: UUID="a1699027-d666e730-44c60622-344f332d" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"
/dev/mtdblock6: MOUNT="/overlay" TYPE="jffs2"

The curious thing is that If I mount manually my disk data partition with the command mount /dev/sda5 /mnt/sda5, I am able to browse my disk content. But I'm unable to mount it automatically at the next boot and to share it via samba.
Can you help me to make Lede recognizing my usb disk?
Thank you.

Run block detect > /etc/config/fstab to generate a config with the uuid's of your disks. Edit this file and set up the mount points and enable flag for the ones that you want to mount. /etc/init.d/fstab restart can be used to mount without rebooting.

After doing what you indicated, I obtain a device "not present" advice:

Please post output of /etc/config/fstab

  • What file system is on the partition(s) and do you have the relevant kmods and filesystem packages installed?

NTFS. Surely, I have installed kmod-fs-ntfs in addition to the packages cited in the tutorial page. Via ssh I am able to browse the partition.
'/etc/config/fstab' content:

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '0'

config mount
	option target '/mnt/sda1'
	option uuid '0A92-8778'
	option enabled '1'

config mount
	option device '/dev/sda5'
	option target '/mnt/sda5'
	option enabled '1'
	option fstype 'ntfs'
        option 'options' 'rw,umask=000'

Do you have the following packages installed: ntfs-3g, ntfs-3g-utils?

  • ntfsprogs_ntfs-3g is also recommended (in lieu of ntfs-3g), but not a requirement

What is on /dev/sda1? In your first post you said the data partition was /dev/sda5. Can you manually mount /dev/sda1? Does /mnt/sda1 exist?

A UUID is longer than 8 numbers. That looks like a DOS filesystem label.

installed. no changes.

Please post output of block detect, as like @mk24 mentioned, that's not a UUID, and is more akin to a file system label or drive serial

It's s system partition, I do not know exactly. I added it to fstab because you told me to add the output of block detect to /etc/config/fstab. Anyway, nothing changes even if I delete such a section and leave sda5 section as it is.

# block detect
config 'global'
	option	anon_swap	'0'
	option	anon_mount	'0'
	option	auto_swap	'1'
	option	auto_mount	'1'
	option	delay_root	'5'
	option	check_fs	'0'

config 'mount'
	option	target	'/mnt/sda1'
	option	uuid	'0A92-8778'
	option	enabled	'0'

Option enabled should be 0 for partitions that you do not want to mount. Block detect should have them all at 0 by default.

So you're saying that block detect does not find your /dev/sda5, but you can mount it manually?

That's right.

And I have to notice that in Pandorabox (a customized version of OpenWrt BB) all worked fine without lifting a finger.

After installing libblkid (Mounting USB: block info block detect not able to see exFAT [solved]), block detects all the usb disk partitions.
But now I have another problem so I open a new thread.

Unless you specifically need exFAT, it's recommended to change to another filesystem type as exFAT has always had issues in Linux to due to, if I remember right, it being a closed source, licensed file system by Microsoft.

  • I personally would recommend ext3, or ext4 if you want journaling (it does come with a downside for flash drives), and then use Paragon's Linux FS on Windows
    • It's worth the $20 and comes in extremely handy, especially if you utilize Linux in VMs
      • I believe the free version allows reading from ext2/3/4, however for the ability to write, it must be purchased.

  • The main benefit of exFAT is it removes the 4GB file size limit of FAT32, however NTFS would be preferred over exFAT, as it [NTFS] has solid support on Linux.

I did encounter similar issues. I formatted my USB into NTFS file system. I chose a msdos partition table.
Then using luci, I installed fdisk
if you have only one drive on USB and the df -h does not show the drive either then try
fdisk /dev/sda
it will have one partition (usually) 1.
make a note
then on LUCI, go to System >> Block Mount and manually enter the /dev/sda1 to /mnt/sda1
go the services and network and configure /mnt/sda1 as say...... "myflash"

for testing purpose give user as nobody, code of file and directory as 777 in both.

ssh into the router and chmod 777 -R /mnt/sda1

and restart the router

In my case thsi automagically got the UUID in place and I then went back to the Services >> Share and added users that I needed to control.

I am a NooB and this my be round about and clumsy but it worked for me...
The Guru on this forum and easily refine and shorten my approach..
Good luck.