BIG NEWBIE and not so IT friendly = ) (TL-MR3020 v1)

Hello OpenWrt community
I have a little challenge, and hope you can help me.

I ve been given a TP LINK MR3020 v1

The person who gave me that just told me that the device need to be flashed and that he didnt know how to do it.
I tried few basic test:
manually factory reset the device, tried many "user" tutorial from the online manual etc.
The leds on the device recognize my ethernet cable and my pc detect the device too, but impossible to get in the web interface with the given ip adress of the router.
So i suspect that a custom firmware have been installed in the router But i might be wrong.

Where should i start i just plan to make the device work either on wrt or with the factory firmware, any help is welcome.

Im with a windows pc and i ve done few very simple thing like home made nas on lubuntu but im definitively not an it guy.

Many thanks in advance

Install wireshark, plug into one of the LAN ports, start a capture, and then plug in the power cord to the router. Watch for what it does and report back.

It should do one of a few things, one of which could be: Boot normally and tell you what it's IP address is.

1 Like

Can you login via ssh?

1 Like

Very nice little box. In the old days it was used to clone pineapple wifi boxes, with a RTL8187 usb adapter. Or at least, people was trying to do it. Therefore, you might have a bricked device.

First thing:
try and see if you can access SSH through something like Putty. If you still can, the box is in semi-working order. You can easily reflash and be (almost) good to go. I understand if you want a recent version (like 19..) you might find a trunk without preinstalled LuCi, which is an hassle. If you can live with a 17.01.7 build, it is waiting for you.
Second thing:
if SSH is not giving you any hint of life, a serial console and TFTP flash method is what you need, similarly to this case.
It might be overwhelming, but I suggest to try. Electronic pollution is a serious matter, and your little box used to be a rare gem, some years ago. It deserves some love.

Anyway, long post.
Have a look at this very informative page full of good informations, and report back if you manage to access SSH on the box. Sometimes things are easy. Some other times are not. Reverting to the original fw for example, in your case, needs a hack to the OEM fw. I checked it for you. I found the stripped firmware, to revert and eventually start from the beginning with owrt.

Ah, I'm a noob. Someone more clever than me might be on the way.

Enjoy tinkering,


Thank you everyone for your answer glad to know that the community is active = D .
Its the first time i use wireshark and an ssh client so sorry if i dont use these tool well = )

Here are some wireshark screenshots.
my pc is connected to the net by wifi, i have only one ethernet cable linked from pc to the MR3020

Here is how i try to connect via ssh with putty,

the result*

i ll check further tutorial with putty.

Thanks for your help = D

I think the IP is, try to set your NIC address to and then try putty (telnet and SSH) to Also try in your browser with http and https.

If the rest of that fails, then you have to run the capture during boot and see if the device makes any attempt to load firmware from a tftp server.

Tip, do not have any other networks connected (wifi, etc), and do not set a default gateway.

1 Like

Thanks !
Ok i ve put and i got

I think its a good new for a first contact =D
i tried to log in with admin as username and password it didnt work =P

i will try your other tips tomorrow

Anyway thanks guys for your fast replies
= D

I'd try the username root instead of admin


This is a 4/32 device.
You should read the big infobox at the beginning of and draw your own conclusions if it is worth wasting your time with a device which is underspeced for current OpenWrt.

Sidnote: I have started with OpenWrt 8 years ago with a MR3020 and quickly realized that it has too little flash + RAM for my usecase.
Rest assured, the situation regarding flash + RAM hasn't gotten any better during the past 8 years.


Hello, i dont necessary need openwrt on this device, i just want to make the router works, a flash to the default original tp link firmware is totally ok for me, since i just need the basic fonctionnality of the device = )

root /admin didnt seem to work




Yes, follow those steps, but use the fw I linked to you earlier.

Still, I don't know how you can flash if you can't access SSH, but maybe failsafe access is going to help you.

P. S: an old version of owrt is always 1000s times better than a stock fw. Go for 17.01.7 stable release, with Luci installed. You won't regret.

I did a factory reset even before trying to access it with putty so i guess the current password is restored to default value (i dont know if its an openwrt firmware or not inside).

I cannot do any command from the terminal because it keeps asking a password that i dont know, the username can be a root or a blank value.

so i dont know if i can do any failsafe command, or should i press the button with the putty terminal opened? will it interact like this?

Thanks again

Since it's running a SSH server, we'll assume that OpenWrt is installed. The factory firmware does not have ssh. If it does not respond to, it may be a trunk or snapshot (development) version of OpenWrt or a custom build to save space.

The default OpenWrt IP is, so it has not been reset to defaults. Read the device page posted by @bright_plastik especially the part about reset and failsafe mode.

Basically for failsafe mode, plug in the power and exactly as it reaches the point in the boot sequence where the LED flashes fast, repeatedly press the button or switch. If you were successful, the LED will start flashing really fast and keep flashing that way. Then you can log in at with no password (old versions use telnet instead of ssh, again with no password).

When you don't know the password and can't reset to defaults, you will need a serial connection to recover. It is probably too early a model to have TFTP recovery in its bootloader, TP-Link did that later.


in the @bright_plastik link failsafe section
i read

  • Power on the TL-MR3020

  • When the WPS button starts to blink:

    • on AA (Attitude Adjustment / 12.09) push the WPS button;

    • on BB (Breaking Barrier / trunk) move the sliding switch quickly from one side to the other.

    • on CC (Chaos Calmer) ??? not sure try any switches or buttons ??? repeatedly is fine. 12/11/2015: repeatdly pushing the WPS worked.

  • Do this until the WPS button starts blinking faster.

  • The device is now in Failsafe-Mode

  • Connect the TL-MR3020 to your computer via ethernet

But what AA BB CC means? Is it the led on the box?


failsafe reached wps button is blinking very fast

AA, BB, and CC are abbreviations of the codenames for old OpenWrt versions.


Ok i ve tried few things i cant access anything like earlier from the ssh anymore as it is mentionned on the section ( but im really not sure ) should i follow this now ?


If it's an old version you will get "Connection refused from" when trying to ssh in failsafe mode.

If it does that you need to use a telnet connection to instead.

Once access is gained, I'd flash it back to stock and use it that way, or give it back to the guy you got it from. As @tmomas said, a 4/32 device does not work well with modern OpenWrt. You'll constantly be needing to work around memory limitations.

1 Like

Excellent @wiileewaller! You're almost there.
Now, as @mk24 told you, you have to use telnet instead of ssh. Nothing different, it is only a different and less secure protocol, but does the job exactly the same way.
Get a copy of the factory.bin
As you quoted, follow the instructions using mongoose and in a few minutes you should have a good little box waiting for first LuCi access.
Once you get failsafe don't rush. You have all the time to launch the commands.

Happy tinkering!

Here is how the router is blinking.

The setting:

But i got a
Putty fatal error windows with: Network error:no route to host
either with ssh and telnet