Best way to force dnsmasq to provide name server in DHCP response

Hello,

as OpenWRT Adblock package enables to bypass Adblock for certain client IPs only with BIND DNS backend, I configured BIND and set dnsmasq's DNS port to 0 as advised. Since then dnsmasq stopped providing name server in its DHCP responses.

I made a workaround by explicitly specifying

dhcp-option=5,192.168.1.1
dhcp-option=6,192.168.1.1

in /etc/dnsmasq.conf, but I am worried that some change to dnsmasq configuration will overwrite it.

Does anyone have a better idea?

1 Like

Providing custom DNS with DHCP

4 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.