Best roaming with Netgear R7800 - Using DAWN?

I think I'm getting to the point where I need a little help.

I am still 12 days on a yard where I would like to replace several AVM fritz.box router with several Netgear R7800 router. There are 4 routers to be replaced, I think the positions are chosen quite well. All router are connected with 1GB-LAN cat 6.

What has worked well so far:

  • flashing all R7800 routers with the latest openwrt stable by this wiki-install
  • setup the main R7800 router, which gets internet through the WAN port
  • setup the 3 other R7800 routers as "dumb ap" with roughly the following settings (but disabled 5Ghz for testing just 2.4Ghz raoming in first place):
root@OpenWrtAcpo1:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option cell_density '0'
        option country 'DE'
        option htmode 'VHT40'
        option channel '48'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option dtim_period '3'
        option key 'SuperP@s$w0rD'
        option ieee80211r '1'
        option mobility_domain '123F'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option encryption 'sae-mixed'
        option ssid 'WLAN-G'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'DE'
        option channel '11'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'WLAN-G'
        option dtim_period '3'
        option key 'SuperP@s$w0rD'
        option ieee80211r '1'
        option mobility_domain '123F'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option encryption 'sae-mixed'
#       option bss_transition '1'
#       option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0'
        option ieee80211k '1'
        option rrm_neighbor_report '1'
        option rrm_beacon_report '1'

With this I tested with an Android 13 (LineageOS) phone and an Ubuntu 20.04 laptop the jumping to the stronger dumb-ap. It was not good. Sometimes I couldn't even get a "jump" when I was 50 centimeters away from the router, even though the currently connected dumb-ap had really bad values.

So I looked for a way to enable 802.11k or 802.11v and found DAWN.
I installed it on all routers and followed the openwrt instructions here. Unfortunately I could not set the following two options in my /etc/config/wireless:

       option bss_transition '1'
       option wnm_sleep_mode '1'

I read it is because of wpad and that you need wpad-full. Currently installed is wpad-basic-wolfssl. In one of my dumb-ap's I uninstalled wpad-basic-wolfssl and installed wpad. This resulted in many syslog errors. Then I read that you can install hostapd instead of wpad to get a full wpad. Unfortunately this caused the same errors in the syslog.

Unfortunately I am now unsure what to install to get DAWN running with the bss_transition & wnm_sleep_mode options.
I think DAWN could be a good solution for me. And yes. I know that romaing is not an easy topic. I also know that each device decides for itself when to change the access point. My goal is simply to have the best possible roaming.

Any help from the community will be appreciated. Thanks in advance.

Your WRTianer

why not simply use 802.11r ?

802.11r is not working good enough. I will qoute myself from first post:

With this I tested with an Android 13 (LineageOS) phone and an Ubuntu 20.04 laptop the jumping to the stronger dumb-ap. It was not good. Sometimes I couldn't even get a "jump" when I was 50 centimeters away from the router, even though the currently connected dumb-ap had really bad values.

sorry, only read the text, not the conf, where you actually posted 11r config.

Bring it to run :star_struck:

Perhaps the way I uninstall or install wpad-wolfssl or wpad was wrong.
You need a full wpad, I read that in the documentation to install DAWN but I thought it was resolved with wpad-wolfssl.

When uninstalling the my basic wpad version, I remove the option "Automatically remove unused dependencies". When installing the new one, I choose:
"Allow overwriting conflicting package files"

Perhaps that fixes my missing wifi issues before. I dont know.

The only thing I am missing was:

  • WPA3 is missing in the dropdown in the wireless radio settings

But I fix this by uninstalling wpad and use wpad-wolfssl (not the basic variant)

The transition from 2.4Ghz to 5Ghz and to other dum-ap's works pretty well now. And that also makes sense. I am now providing 802.11k & 802.11v to the WLAN devices in addition to 802.11r. So they can better decide for themselves when they should switch.

Your WRTianer

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.