Best Build for NBG6817 (Zyxel Armor Z2)

Hello All

Sorry to creating this thread but I need your helps.

I am not new on Openwrt I was using it for a while with Xiaomi 4a Router but Armor Z2 was on a big sale so I purchased it.

We are using internet mainly for gaming, IPTV, video conferencing and daily work related browsing.
I have tried first standard firmware from openwrt but I had some issues. I installed some packages like sqm, dnscrypt and adblock home but somehow wan connection was going down on clients. 10minutes distruptions and connection issues for every 2-3 hours. Dont know its related but I saw too many ath10k related topics and might be the reason

So I installed acwifidude's build and it works great but sqm doesnt work. sqm is important for gaming for me because gaming + video conferencing causes lag issues.

I have 100/5 connection via cable with Docsis 3.0 modem.
Modem works in bridge mode.

So my question is here which build should I go ? I am seeing lots of ipq806x topics but it seems there are few Armor Z2 users.

Thank you for your answers.

Official 22.03 build and install luci-app-sqm

EDIT: oops sorry I missed that part that you've already tried it.

Have you checked all your config? and any log when your connection was down?

Not to sound too rough, but did you read the setup instructions in post #2 of the NSS build thread? It states how to setup NSS SQM. You can’t use Luci SQM to do it, but rather put it in your startup script. It works like a champ.

I’ve used @ACwifidude NSS build on multiple R7800 and also an NBG6817 without issue and would highly recommend it.

I wasn’t sure whether hnyman’s build for R7800 would run on the NBG6817 but I guess it doesn’t. I think you could also try the official release for your specific device and add the packages you need with the firmware selector. If you don’t need special tweaks just a particular package selection, then the firmware selector can build it for your device. Building takes about a minute or so, flashing your device perhaps a minute longer.

Depending on your client devices, you could choose to let the firmware selector build with the “normal” ath10k driver/firmware instead of the ath10k-ct driver/firmware. Simply customize the installed packages list to do that.

I think you are mentioning about this right ?

4. Custom NSS fq_codel startup script if SQM is desired (below is set to 900/900). Recommend setting to 5% below your ISP provided speed and then adjusting from there as per your testing. Maximum is ~900Mbit.

these scripts doesnt work unfortunately for me;

root@GuvenRouter:~# tc qdisc add dev nssifb root handle 1: nsstbl rate 90Mbit bu
rst 1Mb
RTNETLINK answers: No such file or directory

I don't know exactly why but v19.07.x feels smoother than the latest release. However, I would never recommend people to use outdated firmware for obvious reasons.

ulpian

Yes - that is the instruction I'm referring to. You need to edit your startup script to include that. You can add it from within Luci under System > Startup > Local Startup. You need to remove the hash # for it to enable... leaving the hash tells Linux (openwrt) to ignore that line.

Unfortunately that doesnt helps.

I am getting these errors;

Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: FAILURE (2): /sbin/tc qdisc add dev eth0.2 root handle 1: nsstbl rate 4000kbit burst 1749
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: LAST ERROR: RTNETLINK answers: No such file or directory
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: FAILURE (2): /sbin/tc qdisc add dev eth0.2 parent 1: handle 10: nssfq_codel limit 1001 flows 1024 quantum 1514 target 5ms interval 100ms set_default
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: LAST ERROR: RTNETLINK answers: No such file or directory
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: FAILURE (2): /sbin/tc filter add dev eth0.2 parent 1:0 protocol ip prio 0 u32 match ip protocol 1 0xff flowid 1:13
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: LAST ERROR: RTNETLINK answers: Invalid argument We have an error talking to the kernel
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: FAILURE (2): /sbin/tc filter add dev eth0.2 parent 1:0 protocol ipv6 prio 1 u32 match ip protocol 1 0xff flowid 1:13
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: LAST ERROR: RTNETLINK answers: Invalid argument We have an error talking to the kernel
Sat Nov 12 20:41:18 2022 user.notice SQM: WARNING: sqm_start_default: nss.qos lacks an egress() function
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: FAILURE (2): /sbin/tc qdisc add dev nssifb root handle 1: nsstbl rate 90000kbit burst 11250
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: LAST ERROR: RTNETLINK answers: No such file or directory
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: FAILURE (2): /sbin/tc qdisc add dev nssifb parent 1: handle 10: nssfq_codel limit 1001 flows 1024 quantum 1514 target 5ms interval 100ms set_default
Sat Nov 12 20:41:18 2022 user.notice SQM: ERROR: cmd_wrapper: tc: LAST ERROR: RTNETLINK answers: No such file or directory
Sat Nov 12 20:41:18 2022 user.notice SQM: nss.qos was started on eth0.2 successfully

Something must be amiss with the latest Master. Wasn’t aware - my apologies. Have you tried the 22.03 branch?