Belkin RT3200/Linksys E8450 WiFi AX discussion

If you have flashed anything while running the UBI recovery on top of a non-UBI (ie. stock) bootchain, the only way to recover from there is by using the console on the serial port inside the device.
I start to wonder if it was a good idea to recommend everyone to do the full backup. The risks of getting it wrong may well outweigh.

2 Likes

The same thing happened to me when I tried to go back to the stock firmware after installing recovery.itb to do the full backup.

I did this to go back to the stock firmware:

  1. Unplug the router for 30 seconds.
  2. Plug in for 2 seconds and then unplug again.
  3. Plug in and now the router booted with the stock firmware.
2 Likes

The only thing i flashd was

openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb

Then because I couldnt get oem to boot after power cycling I flashed via initramfs-recovery

FW_RT3200_1.0.01.101415_prod.img

Now my router flashes every two seconds :sweat_smile:

1 Like

Capture d’écran 2022-01-06 à 14.50.52

i everybody i has 10gbps and 10Gbps

for the moment but my laptopt has only 1gport ethernet i will test now in swiss country

Capture d’écran 2022-01-06 à 15.07.17

2 Likes

Hi, I am planning to buy two Linksys E8450 to setup a 802.11s Mesh network with 802.11k/v/r Fast Roaming. However, I am not familiar with OpenWrt so I want to ask some basic questions:

Which image I should use to flash to OpenWrt firmware?
Do the Linksys E8450 with OpenWrt support 802.11s and 802.11k/v/r?

As I will flash the routers using non-UBI method (as the router is in warranty), I would like to know the correct method of flashing it in the vendor firmware web admin page. I see there are several image available in the download page.
https://downloads.openwrt.org/snapshots/targets/mediatek/mt7622/

Thank you.

If you want to keep the vendor layout, because of a problem with the SPI-NAND driver, you first have to flash openwrt-mediatek-mt7622-linksys_e8450-initramfs-kernel.bin using the vendor Web UI. Then connect to the router using ssh root@192.168.1.1 after if comes up with OpenWrt initramfs and from there use sysupgrade to flash openwrt-mediatek-mt7622-linksys_e8450-squashfs-sysupgrade.bin.

5 Likes

Also 802.11s is broken on snapshots on this router for many months now. Just use WDS.

3 Likes

Thank you for you reply, Lynx.
I will consider another product as 802.11s is a requirement for me.

I managed to load Uboot on Putty but what option do I press? I just wanna flash this to go back to stock and try flashing OpenWrt again.

 1. System Load Linux to SDRAM via TFTP.
 2. System Load Linux Kernel then write to Flash via TFTP.
 3. Boot master system code via Flash.
 4. Boot slave system code via Flash.
 5. System Load U-Boot then write to Flash via TFTP.
 6. System Load U-Boot then write to Flash via Serial.
 7. System Load ATF then write to Flash via TFTP.
 8. System Load Preloader then write to Flash via TFTP.
 U-Boot console

I don't know what option to press. I read somewhere in this thread I have to press two? Once I do, I have to have a filed called "lede-mediatek-mt7622-MTK-AX3200-MT7531-squashfs-sysupgrade.bin"
where do I even find this file?

1 Like

Set your computer (i.e. tftp server) IP to 192.168.1.254 and rename the factory firmware to "lede-mediatek-mt7622-MTK-AX3200-MT7531-squashfs-sysupgrade.bin". Then use option 2.

2 Likes

Thank you so much! Got it back to stock.. Linksys stock firmware. Now my problem is that I'm using an RT3200 not the linksys version lol

1 Like

Then flash the belkin version :slight_smile:
LE: just noticed they are the same ... If it does not show Belkin then it seems you don't have the original mtd5 "Devinfo" partition.

2 Likes

The thing is I am flashing it, yet it somehow Linksys setup page still manages to pop up, Anyway, I'm preceding to flash OpenWrt! Thank you!

EDIT: what does "mtd5 "Devinfo" partition" mean?

1 Like

Here is the description of the original and new (UBI) flash format https://openwrt.org/toh/linksys/e8450. The original mtd5 keeps some information like manufacturer, version, serial number, mac addresses, default ssid, passphrase, things that are used by the factory firmware. This is not used by openwrt.

1 Like

Is there no way to do this without opening up the router? E.g. just using tftp server? Can that not be facilitated somehow? I feel for all these individuals having to crack open router just to flash stock firmware.

I don't know for sure. If the factory bootchain is intact, maybe there is a method to trigger the automatic loading by tftp. I think I remember someone mentioning that you need to press the reset button while the device is booting (not before powering) and having the tftp server on LAN1 but I did not test it as mine is already on UBI bootchain with no intention to revert...

2 Likes

What actually is the bootchain? In my own I installed the initial installer but that got upgraded and I installed the upgraded installer. What does that mean for my bootchain? Not that I would ever want to go back to stock, but I'd still like to try to understand the concepts.

Bootchain is the collection of partitions that loads the operating system (Preloader + ATF + Bootloader + Config -or- bl2 + fip, see the above link with partition structure, Factory is usually not touched). Installing the UBI variant replaces the original partitions mtd0..3 with new partitions mtd0..1. You may still have the original boot partitions in the new ubi0_3 partition, depending on the procedure you've followed. To verify, connect with ssh the router and execute these:

mount -t ubifs /dev/ubi0_3 /mnt
ls /mnt

If you have here mtd files then transfer these to your computer and store them safely. But if you installed a second time the UBI installer from Daniel, they will be replaced with the UBI partitions, so the initial backup is overwritten.

2 Likes

Thank you for the insights.

I kept a backup of those before overwriting I think.

Do these contain info unique to router like wireless calibration data? Or will they be same for every RT3200? Can someone just use backup created by another?

Please can someone else confirm if 802.11s is working or not in the RT3200 at the moment? Last I checked not, but now I'm worried it's just a config issue.

For the benefit of anyone else concerned about wireless connectivity I can confirm that WDS works perfectly and I see speeds in excess of 300 Mbit/s without ramping up power.

Anyone know the max tx power these devices are capable of? I haven't tried ramping that up.