Belkin RT3200/Linksys E8450 WiFi AX discussion

I'm trying to revert back to vendor stock firmware. I restart and use the reset button got into openwrt failsafe mode I think. I was able to mount ubi0_3 and found mtd0, mtd1 and mtd2 files inside. After copy them to /tmp and umount partitions, I can't use mtd write to get these into mtd. Btw how can I flash stock firmware after the mtd write?
Here is more information
There is no document on how to revert back to stock I can find. any help is appreciated.

root@OpenWrt:/tmp# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                   241.2M     17.3M    223.9M   7% /
tmpfs                   241.2M      2.8M    238.4M   1% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev


root@OpenWrt:/tmp# ubidetach -d 0
root@OpenWrt:/tmp# ubinfo
UBI version:                    1
Count of UBI devices:           0
UBI control device major/minor: 10:63

root@OpenWrt:/# mtd write /tmp/mtd0 mtd0
Could not open mtd device: mtd0
Can't open device for writing!

If you converted yours to UBI, then the only way back from what I've been reading is though JTAG process. That's why I am holding off converting mine to UBI a bit to see to see if it becomes possible again to flash non-ubi builds. I would like to avoid the one way street UBI brings if necessary but if I want openwrt installed, I may have no choice.

Maybe kmod-mtd-rw is not installed?
LE: So I was curious and set a network card with ip=192.168.1.254, then I started tftp to serve the new openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb file and after reset+power the router loaded this new recovery. There is no mtd-rw.ko file in the /lib/modules/5.10.72/ folder, and I think mtd cannot write a partition without this module. If you don't have this file I guess you can download the installer from the latest snapshot build (https://downloads.openwrt.org/snapshots/targets/mediatek/mt7622/kmods/5.10.72-1-a3398c593d3440164c247a13bc67d164/kmod-mtd-rw_5.10.72+git-20160214-2_aarch64_cortex-a53.ipk), copy it to the router /tmp and install it with opkg install /tmp/kmod..etc...etc..a53.ipk. Then I think you need to execute insmod mtd-rw.ko i_want_a_brick=1 and only after that you can use mtd to write. These instructions are from some of my old notes when I was dealing with Atheros art partitions, I did not test them with RT3200.
After puting back the original bootchain, it looks to me that the router will need the file named "lede-mediatek-mt7622-MTK-AX3200-MT7531-squashfs-sysupgrade.bin" served by tftp, so I suppose you can rename a factory firmware, start the router again by reset+power and try it.
Again, I did not test any of the above, but maybe Daniel can correct me if I'm mistaken, there is a strong risk to brick the device.

On the other hand, I noticed that simply booting the router by tftp from the new recovery, it is not automatically written to the coresponding partition. I looked at what install.sh is doing and with these steps I updated the recovery:

  • copied the new openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb file to /tmp
  • executed ubiupdatevol /dev/ubi0_2 /tmp/openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb
    Rebooted again with reset+power and the new recovery came up!

You can (temporarily, in initramdisk) install the package kmod-mtd-rw using opkg.
That will unlock the volumes and give you read-write access.

I upgraded to v0.6.0 of the dangowrt installer, but now the highest available 5Ghz WiFi channel is 144 in Luci. I was using 157 before the upgrade. Anyone know how to restore the other channels?

EDIT
Oh nevermind, you have to set country code

I am not sure if I am the only one experiencing this issue, I see intermittent packet drops (5-10 packets) in the network and it's not just happening from one device. The issue is only affecting devices connected to wifi and not the through LAN. If I run a continuous ping to E8450 from different devices, I see packets getting dropped at different times. This doesn't happen when the devices are connected to the LAN and so it's something with the Wifi.

So @daniel to confirm for the many of us on v0.5.3 - your recommended advice is do nothing and just keep using the attended sysupgrade?

2 Likes

hello I do not know if I have already updated via 0.5.3 my openwrt or an older version if I reuse 0.5.3 recovery when I had already used it there will be a problem? thank you

No idea. We are all at the mercy of the vital scraps that @daniel feeds us as we scurry around underneath the table.

Absent fuller documentation or explanation, an understanding of the UBI layout / boot / recovery / installer aspects is surely beyond a significant proportion of the user base. For example, I am completely lost about the driver / error checking / calibration data / OEM reading / writing aspect.

Above it is specified:

What does that mean - 'just replace the recovery image'? I mean it obviously means replace the recovery image. But how do we do that? What is the recovery image actually? Are there two images on every device - one recovery and one full? Is the latter what sysupgrade is?

openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb
openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb
openwrt-mediatek-mt7622-linksys_e8450-ubi-squashfs-sysupgrade.itb

If some kind soul were to provide a write up about these aspects I think that would benefit many.

1 Like

Thank you guys.
I was able to successfully write mtd0, 1, 2 with the one in ubi0_3. I also ubiupdatevol /dev/ubi0_2 /tmp/openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb

However in the recovery luci the model still says UBI, the ubi are seen in /dev/ and I can't get out of initramfs after force upgrade a factory image.

Am I back on the stock vendor's boot chain?
I previously updated uboot for newer openwrt version, does ubi0_3 got overwritten if i'm updating from a ubi to another ubi? (I was using 0.52 then i updated to 0.53 to use [openwrt/openwrt@050621a].

Thanks!

Strange behavior today. I installed with 0.5.3 a little bit ago, and played around for a bit before I got started since I’ve never used openwrt. Then, after the mt76 update, I performed an attended system upgrade with no problems. I set up my config and ran the router for a week with a 2.4ghz N network with no issues. I then decided to get rid of my old router and switch over to this one permanently. When doing so I set up an AX network and it was working for a few minutes. Then, yellow light on the internet led, and off to recovery mode.

So time to start over. Except now, I cannot do an attended sysupgrade. Snapshot downloads, install begins, then yellow light on the internet and back to the recovery snapshot.

Any ideas?
Thanks

Update:

I decided to unplug the router and try again just for fun. When I turned the router back on, it was on the latest snapshot.

Update 2:

Seem to be short my 5ghz radio now. Planning on messing around more tomorrow.

The second part from my message was about my experience with updating the ubi recovery (I said "on the other hand" :slight_smile: ) and not related to the "back to factory" procedure. The original vendor flash layout is not ubi-based and does not include a so-called "recovery" partition, it is "dual-firmware".
There is an OpenWRT page explaining this: https://openwrt.org/toh/linksys/e8450
What I've recommended after installing the factory bootchain, is to use the original factory firmware, rename it to lede-mediatek-mt7622-MTK-AX3200-MT7531-squashfs-sysupgrade.bin (I saw it in the U-Boot code) and serve it by tftp to the factory U-Boot. I am not sure if U-Boot will automatically load and flash this file or you need to use the serial console, this depends how it is programmed, it is just a hunch from my times debricking Atheros-based routers.

As you have re-run the installer, what you find in boot_backup now is the bootchain of the previous installer run (ie. UBI, but pre-0.5.3).

... that explains why he managed to boot the flashed UBI recovery.... unfortunately, if @indarkness does not have a previous backup of mtd0-3 in other place, it seems he lost the factory bootchain. I have the files from my RT3200 backup, do you think they can be used for his (another) router?

May I suggest to update your instructions explicitely mentioning that re-running the installer will replace the factory bootchain backup? It is very important, I think...

Yes, the files are compatible even between RT3200 and EA8450, you may have to edit factory and devinfo to put back the right MAC addresses.

Ok so I tried to use the reset button to return to the recovery image. Seems like that just resets the settings on the latest snapshot I downloaded. Still no 5 ghz radio.

Probably the kernel has crashed while running production firmware which (deliberately) results in the bootloader booting into recovery until crash logs in /sys/fs/pstore have been removed.
Please check if you find anything there and if so, please post the content of the files and delete them from /sys/fs/pstore.

So I was moving a little quick and ended up reflashing manually with the prebuilt sysupgrade file. 5ghz radio returned. Attended sysupgrade to newest snapshot and 5ghz radio remains. I’ll reconfigure and if I crash again with AX I will certainly upload any information from pstore. Thank you!

1 Like

me too X doesn't work i don't know why :confused:

where i recupered ps store ?

ok i has found just tape the command and AX appair in wireless :wink:

/etc/init.d/network restart

cheers

I finally got my Belkin RT3200. I like others cannot flash from the stock firmware. I am nervous about flashing the ubi version and not being able to return to stock. I have never used a serial cable before. Could someone link me to one that will work so that way I can return to stock if need be for testing purposes? I also want to get one in case I need to for some reason. Better safe than sorry I was always told.

Is there a guide on how to flash the ubi firmware? If so can someone link me to that? I am going to give it a shot. I want to make sure I have accurate information and up to date. I have been fallowing the discussion as much as I can but I have to admit 719 comments is a lot to read through as busy as I have been. When I go to install the ubi firmware will it create the necessary files for me to go back to stock with the serial cable?