Belkin RT3200/Linksys E8450 WiFi AX discussion

I have tracked down this issue to my laptop which I have in the same desk as the Belkin RT3200.

When the laptop runs Linux I have no problems at all but if I boot into Windows then I get slow internet on my Galaxy S10e.

The laptop has a Qualcomm QCA61x4A card.

Definitely share what hardware you end up trying out.

Folks trying external antennas have had mixed results

Not sure this is the right place. Got a couple of RT3200s. Generally working great as APs.
Have a Drayton Wiser central heating hub that can't get an IP address when connecting through a RT3200 AP or, as I've just tested, directly to the RT3200 configured as a router.
tcpdump shows a DHCP discover packet from the hub and then an offer packet going back to the hub but no subsequent request from the hub.
Other devices all work fine. The difference between the Wiser hub and the other devices is that the hub requests a broadcast response in it's discover message whereas the other devices request / get a unicast response.
The hub can get an IP address from my old Netgear WNDR3700.
Any suggestions? I guess this could be a 21.02 vs 19.07 thing?

1 Like

What's the latest regarding hooking these up together to form wireless mesh? Does it work? What is the simplest way to do this?

Also for cloning existing configuration to new router is there a way to download firmware with packages installed on existing system for flashing to new system? Like with the LuCi unattended sysupgrade can you request download of firmware rather than flash?

I used this tutorials, worked out of the box

you can also clone the backuped config to other routers, but be aware, that if you use fixed ips for the interfaces, that you have to be sure, to which of the ones you are connected after applying the backup.
best

Peter

2 Likes

Since a week I've got similar issues with two clients. Setup is two dumb AP (e8450 and a RT3200) and a ISP router serving DNS and DHCP. Struggling with it for a week to find a setup which works. Then I finally set lan interface to explicitly set broadcast IP as it was greyed out in Luci. It is default perhaps but after applying things explicitly option broadcast xxx.xxx.xxx.xxx was added in /etc/config/network in then lan interface section and things are working as expected again. When I revert this change I can reproduce the issue again.

As you mentioned broadcast request it might be something similar

I think I broke my Belkin RT3200.

At first, I tried to select the file openwrt-mediatek-mt7622-linksys_e8450-squashfs-sysupgrade.bin as the update file for my router, that did nothing, then I tried using openwrt-mediatek-mt7622-linksys_e8450-initramfs-kernel.bin, and now my router is broken I think. Would someone please help me? I was going to use this, but the script didn't work.

I can connect to the router, but the internet doesn't work. I can't ping the address. On the router there is a flashing power light and the internet light isn't on at all. It worked before with the default software. I tried resetting it (holding the reset button for 20 seconds) and that did nothing. There is also the "Post OpenWrt "recovery mode" process" from the script I didn't use, I tried holding down both buttons for 49 seconds and nothing happened.

OS: openSUSE Tumbleweed with KDE Plasma
Hardware: Belkin RT3200
Software Version: Snapshot (I think)

here is what happened when I tried the script, by the way.

Is there anyway to fix this? Should I buy a new router?

ignore this... It seems while re initializing things service restored shortly but over time I got again clients which are intermittently not associating.

You are trying to acces 192.168.1.1. from 75.111.26.121. Set it manually as indicated in step 2 in the provided instruction and go from there.

Please install libfdt-dev and cmake on your host, they are needed to build a tool which is needed to generate the installer.

1 Like

I don't know how to do that, I will try to look up a guide or something.

Edit: is this assigning a local static IP? Is that what you mean? 75.111.26.121 is my public IP, is it also my private IP? I'm trying to use commands to see what my private IP address is and I can't figure it out, so maybe they are the same? But that seems really weird.

Edit: I found a guide to change it using ifconfig, but that command doesn't do anything on my PC, do I need to install a package or something?

I got cmake but I can't find a provider for the libfdt-dev package on openSUSE.

Edit: I found libfdt-devel and libfdt1, will that work?

I just loaded my new rt3200 with OpenWrt SNAPSHOT r17598-ac03e24635

I am unable to see the switch option under LUCI....anyone know if this is a bug or I am missing something?

Yes, libfdt-devel sounds good.

If you are looking for Vlans you will need to install kmod-ipvlan package and then goto Network>Interface>Devices to configure it.

1 Like

Thank you bobbythomas, I will give it a try....I miss having the switch option, perhaps it will be reenable in the near future for this device.

1 Like

@daniel are the switch LEDs configurable here?

If you are upgrading snapshots using Attended Sysupgrade, you can select the ipvlan package there. Else you will need to install the package manually after the upgrade.

1 Like

Okay, thank you. So now I know what I should have done. Do you have any advice for fixing my current problem? Should I just buy another router and start from scratch?

inez has been getting help on Reddit as well but not sure if following through.
Did you set your IP to static as suggested inez?
As I said ethernet port may not be eth0, on my msys2 system on windows it's called enp2s0 for example. The screenshot you posted has a similar format to this which is why I mention it.