Belkin RT3200/Linksys E8450 WiFi AX discussion

For an already Openwrt running RT3200/E8450;
Are there any advantages to "upgrade" to this new recovery image?
And if yes (or just as information); What are the steps to be taken?

I've never entirely understood the significance of the various releases here:

So, for example, release v1.0.0 states:

That sounds pretty significant. What about those of us who installed releases prior to v1.0.0 (many are probably around v0.6.2 or so). Does that make our devices more vulnerable to 'bad blocks'?

So now there is the v1.0.3 release:

Is the recommendation only to update OpenWrt and not try to upgrade the recovery / other aspects covered by these releases?

Probably I lack an understanding of what the installers does. It converts the layout to UBI and then installs recovery, ARM trusted firmware, U-boot and OpenWrt? Wouldn't it desirable to facilitate a way to upgrade recovery, ARM trusted firmware, U-boot without going through the full installation from scratch / UBI conversion process?

Am I the only one not entirely understanding these things?

Curious about this too!

The documentation does clearly say: " WARNING #3 The installer is meant to be executed only once per device. Executing the installer more than once should be avoided! U.."

But you're right.. should UBoot be updated via another method?

And what about the recovery / ARM Trusted Firmware?

Guys, something happened to my RT3200 today.

I have it set up to reboot daily at 3:30 am. Never had a problem with this since I use OpenWRT from my WDR4300, next my Redmi AC2100 and now my RT3200.

However, this morning I found out that my 5G radio was off. Tried wifi reload in SSH and then restart the 5G radio and it didn't work. I had to reboot the router.

Oh, and also I faced the problem I mentioned earlier: when I click reboot on System > Reboot on Luci, the router just shuts down (all leds off), it doesn't come back up. I had to use the rear switch to off, wait few seconds, and turn it on.

What should I do when something abnormal like this happens? On the system log I don't see anything. On the kernel log before reboot? IDK if there's a wiki about this to diagnose our devices before askig for support here.

Thanks in advance!

I just a couple of these to use as dumb APs basically - however, I am having the darndest time setting them up. I try to follow the instructions on the dangowrt page, but am hitting roadblocks.

If i try to exit out of the wizard early like is suggested, the router goes to the login page and will not let me in - if i enter the admin password it flashes to the admin page in the router, but then redirects me right back to the login.

If I complete the entire wizard, set the ssids and password, it takes me to the login page, and does the same loop.

I'm stumped at how to get past this, i know that if i enter a wrong password the login screen tells me that, so i know the password is right, i just am stuck.

All i want to do is install open WRT on these, but I'll just send them back if they are such a pain in the ass. I can't even set them up using the belkin firmware.

Hopefully I am missing something stupid, thanks in advance,

@odrt gave a solid reason a couple of posts above.

You don’t HAVE to keep the recovery updated, but it certainly doesn’t hurt. To update just flash the installer like you would any other firmware update via the web GUI.

You mean this one?:

@hnyman linked steps to update the recovery instance:

Kinda sounds like your browser. Try turning off add blockers and using a different browser.

Its been a long time since I saw the original firmware's screens so I don't remember it logging in required a special trick.

Failing that, you could flash via serial & tftp That's what I wound up doing in the end. Google "rt3200 how to open" and you'll find some you tube videos on how to it. Then, you just need a 3V serial port adapter.

Its worth the effort as these are one of the most stable, well supported openwrt devices out there right now. Another option that is straightforward to flash is the the wax206, if you can find them. It uses the same chipset as the belkin but has better antennas and a 2.5Gbps wan port.

1 Like

Yes it was the browser. I was using chrome, I tried Firefox right after I wrote my comment and that worked, flash was easy after that. WiFi seems stronger than my orbi rbr20 that this will replace, and sitting upstairs while testing it the status panel reported my link was 900+Mbits. So in theory much faster than the orbi as well.

Had to run out to a show but will flash the other one then get them set up as dumb access points with fast handoff and we will see how it goes

Thanks for responding by the way


1 Like

@odrt @hnyman
Did some more reading but am not sure. ...(I like to experiment but do not want a brick).

Flash this image in Luci via System-Flash firmware

Luci reports......

....and accept Force upgrade?

Is this all correct?

You can only flash the sysupgrade image via normal sysupgrade.

If you want to upgrade the recovery image, you need to enter the recovery console mode, and from the SSH console there do the commands linked in my earlier message.

(with the ubi manipulation process described in Belkin RT3200/Linksys E8450 WiFi AX discussion - #1318 by daniel)

If you are unsure what to it means and what commands you should do, please do not try it.

1 Like

That's why I got cold feet and ask for advice.

Hi all, I'm about to update my three E8450's to 23.05.0, and I am planning on using Attended Sysupgrade. In this process, I noticed I have an awful lot of packages on my installation currently, and I have a few questions, thanks in advance!

  1. Where can I find the default package list for this device for comparison with possible non-essential packages I might have installed and forgotten?

  2. I'm currently running dnsmasq-full , openssl and wpad-openssl. Would there be any sense in moving over to the mbedtls stack?

  3. If I leave the Board Name / Profile as "linksys,e8450-ubi", will that handle any new packages or kernel modules that might have been split since the previous release?

I don't recommend doing an Attended Sysupgrade from 22.03 to 23.05 because at least the firmware is split and you can end up without WiFi. Here's what I did using the Firmware Selector:


Hi Guys,
Since installing 23.05 on my Linksys E8450 I started to get these errors:

[772585.366317] ------------[ cut here ]------------
[772585.371059] Timeout waiting for MCU reset state 20
[772585.376024] WARNING: CPU: 0 PID: 15417 at 0xffffffc000a0d278 [mt7915e@00000000d9d682c2+0x1f000]
[772585.384846] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_syslog nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c hwmon crc_ccitt compat seqiv leds_gpio xhci_plat_hcd xhci_pci xhci_mtk_hcd xhci_hcd gpio_button_hotplug usbcore usb_common
[772585.446326] CPU: 0 PID: 15417 Comm: kworker/u4:2 Tainted: G S      W         5.15.134 #0
[772585.454497] Hardware name: Linksys E8450 (UBI) (DT)
[772585.459453] Workqueue: mt76 0xffffffc000a0f334 [mt7915e@00000000d9d682c2+0x1f000]
[772585.467022] pstate: 80400005 (Nzcv daif +PAN -UAO -TCO -DIT -SSBS BTYPE=--)
[772585.474063] pc : 0xffffffc000a0d278 [mt7915e@00000000d9d682c2+0x1f000]
[772585.480671] lr : 0xffffffc000a0d278 [mt7915e@00000000d9d682c2+0x1f000]
[772585.487278] sp : ffffffc00eadbc50
[772585.490670] x29: ffffffc00eadbc50 x28: ffffff8002761ec0 x27: ffffff80027625f8
[772585.497889] x26: 0000000000000000 x25: 0000000000000000 x24: ffffff8002762020
[772585.505106] x23: 0000000000000000 x22: ffffff8002766020 x21: 0000000000000020
[772585.512323] x20: ffffff8002769ee0 x19: 0000000000000000 x18: ffffffc008a3a338
[772585.519541] x17: 00000000000010c0 x16: ffffffc008cf7000 x15: 00000000000004e9
[772585.526758] x14: 00000000000001a3 x13: ffffffc00eadb988 x12: ffffffc008a92338
[772585.533975] x11: 434d20726f662067 x10: ffffffc008a92338 x9 : 0000000000000000
[772585.541192] x8 : ffffffc008a3a2e8 x7 : ffffffc008a3a338 x6 : 0000000000000001
[772585.548409] x5 : ffffff801fea26f8 x4 : 0000000000000000 x3 : 0000000000000027
[772585.555627] x2 : 0000000000000027 x1 : 0000000000000023 x0 : 0000000000000026
[772585.562845] Call trace:
[772585.565369]  0xffffffc000a0d278 [mt7915e@00000000d9d682c2+0x1f000]
[772585.571631]  0xffffffc000a0f544 [mt7915e@00000000d9d682c2+0x1f000]
[772585.577892]  0xffffffc008050950
[772585.581111]  0xffffffc008050c60
[772585.584330]  0xffffffc008058e2c
[772585.587549]  0xffffffc00801581c
[772585.590767] ---[ end trace 8f2b00311654e471 ]---
[772605.846158] mt7915e 0000:01:00.0: Message 000026ed (seq 7) timeout
[772626.325996] mt7915e 0000:01:00.0: Message 00005aed (seq 8) timeout

WED is enabled, I use 80 MHz channel width on the 5 GHz wifi. Any idea why I'm getting these errors? On 22.03.05 there was no such problems.

Nobody recommended to flash the recovery instance via Luci.

I recommend you to not try to update the recovery instance if you continue to cut corners on linked procedures for two times.

This is not a web interface procedure. You could produce a brick easily.

1 Like