Belkin RT3200/Linksys E8450 WiFi AX discussion

@daniel I see you closed
about a week ago mentioning a better fix already being merged.

I'm not solid on the openwrt mechanics with the different repositories...
Is that better fix in the mt76 repository and would that be pulled if I install a current snapshot image?
If yes I'd give WED another try.

Does anyone with these devices face the issue mentioned here: Support for DLink M32 Mesh System and R32 Router - #56 by RolandoMagico

I saw it first on D-Link M32/R32 but I’m curious if it affects similar devices as well

What issue, exactly? The linked thread just shows the OpenWrt default, wifi being initially disabled.

In the wireless settings, all modules/devices are shown as "Generic Unknown" after startup.
Also scanning for WiFi networks doesn’t work as long as no AP is activated.

The expected behavior (tested with another OpenWrt device with different CPU): name of the WiFi devices is shown correctly and scanning networks is possible without enabling an AP before.

The issue is not present in v23.05.0-rc3 but in the latest snapshots

Thanks for mentioning this - I just flashed 23.05-RC3 on my RT3200 and I have WED enabled using bridger (dumb AP mode), and I was seeing strange timeouts in some of the iperf3 test runs that I was doing.

I haven't seen that message in my error logs, but I'd need to rerun some tests since I may have rebooted since I last saw them.

Other than the odd timeouts, the performance of 23.05-RC3 has been excellent. Crazy speeds using AX + 160Mhz and the latencies are excellent over wifi (with WED enabled).

1 Like

I'm curious about the same. @daniel Could you please expand on the better fix?

4 posts were split to a new topic: Trying to connect ORICO M2PV-C3 M.2 NVMe Enclosure as usb device

I've been noticing a significant loss in performance for some months. I'm running on snapshot and updating at least every month or when I see new mt76 updates.
I've now done some troubleshooting and I noticed that WED and hardware flow offloading don't work anymore.

Doing a speedtest on a BBR server now I reach about 5-600 Mbps in download and 7-800 Mbps in upload while before I easily reached 900+ Mbps in download and 850+ mbps in upload.

Via htop I noticed that enabling or disabling hardware (and software) offload seem to end up in the same result: one of the two cores is at 100% load during speedtest, while I remember clearly that it was barely up some time ago. Is it common knowledge that this feature has been broke by recent updates?

It's true that WED was broken for some months on MT7622, but it should now work again after


Thanks, I was now running the SNAPSHOT - r23845-abc536f547 from August 29.
I am now upgrading to the latest.

But I'm not mainly interested in WED, more in the wired performace that I notice being slow too.
The speeds i was telling in the previous post were obtained via wired ethernet with a PPPoE WAN.

Edit: It works finally, thanks!

      Server: Vodafone IT - Milan (id: 4302)
         ISP: Dimensione Srl
Idle Latency:    13.59 ms   (jitter: 0.33ms, low: 13.40ms, high: 13.82ms)
    Download:   926.01 Mbps (data used: 1.2 GB)                                                   
                 21.14 ms   (jitter: 17.92ms, low: 13.33ms, high: 329.49ms)
      Upload:   919.53 Mbps (data used: 1.1 GB)                                                   
                 21.36 ms   (jitter: 2.97ms, low: 13.54ms, high: 91.96ms)
 Packet Loss:     0.0%
  Result URL:

Thanks, WED works again with IPv6 enabled WAN :100:

It seems that for me the timeout or freezing problems were solved somewhere along the way in the last month because I have not experienced such events again. And yes, wed works again without supplemental patches to mt76. My builds use kernel 6.1 and the 20230418 firmware for mt7915 and are working fine now, but I know that other developers are still struggling with the timeout problem or UDP floods killing MCU communication. Following the issues I think they are still not sure if it is a mt7915 firmware or wed code issue, but I am optimistic they will solve it.


I've experienced a freeze yesterday, using current snapshot, with standard firmware though.

Do you publish build anywhere? Or have some good read about building Openwrt with newer kernel?


Rany2 pushes a commit to his mt76 git branch with firmwares from the TP-Link EAP605 which supposedly fix the UDP flooding issue.

Edit: Sorry, saw it was already dicussed in the linked mt76 issue thread

Yes, I think this issue is solved by using that particular firmware, but myself I've never encountered it, so it likely depends on usage scenarios. The timeout issue is present much more often.
LE: I forgot about another probably fixed issue: 100% CPU usage for no reason, which no one has any idea what caused it and I hope it never comes back.

No, I don't publish my builds. The building process is tipical, it just depends on the experience - just select the testing kernel at menuconfig phase. I can give you my .config file if useful

Spoke too soon :slightly_frowning_face::

Some misbehaving driver.
96% softirq, means that some hardware driver floods the system with interrupt calls.

You might try identifying it by shutting down one radio at a time, disconnecting wired cables one by one, etc.

Restarting the mt7915e radio solves the problem. Could it be related to wed, like the timeout problem? I'll try to disable it for a while.
LE: On the other hand, this commit sounds interesting. I will test with the latest mt76 and wed enabled, let's see what happens...

Please help me guys, give me some advice!
I got a Linksys E8450 as the main router with OpenWrt 22.03.05. If I connect via cable I can almost max out my ISP bandwidth (850-850Mbps). If I connect to one of my dumb AP's via 802.11ac I can also max out my bandwidth
However if I connect with the same device to the Linksys E8450 the max speed is between 2-400 Mbps. WED is enabled and it doesn't matter if I configure AC or AX on the router, the results are the same. The internet connection is PPPOE.
The only strange thing is that the /sys/kernel/debug/mtk_ppe/bind is almost always empty.

What am I missing?