Belkin RT3200/Linksys E8450 WiFi AX discussion

I've also noticed this, when I connect to my 2.4ghz wifi, the width is always at 20 Mhz, even though my settings are at 40 Mhz.
image

You can force 40 MHz mode in LuCIs "Advanced" Tab. My RT3200 did not use 40 MHz channel width otherwise, but check for overlapping channels with your 2.4GHz neighbours first.

To all the guys who recently mentioned the WiFi issues with the E8450, I have had the same issues with both WiFi 2.4Ghz and 5Ghz disconnecting and re-connecting within seconds, especially Apple devices, no Internet intermittently although being connected to WiFi, etc. After a lot of searching and trying, the workaround that actually fixed the issues was to add

echo 0 > /sys/kernel/debug/ieee80211/phy0/aql_enable
echo 0 > /sys/kernel/debug/ieee80211/phy1/aql_enable

in the startup, initscripts, rc.local , before the exit 0 to switch off obviously buggy AQL according to

I have been running 20.03 RC3 and now RC4 with this for weeks now without any WiFi issues anymore, could you try, reboot, and feedback, if this worked for you ?

1 Like

Has this helped with latency variation, especially on 2.4?

A working solution is described here

Apologies if you have tried this in the past, but a suggestion (from another thread your familiar with) might help you narrow it down a bit if you haven't. Have you tried disabling any form of WPA (wifi encryption)? I know this is not a solution and might be risky given you can't reproduce the issue on demand - but it might help to narrow down the cause.

For the record, I don't have your device and so far the three other family members in my household that use apple devices have not complained to me about this issue.

I've seen this issue once on rc4. WPA3 on iOS 15 and it was like the device was in a failed auth loop. Eventually it connected but I did notice it. I might just not be aware as 5G works well where I am and it may just be failing over to it during the intermittence.

Im having a problem where the router becomes unresponsive after about 2 minutes. Everything boots normally and I can login to LuCi and ssh into the router. Then suddenly I lose all connectivity.

I first tried: 22.03-SNAPSHOT r19338-ae64d0624c
then I installed: RC4

Same issue with that one.

I have one ethernet cable hooked into ethernet port 1, nothing in the internet port, have tried enabling and disabling the wireless, that didn't work.

Any ideas?

Ignored the warnings and bricked it trying to return to the factory firmware. Oops.

I had an E7350 (same platform as that netgear looks like) and was very happy with the WiFi. 2.4ghz was not disappointing.

1 Like

Can someone elaborate what aql_enable exactly is doing ?

1 Like

Probably it's better you ask here

Woke up this morning and my 5GHz radio was dead again (interface show disabled in luci). Restarting the radio didn't work, had to completely reboot. I probably should've done more diagnosing to help here but I needed my network back up immediately.

The radio has 4 SSIDs broadcasting currently, set to DFS channel 100 with 80MHz bandwidth. WPA3 only on the main network and WPA2+WPA3 on the others (which aren't even currently used). Running 2022-rc4. Same exact settings on 2.4G and I don't have this issue (only the random disconnect issue that resolves itself).

Anything in dmesg or logread to indicate cause?

1 Like

Unfortunately I wasn't able to check as I mentioned I needed the network back up immediately and so I rebooted. Next time it happens I'll be sure to look though. Happens very irregularly and has probably been a month or two since the last time it happened.

2 Likes

I'm here "r19504-c18c6e53b9" for around 2 months, zero issues at the moment.

1 Like

Maybe can help

1 Like

FYI mt76 driver was updated in 22.03 branch yesterday.

Testing on my RT3200 now. No obvious regressions so far.

3 Likes

Looks substantive. Thanks for the heads up. How do we verify that the latest 22.03 snapshot includes this commit?

You have to build your own load for now.

Prepare to dedicate an afternoon or more to this if you are unfamiliar with building embedded Linux images. This is a steep learning curve for a casual user. If you aspire to become a developer, this is an essential first step.

If this is too much, just wait for rc5 to come out.

2 Likes