Belkin RT3200/Linksys E8450 WiFi AX discussion

You can (temporarily, in initramdisk) install the package kmod-mtd-rw using opkg.
That will unlock the volumes and give you read-write access.

I upgraded to v0.6.0 of the dangowrt installer, but now the highest available 5Ghz WiFi channel is 144 in Luci. I was using 157 before the upgrade. Anyone know how to restore the other channels?

Oh nevermind, you have to set country code

I am not sure if I am the only one experiencing this issue, I see intermittent packet drops (5-10 packets) in the network and it's not just happening from one device. The issue is only affecting devices connected to wifi and not the through LAN. If I run a continuous ping to E8450 from different devices, I see packets getting dropped at different times. This doesn't happen when the devices are connected to the LAN and so it's something with the Wifi.

So @daniel to confirm for the many of us on v0.5.3 - your recommended advice is do nothing and just keep using the attended sysupgrade?


hello I do not know if I have already updated via 0.5.3 my openwrt or an older version if I reuse 0.5.3 recovery when I had already used it there will be a problem? thank you

No idea. We are all at the mercy of the vital scraps that @daniel feeds us as we scurry around underneath the table.

Absent fuller documentation or explanation, an understanding of the UBI layout / boot / recovery / installer aspects is surely beyond a significant proportion of the user base. For example, I am completely lost about the driver / error checking / calibration data / OEM reading / writing aspect.

Above it is specified:

What does that mean - 'just replace the recovery image'? I mean it obviously means replace the recovery image. But how do we do that? What is the recovery image actually? Are there two images on every device - one recovery and one full? Is the latter what sysupgrade is?


If some kind soul were to provide a write up about these aspects I think that would benefit many.

1 Like

Thank you guys.
I was able to successfully write mtd0, 1, 2 with the one in ubi0_3. I also ubiupdatevol /dev/ubi0_2 /tmp/openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb

However in the recovery luci the model still says UBI, the ubi are seen in /dev/ and I can't get out of initramfs after force upgrade a factory image.

Am I back on the stock vendor's boot chain?
I previously updated uboot for newer openwrt version, does ubi0_3 got overwritten if i'm updating from a ubi to another ubi? (I was using 0.52 then i updated to 0.53 to use [openwrt/openwrt@050621a].


Strange behavior today. I installed with 0.5.3 a little bit ago, and played around for a bit before I got started since I’ve never used openwrt. Then, after the mt76 update, I performed an attended system upgrade with no problems. I set up my config and ran the router for a week with a 2.4ghz N network with no issues. I then decided to get rid of my old router and switch over to this one permanently. When doing so I set up an AX network and it was working for a few minutes. Then, yellow light on the internet led, and off to recovery mode.

So time to start over. Except now, I cannot do an attended sysupgrade. Snapshot downloads, install begins, then yellow light on the internet and back to the recovery snapshot.

Any ideas?


I decided to unplug the router and try again just for fun. When I turned the router back on, it was on the latest snapshot.

Update 2:

Seem to be short my 5ghz radio now. Planning on messing around more tomorrow.

The second part from my message was about my experience with updating the ubi recovery (I said "on the other hand" :slight_smile: ) and not related to the "back to factory" procedure. The original vendor flash layout is not ubi-based and does not include a so-called "recovery" partition, it is "dual-firmware".
There is an OpenWRT page explaining this:
What I've recommended after installing the factory bootchain, is to use the original factory firmware, rename it to lede-mediatek-mt7622-MTK-AX3200-MT7531-squashfs-sysupgrade.bin (I saw it in the U-Boot code) and serve it by tftp to the factory U-Boot. I am not sure if U-Boot will automatically load and flash this file or you need to use the serial console, this depends how it is programmed, it is just a hunch from my times debricking Atheros-based routers.

As you have re-run the installer, what you find in boot_backup now is the bootchain of the previous installer run (ie. UBI, but pre-0.5.3).

... that explains why he managed to boot the flashed UBI recovery.... unfortunately, if @indarkness does not have a previous backup of mtd0-3 in other place, it seems he lost the factory bootchain. I have the files from my RT3200 backup, do you think they can be used for his (another) router?

May I suggest to update your instructions explicitely mentioning that re-running the installer will replace the factory bootchain backup? It is very important, I think...

Yes, the files are compatible even between RT3200 and EA8450, you may have to edit factory and devinfo to put back the right MAC addresses.

Ok so I tried to use the reset button to return to the recovery image. Seems like that just resets the settings on the latest snapshot I downloaded. Still no 5 ghz radio.

Probably the kernel has crashed while running production firmware which (deliberately) results in the bootloader booting into recovery until crash logs in /sys/fs/pstore have been removed.
Please check if you find anything there and if so, please post the content of the files and delete them from /sys/fs/pstore.

So I was moving a little quick and ended up reflashing manually with the prebuilt sysupgrade file. 5ghz radio returned. Attended sysupgrade to newest snapshot and 5ghz radio remains. I’ll reconfigure and if I crash again with AX I will certainly upload any information from pstore. Thank you!

1 Like

me too X doesn't work i don't know why :confused:

where i recupered ps store ?

ok i has found just tape the command and AX appair in wireless :wink:

/etc/init.d/network restart


I finally got my Belkin RT3200. I like others cannot flash from the stock firmware. I am nervous about flashing the ubi version and not being able to return to stock. I have never used a serial cable before. Could someone link me to one that will work so that way I can return to stock if need be for testing purposes? I also want to get one in case I need to for some reason. Better safe than sorry I was always told.

Is there a guide on how to flash the ubi firmware? If so can someone link me to that? I am going to give it a shot. I want to make sure I have accurate information and up to date. I have been fallowing the discussion as much as I can but I have to admit 719 comments is a lot to read through as busy as I have been. When I go to install the ubi firmware will it create the necessary files for me to go back to stock with the serial cable?

I now there isn't a clear guide, but if you go the easy way of installing UBI with Daniel's method (, you'll end with only the bootchain backup (factory partitions mtd0...mtd4) packed in mtd0, mtd1 and mtd2 files (here is the partition structure - and see how they match). If you want to have a backup of all factory partitions, according to the "manual" instructions from here;a=commit;h=02351861824a13ed158db1ef59aede2db6ba7568 you need to boot from the recovery image (NOT the installer). I don't know about the recovery capabilities of the original factory U-Boot and if can be used to debrick a router only by putting back the bootchain (factory mtd0, 1, 2, 3 - factory mtd4 was not affected in my case, that means only mtd0 and mtd1 are needed from the UBI backup) then serving the original firmware by tftp. If there is such method (like in atheros based routers) then you don't need a serial. But who is willing to experiment or enlighten us what are the capabilities of the original U-Boot?

Apologies, as this has undoubtedly been answered somewhere in this thread (probably even many times), but what exactly is the benefit of using the dangowrt installer and replacing the UBI? A “disadvantageous flash layout” with stock doesn’t mean much to me

Edit: Never mind, found the answer:

Walmart is now selling the Belkin RT3200 for $59 shipped