Belkin RT3200/Linksys E8450 WiFi AX discussion

inez has been getting help on Reddit as well but not sure if following through.
Did you set your IP to static as suggested inez?
As I said ethernet port may not be eth0, on my msys2 system on windows it's called enp2s0 for example. The screenshot you posted has a similar format to this which is why I mention it.

I haven't found a way to change the IP yet.

I am using the Attended Sysupgrade way so it worked flawless. I am using RT3200 as my primary router now, waiting for another pair to get here so I can create my own home mesh. I am letting my pfsense firewall to do the DHCP and firewalling for now, but this looks very promising guys.

inez, perhaps someone can help you into more details using IRC or a zoom you have access to those tools?

Same here, I am using my Opnsense firewall which handles all the firewalling and most of the networking stuff (DHCP, DNS etc). Trying to setup mesh with my Archer C7 running Openwrt.

Hi all,

I'm encountering a weird issue that I couldn't figure out, so I thought I ask here.

I'm using my own custom master build from early Aug for my E8450. So far it has been working quite well (both WiFi and LAN), except for when I restart the router.

When I restart the router with the WAN port cable connected to my ISP's fibre modem, the router will not be able to obtain any WAN IPs (both IPv4 and IPv6) configured using DHCP client.

To get the router to work, I had to disconnect the WAN cable from the fibre modem and restart the router. I have to wait for the router to boot up successfully before connecting the WAN port before it is able to get any IP address from the fibre modem. If the router crashed and restart, this will cause Internet to go down at home.

Have anyone encountered similar issue and found out the root cause or hopefully have a work-around?

I have the same configuration to my ISP and I'm not seeing the same problem.
Was it always like that?

Yeah, it's been like this since I first started using it in early Aug 2021. Was looking at the netifd commits but it doesn't look like there's anything there that could cause the issue what I'm seeing.

I think I could probably bring down the wan device in the startup script and bring it back up after sleeping for some seconds.

I can't find the comments discussing it unfortunately (may have been in another thread), but yes, that was a known bug, I saw it too, it's fixed in current snapshots.

1 Like

I don't use IRC but I use XMPP ( if you use that. I can also use zoom. Also, I found a way to change the IP on openSUSE, but I really don't know what to do now. I think I should just but a new router and start all over again. I would have been more careful if I knew installing the wrong version would brick it. :confused:

Would you be willing to mail me the bricked router?
Might require soldering a serial connection but would enjoy trying to fix.

I don't know, I might try to return it or something. I mean, that's probably kind of immoral... I have to think about it. I really don't want to have to. It's crazy that installing the wrong software renders hardware unusable, I guess it's different from a PC where you can just boot from a live USB or something to save it. If I decide it's 100% broken and I don't want to try to return it or anything, sure, I'll send it to you.

Yeah it's probably a bad idea to return after a possible bad flash. The manufacturers will find out and the response would be to lock down the routers in the future. Feel free to PM on Reddit and we can arrange.


Thank you @PeterPan it worked. Did you have to set the bandwidth to 80Mhz? I found 160Mhz wouldn't work with mesh. It worked with WDS but then I got very slow upload (5Mbit/s). With 3x RT3200 in mesh I get 350Mbit/s download and upload. I mean that's pretty good right? So far so good in terms of stability. Covers my whole large three storey house with metre thick walls and garden. Is it best to set access point master same frequency as mesh?

Also, gents, is 802.11r fast transition still broken? Aside from the error messages I think this may cause minor dropoff in zoom calls.

Also anyone use WireGuard? If so when you click on status in LuCi do you get an error message? Something about RPC:

Overall delighted with these routers. On Amazon UK these are now £80. Hence why I bought three.

1 Like

This device uses DSA, you can manage the switch from interfaces tab.

Based on those, I am pretty baffled on what you are trying to do, and if you understand the situation at all.

  • Private IP is a local IP address inside the local network. (The local network provided by your router, usually addresses given out locally via DHCP)

  • Your RT3200 router defaults to, so any address between and are ok as the private address for the PC.

  • You should likely disconnect PC from internet (ISP modem, your old router, whatever), and only connect it to the RT3200 lan port via fixed cable. So you would only have RT3200 providing

    • So the router might get an new local address from the router via DHCP, quite normally (if the RT3200 has a working initramfs image running)
  • If that does not work, you should set a fixed IP, like, in your OS (opensuse?).

And you need to connect to the router via SSH console, as the initramfs image likely does not contain LuCI GUI. Also the wifi is likely turned off by default.

But nothing about this has really anything specifc to RT3200, so this is going offtopic :frowning:

@inez don't give up this is a fantastic router and you won't have bricked your device. You just need to figure some stuff out and it will pay dividends in the future. OpenWrt unlocks a vast amount of potential not offered by the original firmware so it would be worth persevering. If it's not too late

As explained above you may need to temporarily set a static IP for your computer. Say with subnet mask If you have a Windows box you could also use that by just googling how to set static IP on adapter properties by clicking IPV4 options and entering the values or similar.

If you need help you can also try logging on IRC by going to the web chat version for OFTC then going to channel #openwrt. If I see you there I will try and help.

1 Like

Hey @Lynx
I can confirm this same behaviour with WireGuard as well as I'm no longer able to create a new WG interface. Perhaps this issue has something to do with recently updated kernel 5.10.64.
Apart from that, this router is a real beast.

1 Like

I bought it used, but yeah, probably.

So, the issue is that when I plug my computer into the RT3200 router I don't get a private IP address and my internet doesn't work and I can't access I think this is because I installed the wrong firmware as I described on my original post. I don't care if you move it or whatever, but if there is any way to make the router work with original or openWRT (I prefer openWRT, but either are better than this), I would like help doing so.