Belkin RT3200/Linksys E8450 WiFi AX discussion

I like it when people find regional friends here. :+1:

But: please stick to English in the public forum so that others can easily read and take part in your conversation without translation tools. You are free to use whatever language you like in private messages.

3 Likes

Update on this - this actually seems to be a regression in my client, and not the 23.05 firmware.

I confirmed by flashing back to 23.05-rc3 and I was getting the same poor speeds.

So something seems to have slipped through in the Linux Kernel that regressed my Intel AX211 speeds somehow. It's even in the LTS kernel, so I'm not sure what's going on there.

Regardless, I'm happy to report that 23.05 seems to be nice and stable on my RT3200, and my weird speeds are a different issue.

1 Like

Thanks for the update. What is the result of your speed test on 80 MHz channels since the problem occurred on MT7915 out of spec experimental 160 MHz channels?

@daniel has not yet updated his pre-built UBI installer etc. for 23.05.0, but as an intermediate solution, before Daniel updates his release:

You can clone Daniel's UBI installer github repo and change the build_installer.sh script to use 23.05.0 and build by yourself. The script builds both the ubi initramfs recovery installer image, the recovery image and the (probably unnecessary) normal sysupgrade image.

As far as I can see, the only changes needed are the branch name and the PGP key (the unattended PGP key from from https://openwrt.org/docs/guide-user/security/signatures instead of the old 22.03 key):

perus@ub2310:/Openwrt/owrt-ubi-installer$ git diff
diff --git a/build_installer.sh b/build_installer.sh
index a28fa2b..e22c9e1 100755
--- a/build_installer.sh
+++ b/build_installer.sh
@@ -5,7 +5,7 @@ set -o pipefail
 
 DESTDIR="$PWD"
 
-OPENWRT_PGP="0xCD54E82DADB3684D"
+OPENWRT_PGP="0xCD84BCED626471F1"
 KEYSERVER="keyserver.ubuntu.com"
 INSTALLERDIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" >/dev/null 2>&1 && pwd )"
 OPENWRT_DIR="${INSTALLERDIR}/openwrt-ib"
@@ -250,7 +250,7 @@ bundle_initrd() {
 }
 
 linksys_e8450_installer() {
-       OPENWRT_RELEASE="22.03.5"
+       OPENWRT_RELEASE="23.05.0"
        OPENWRT_TARGET="https://downloads.openwrt.org/releases/${OPENWRT_RELEASE}/targets/mediatek/mt7622"
        OPENWRT_IB="openwrt-imagebuilder-${OPENWRT_RELEASE}-mediatek-mt7622.Linux-x86_64.tar.xz"
        OPENWRT_INITRD="openwrt-${OPENWRT_RELEASE}-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb"

I tested it, built the images and (just for testing purposes) updated the OpenWrt recovery image on my RT3200 (with the ubi manipulation process described in Belkin RT3200/Linksys E8450 WiFi AX discussion - #1318 by daniel), and used that recovery instance to flash my normal main/master snapshot image. Quite ok. (I did not touch the u-boot bootloader.)

Now my recovery instance has 23.05.0:

Ps.
(There is no real reason to upgrade your recovery instance, as it is only used in emergencies to flash a new OpenWrt sysupgrade image. I updated it just for testing purposes.)

3 Likes

I agree for most expected scenarios: regular updates via sysupgrade, nothing goes wrong, stable sysupgrade process. In this case the initial recovery instance is never used or needed again.

But: I think sysupgrades between major versions are mostly done only between one major version to the successor major version: like 22.03 to 23.05. There will only be a small to zero number of users sysupgrading from let's say 22.03 to 28.xx.

If the recovery instance is needed some years later it should be safe to upgrade between each major version to the successor major version. But upgrades directly from a release several years ago jumping over intermediate versions is not tested and not guaranteed.

For now years old EOL sysupgrade images are still available on https://downloads.openwrt.org but this is not guaranteed in the future.

I will keep one sysupgrade image of each major version for my E8450 by myself. With this I am independent of the OpenWrt EOL sysupgrade image archive and the recovery instance can stay on 22.03.

A better solution would be if we could easily update the recovery instance once for each major version.

In practice for the expected lifetime of let's say five years no recovery instances updates should be needed. But when I see that some models like the TP-Link Archer C7 v2 are supported since 14.07 and have no projected device EOL I am not sure if it is the best decision to stay on 22.03 for the recovery instance forever.

1 Like

Since upgrading to 23.05 neither my AX6s nor my RT3200 activate 5GHz radio anymore (it works with my Archer 2600 so I presume its chipset specific, all are just dumb APs). Am I missing something?

FWIW, Kernel log on the AX6s:

[    6.369337] kmodloader: loading kernel modules from /etc/modules.d/*
[    6.378617] Loading modules backported from Linux version v6.1.24-0-g0102425ac76b
[    6.386137] Backport generated by backports.git v5.15.92-1-44-gd6ea70fafd36
[    6.446402] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[    6.464254] mt7915e 0000:01:00.0: assign IRQ: got 139
[    6.469370] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
[    6.475497] mt7915e 0000:01:00.0: enabling bus mastering
[    6.481389] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a
[    6.481389] 
[    6.574873] mt7622-wmac 18000000.wmac: N9 Firmware Version: _reserved_, Build Time: 20220630094834
[    6.610923] mtk-pcie 1a143000.pcie: msi#0 address_hi 0x0 address_lo 0x44d1d0c0
[    6.618910] urngd: v1.0.2 started.
[    6.632709] mt7915e 0000:01:00.0: Direct firmware load for mediatek/mt7915_rom_patch.bin failed with error -2
[    6.642668] mt7915e 0000:01:00.0: Falling back to sysfs fallback for: mediatek/mt7915_rom_patch.bin
[    6.929410] mt7915e: probe of 0000:01:00.0 failed with error -12

You're probably missing the kmod-mt7915-firmware package. How did you do the upgrades, via ASU or auc? Try installing above kmod and reboot.

2 Likes

I had updated using luci attended sysupgrade and yes, the kmod was missing. Installing it indeed fixed it. Thanks a lot!

1 Like

Incase you missed it and/or haven’t built your own already. @daniel has released his updated recovery/installer images.

4 Likes

For an already Openwrt running RT3200/E8450;
Are there any advantages to "upgrade" to this new recovery image?
And if yes (or just as information); What are the steps to be taken?

I've never entirely understood the significance of the various releases here:

So, for example, release v1.0.0 states:

That sounds pretty significant. What about those of us who installed releases prior to v1.0.0 (many are probably around v0.6.2 or so). Does that make our devices more vulnerable to 'bad blocks'?

So now there is the v1.0.3 release:

Is the recommendation only to update OpenWrt and not try to upgrade the recovery / other aspects covered by these releases?

Probably I lack an understanding of what the installers does. It converts the layout to UBI and then installs recovery, ARM trusted firmware, U-boot and OpenWrt? Wouldn't it desirable to facilitate a way to upgrade recovery, ARM trusted firmware, U-boot without going through the full installation from scratch / UBI conversion process?

Am I the only one not entirely understanding these things?

Curious about this too!

The documentation does clearly say: " WARNING #3 The installer is meant to be executed only once per device. Executing the installer more than once should be avoided! U.."

But you're right.. should UBoot be updated via another method?

And what about the recovery / ARM Trusted Firmware?

Guys, something happened to my RT3200 today.

I have it set up to reboot daily at 3:30 am. Never had a problem with this since I use OpenWRT from my WDR4300, next my Redmi AC2100 and now my RT3200.

However, this morning I found out that my 5G radio was off. Tried wifi reload in SSH and then restart the 5G radio and it didn't work. I had to reboot the router.

Oh, and also I faced the problem I mentioned earlier: when I click reboot on System > Reboot on Luci, the router just shuts down (all leds off), it doesn't come back up. I had to use the rear switch to off, wait few seconds, and turn it on.

What should I do when something abnormal like this happens? On the system log I don't see anything. On the kernel log before reboot? IDK if there's a wiki about this to diagnose our devices before askig for support here.

Thanks in advance!

I just a couple of these to use as dumb APs basically - however, I am having the darndest time setting them up. I try to follow the instructions on the dangowrt page, but am hitting roadblocks.

If i try to exit out of the wizard early like is suggested, the router goes to the login page and will not let me in - if i enter the admin password it flashes to the admin page in the router, but then redirects me right back to the login.

If I complete the entire wizard, set the ssids and password, it takes me to the login page, and does the same loop.

I'm stumped at how to get past this, i know that if i enter a wrong password the login screen tells me that, so i know the password is right, i just am stuck.

All i want to do is install open WRT on these, but I'll just send them back if they are such a pain in the ass. I can't even set them up using the belkin firmware.

Hopefully I am missing something stupid, thanks in advance,
Mike

@odrt gave a solid reason a couple of posts above.

You don’t HAVE to keep the recovery updated, but it certainly doesn’t hurt. To update just flash the installer like you would any other firmware update via the web GUI.

You mean this one?:
openwrt-23.05.0-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb

@hnyman linked steps to update the recovery instance:

Kinda sounds like your browser. Try turning off add blockers and using a different browser.

Its been a long time since I saw the original firmware's screens so I don't remember it logging in required a special trick.

Failing that, you could flash via serial & tftp That's what I wound up doing in the end. Google "rt3200 how to open" and you'll find some you tube videos on how to it. Then, you just need a 3V serial port adapter.

Its worth the effort as these are one of the most stable, well supported openwrt devices out there right now. Another option that is straightforward to flash is the the wax206, if you can find them. It uses the same chipset as the belkin but has better antennas and a 2.5Gbps wan port.

1 Like