Belkin RT3200/Linksys E8450 WiFi AX discussion

Dunno how it looked yesterday but the price is now ~$50 and the seller is not Walmart but a private seller named "GreatDeals"

Just FYI:

2 Likes

For folks who have been plagued by the mt7915e timeout such as the message below:

mt7915e 0000:01:00.0: Message 000026ed (seq 13) timeout

, do you have wed turned on via /etc/modules.conf?

It could be that enabling wed may be causing the timeout.

An interesting discovery I noticed is that even though I removed the wed module entry in /etc/modules.conf and rebooted my router, I still see entries when I cat /sys/kernel/debug/ppe0/bind which suggest that wed is still enabled?

Edit: The entries described above appears to be from wired clients as I have hardware flow offload enabled. It’s not from wed.

In any case, if you see the occasional or even frequent timeouts, try removing the wed entry in /etc/modules.conf and see if it helps you.

1 Like

Yes, the entries you see in /sys/kernel/debug/ppe0/bind just show that hardware NAT acceleration is active. To check if wed is working you must find in that list the MAC addresses or IP-s of wireless clients, but wed works for latest mt76 builds only if the commit from https://github.com/openwrt/mt76/pull/806 is applied.
I usually compile and use a new build from main branch once every 3-4 days and regarding the timeout events, I did not detect any recently (the last was several weeks ago). I did encounter one or two total crashes or freezes (router inaccessible from LAN) but couldn't find something relevant in logs, the router started normal again and not in recovery mode. Maybe the new 6.1 testing kernel is the problem? And also the 100% CPU usage (for no reason) issue seems to become rarer.

1 Like

Have not had WED working in a while. I am running 23.05 snapshot and it's likely this commit restored it.

The device page suggests Hardware Flow Offloading in the Firewall section is not needed to use WED. That doesn't seem to be the case for me as I tried fully off, then with only Software Flow Offloading, both with no effect. Turning on Hardware Flow Offloading significantly reduced CPU usage.

I can now get just over 800Mbps with ~30% CPU usage, without WED working ~600Mbps with 100% usage.

4 Likes

@daniel I see you closed
https://github.com/openwrt/mt76/pull/806
about a week ago mentioning a better fix already being merged.

I'm not solid on the openwrt mechanics with the different repositories...
Is that better fix in the mt76 repository and would that be pulled if I install a current snapshot image?
If yes I'd give WED another try.

Does anyone with these devices face the issue mentioned here: Support for DLink M32 Mesh System and R32 Router - #56 by RolandoMagico

I saw it first on D-Link M32/R32 but I’m curious if it affects similar devices as well

What issue, exactly? The linked thread just shows the OpenWrt default, wifi being initially disabled.

In the wireless settings, all modules/devices are shown as "Generic Unknown" after startup.
Also scanning for WiFi networks doesn’t work as long as no AP is activated.

The expected behavior (tested with another OpenWrt device with different CPU): name of the WiFi devices is shown correctly and scanning networks is possible without enabling an AP before.

The issue is not present in v23.05.0-rc3 but in the latest snapshots

Thanks for mentioning this - I just flashed 23.05-RC3 on my RT3200 and I have WED enabled using bridger (dumb AP mode), and I was seeing strange timeouts in some of the iperf3 test runs that I was doing.

I haven't seen that message in my error logs, but I'd need to rerun some tests since I may have rebooted since I last saw them.

Other than the odd timeouts, the performance of 23.05-RC3 has been excellent. Crazy speeds using AX + 160Mhz and the latencies are excellent over wifi (with WED enabled).

1 Like

I'm curious about the same. @daniel Could you please expand on the better fix?

4 posts were split to a new topic: Trying to connect ORICO M2PV-C3 M.2 NVMe Enclosure as usb device

I've been noticing a significant loss in performance for some months. I'm running on snapshot and updating at least every month or when I see new mt76 updates.
I've now done some troubleshooting and I noticed that WED and hardware flow offloading don't work anymore.

Doing a speedtest on a BBR server now I reach about 5-600 Mbps in download and 7-800 Mbps in upload while before I easily reached 900+ Mbps in download and 850+ mbps in upload.

Via htop I noticed that enabling or disabling hardware (and software) offload seem to end up in the same result: one of the two cores is at 100% load during speedtest, while I remember clearly that it was barely up some time ago. Is it common knowledge that this feature has been broke by recent updates?

It's true that WED was broken for some months on MT7622, but it should now work again after

5 Likes

Thanks, I was now running the SNAPSHOT - r23845-abc536f547 from August 29.
I am now upgrading to the latest.

But I'm not mainly interested in WED, more in the wired performace that I notice being slow too.
The speeds i was telling in the previous post were obtained via wired ethernet with a PPPoE WAN.


Edit: It works finally, thanks!

      Server: Vodafone IT - Milan (id: 4302)
         ISP: Dimensione Srl
Idle Latency:    13.59 ms   (jitter: 0.33ms, low: 13.40ms, high: 13.82ms)
    Download:   926.01 Mbps (data used: 1.2 GB)                                                   
                 21.14 ms   (jitter: 17.92ms, low: 13.33ms, high: 329.49ms)
      Upload:   919.53 Mbps (data used: 1.1 GB)                                                   
                 21.36 ms   (jitter: 2.97ms, low: 13.54ms, high: 91.96ms)
 Packet Loss:     0.0%
  Result URL: https://www.speedtest.net/result/c/23a32705-ec9d-4219-9dbd-30f2805091e1

Thanks, WED works again with IPv6 enabled WAN :100:

It seems that for me the timeout or freezing problems were solved somewhere along the way in the last month because I have not experienced such events again. And yes, wed works again without supplemental patches to mt76. My builds use kernel 6.1 and the 20230418 firmware for mt7915 and are working fine now, but I know that other developers are still struggling with the timeout problem or UDP floods killing MCU communication. Following the issues I think they are still not sure if it is a mt7915 firmware or wed code issue, but I am optimistic they will solve it.

3 Likes

I've experienced a freeze yesterday, using current snapshot, with standard firmware though.

Do you publish build anywhere? Or have some good read about building Openwrt with newer kernel?

FWIW

Rany2 pushes a commit to his mt76 git branch with firmwares from the TP-Link EAP605 which supposedly fix the UDP flooding issue.

Edit: Sorry, saw it was already dicussed in the linked mt76 issue thread

Yes, I think this issue is solved by using that particular firmware, but myself I've never encountered it, so it likely depends on usage scenarios. The timeout issue is present much more often.
LE: I forgot about another probably fixed issue: 100% CPU usage for no reason, which no one has any idea what caused it and I hope it never comes back.

No, I don't publish my builds. The building process is tipical, it just depends on the experience - just select the testing kernel at menuconfig phase. I can give you my .config file if useful