Belkin RT3200/Linksys E8450 WiFi AX discussion

Hi, I'm trying to do mesh on my belkin rt3200 but it works one moment and then I have either a limited connection or no internet access

this is my config @Lynx

1ER ROUTER 

config wifi-iface 'wifinet1'
	option device 'radio0'
	option key '£££££££'
	option network 'lan'
	option wps_pushbutton '1'
	option mode 'ap'
	option encryption 'psk2'
	option ssid 'mesh1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option key '££££££££'
	option network 'lan'
	option wps_pushbutton '1'
	option mode 'ap'
	option encryption 'psk2'
	option ssid 'mesh2'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '££££££££'
	option wps_pushbutton '1'
	option network 'lan'
	option mesh_id 'mesh2'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '£££££££'
	option wps_pushbutton '1'
	option network 'lan'
	option mesh_id 'mesh1'





2nd router 
config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option disabled '1'
	option ssid 'mesh2'
	option encryption 'psk2'
	option key '££££££££'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mesh2'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '££££££££'
	option wps_pushbutton '1'
	option network 'lan'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mesh1'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '£££££££'
	option network 'lan'
	option wps_pushbutton '1'


Hmm I don't other with mesh. WDS seems more appropriate most of the time. WDS has always been rock solid for me but mesh seems off and on. Albeit I haven't tested in a long time so the issues could have been ironed out by now.

1 Like

Not really.
But the incompatibility comes from the two needed kernel modules. (You can't install kmods from the public repo to other/private builds due to strict hash checksums on kernel config)

I might add those two kmod-sched-xxx modules to my build. (and then you can opkg install bridger by yourself).

2 Likes

Thanks for the reply. I know these are your personal builds, so please do not feel pressured to add them. More wishful thinking on my side than anything else.

New price : Amazon France: 96,46 €

According to this post, a patch was recently added to the snapshot build that may fix 802.11r fast BSS transitions. I've read other posts that suggest that 802.11r fast BSS transitions have been broken in the 22.03 release for RT3200/E8450 devices. I would love to get this working.

Two questions:

  1. Has anyone tried a recent snapshot build on an RT3200/E8450 to see if 802.11r now works?
  2. I recently did sysupgrade on a RT3200 using the snapshot file linksys_e8450-ubi-squashfs-sysupgrade.itb to try to test 802.11r. However, I stopped when I saw the below warning in the boot log about ubi not being able to reserve enough PEBs for bad PEB handling. Should I be concerned about this warning? The snapshot release otherwise seems to work fine, but I don't get this same warning when running 22.03.2, and UBI sounds important (but not sure about PEB handling).
 kern.warn kernel: [    2.194364] ubi0 warning: ubi_eba_init: cannot reserve enough PEBs for bad PEB handling, reserved 18, need 20
1 Like

I've just turned it on (on SNAPSHOT) and it seems to work nicely.
Walking through the house and grepping for auth_alg shows just one auth_alg=open and ther rest are all ft:
Sun Dec 18 09:32:28 2022 daemon.notice hostapd: wl1-ap0: AP-STA-CONNECTED xx:xx:xx:xx:xx:xx auth_alg=ft

Works smoothly between the RT3200 and also Archer C7v5
I think I've reached a state where 802.11 k,r,v (I also use DAWN) do finally work as expected.

I'd switched two APs earlier to OpenWrt SNAPSHOT r21517-d7876daf65 / LuCI Master git-22.325.41248-fa17c15 which does also include the 802.11r fix, but did not turn it on. So far no stability issues.
Only today I actually turned on 802.11r.

I did switch back from AX to AC though (just gave it another try), since there still seems to be an issue with that. At some locations in my house I have good signal strength (better than -60dB), but only 25mbit/s with AX, that's not the case with AC (between 100 and 300mbit/s at the same locations).
So I'll rather have the more balanced throughput maxing out at 70Mbyte/s than the big variation maxing out at 100Mbytes/s.

My config:

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option country 'DE'
        option cell_density '0'
        option he_su_beamformee '1'
        option he_bss_color '5'
        option htmode 'VHT80'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'XXXX'
        option encryption 'psk2+ccmp'
        option key 'XXXX'
        option ieee80211k '1'
        option ieee80211r '1'
        option reassociation_deadline '20000'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0'
        option rrm_neighbor_report '1'
        option rrm_beacon_report '1'
2 Likes

I don't seem to have the PEB issue, I don't even know what PEBs are...:

[2.195604] ubi0: PEB size: 131072 bytes (128 KiB)>
[    2.202481] ubi0: min./max. I/O unit sizes: 2048/2>
[    2.209269] ubi0: VID header offset: 2048 (aligned>
[    2.216238] ubi0: good PEBs: 1000, bad PEBs: 0, co>
[    2.222327] ubi0: user volume: 6, internal volumes>
[    2.229551] ubi0: max/mean erase counter: 4/2, WL >
[    2.238686] ubi0: available PEBs: 0, total reserve>
[    2.248007] ubi0: background thread "ubi_bgt0d" st>

PEB stands for Physical Erase Block:

Eventlog message says you are running a bit short in blocks reserved as spare PEB

On RT3200(UBI) there are 1000 blocks used / 20 spare:
ubi0: available PEBs: 0, total reserved PEBs: 1000, PEBs reserved for bad PEB handling: 20
Please look at your dmesg. You may have 2 blocks damaged -> only 18 available.

2 Likes

I just realized that one of my three active RT3200 also has this issue:

root@router:~# dmesg | grep PEB
[    2.182948] ubi0 warning: ubi_eba_init: cannot reserve enough PEBs for bad PEB handling, reserved 18, need 20
[    2.199291] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    2.219910] ubi0: good PEBs: 1000, bad PEBs: 0, corrupted PEBs: 0
[    2.242265] ubi0: available PEBs: 0, total reserved PEBs: 1000, PEBs reserved for bad PEB handling: 18

The other two are fine.

Comparing dmesg does not really show more detail (removed timestamps before the diff). In particular there are no messages about damaged blocks.

The only difference I found is (well besides stuff I consider unrelated):
Good router, all 20 spare PEBs available:

UBIFS (ubi0:5): FS size: 89010176 bytes (84 MiB, 701 LEBs), max 712 LEBs, journal size 4444160 bytes (4 MiB, 35 LEBs)
UBIFS (ubi0:5): reserved for root: 4204169 bytes (4105 KiB)
UBIFS (ubi0:5): media format: w5/r0 (latest is w5/r0), UUID XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX, small LPT model

Router with just 18 spare PEBs available:

UBIFS (ubi0:5): FS size: 85708800 bytes (81 MiB, 675 LEBs), max 686 LEBs, journal size 4317184 bytes (4 MiB, 34 LEBs)
UBIFS (ubi0:5): reserved for root: 4048238 bytes (3953 KiB)
UBIFS (ubi0:5): media format: w5/r0 (latest is w5/r0), UUID XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX, small LPT model

I don't know whether the difference is just due to different image sizes (the one with PEB issue is my main router, the other an AP).

1 Like

No. This is simply due to a small difference in handling UBI introduced by

Hence, next time you write updated sysupgrade when coming from a commit after the above this warning will disappear.

3 Likes

Thanks so much. I flashed another SNAPSHOT image a second time after upgrading from 22.03.2, and now the warning message disappears about not being able to reserve enough PEBs for bad PEB handling. The syslog now says:

ubi0: available PEBs: 0, total reserved PEBs: 1000, PEBs reserved for bad PEB handling: 20

The best news is 802.11r appears to work for fast BSS transitions. For now, I'm running 802.11r using WPA2 and 802.11ac. I read WPA3 wasn't yet supported with 802.11r, and also read that 802.11ax has performance issues with the default driver. No problem as long as 802.11r works.

Updated my SNAPSHOT and now see the warning/bad PEBs:

Before:

OpenWrt SNAPSHOT, r20856-2b4f12e55b
 -----------------------------------------------------
root@Belkin:~# dmesg |grep PEB
root@Belkin:~#

After:

OpenWrt SNAPSHOT, r21517-d7876daf65
 -----------------------------------------------------
root@Belkin:~# dmesg | grep PEB
[    2.174368] ubi0 warning: ubi_eba_init: cannot reserve enough PEBs for bad PEB handling, reserved 17, need 19
[    2.191038] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    2.211660] ubi0: good PEBs: 999, bad PEBs: 1, corrupted PEBs: 0
[    2.234003] ubi0: available PEBs: 0, total reserved PEBs: 999, PEBs reserved for bad PEB handling: 17
root@Belkin:~#

Strange...

You were coming from a build before the relevant change. Hence the warning will disappear next time you use sysupgrade.

1 Like

Thanks! Just noticed the date difference :slight_smile:

Using iperf service on my main RT3200 AP running the prior snapshot (r20856) I would use my phone to test network transitions (FT) between APs and would get pretty good results ~300-700Mpbs everywhere - working great!

After updating to snapshot (r21517), I noticed that I can no longer use iperf in this manner on the main AP because although I am still getting a good connections, iperf only works on the AP where initiated (i.e. I start on AP1, walk to AP2 iperf result =0, walk back to AP1 iperf=600). Thus I setup another iperf server not on an AP and this behavior goes away.

Definitely unexpected... I see there was a change in iperf3 (update to 3.12) in between my snapshots, but I downgraded to 3.11-1 and problem persists. Is there something weird with the wireless interface in this snapshot that might cause this?

Hey Daniel,

Still stuck in this crash loop sadly, can I snag a copy of the binaries with the debug info set up? Would love to try and solve this :sob:

Running OpenWrt SNAPSHOT r21452-1e240f60a5 ("kernel: modules/lib-lz4: add lz4hc_compress"), just spotted the following in the dmesg of my client computer (Intel AX200, iwlwifi):

[327897.958286] wlp3s0: authenticate with MA:CA:DD:RE:SS:SS
[327897.964049] wlp3s0: bad VHT capabilities, disabling VHT
[327897.964051] wlp3s0: Invalid HE elem, Disable HE
[327897.964053] wlp3s0: 80 MHz not supported, disabling VHT

From the backlog it seems that there's not been an mt76 code drop since, I wonder whether the previous mt76 fixes may have broken something in the way the RT3200 advertises it's .ac/.ax capabilities?

1 Like

Hi folks.

I am running this firmware on my belkin RT3200 since it was in beta.

Now it seems that it is in the mainstream, and RT3200 is fully compatible with version 22.03 or opewrt.

I am currently running SNAPSHOT - r20893-ffd29a55c3 on my Belkin RT3200 -Ubi snapshot loaded it is idenfified as Linksys E8450 (UBI)-.

i woul like to upgrade to the latest mainstream version -22.03.2, I think- as currently I cannot be so dependent of development issues and do not follow development evolution.

But I am not sure of how to upgrade it to that mainstream version.

And I am not sure if there will be compatibility issues.

It seems it has migrated form firewallv3 to firewallv4 (I think my system is currently using IPtablesv3 but I am not sure, as it seems that firewallv4 is installed in the system)

Would be iptables migrated transparently of there are compatibility issues yet?

How is it the best way of dealing with these upgrade?
Can it be made using luc attended sysupgrade? (it seems it only lists snapshot versions)

Thank you for any advice.

EDITED: it seems that I can confirme I am using iptable v4 and firewall 4, as firewall4 is installed in the system and I can see no firewall3 module.

It seems that I have upgraded previously in the las snapthot install.

I would like to change now to the master install to be sure I am runing a stable version.

But I cannot, there is no option to change to master, only a new snapshot version.
MAY IT BE because the snapshot version I am running is ahead of the 22.03.2 version that is the last published in the master now?

If that is the problem I can just wait to the next master upgrade and move to it.

1 Like

1.Follow this link to the firmware selector for Openwrt 22.03.2:
https://firmware-selector.openwrt.org/?version=22.03.2&target=mediatek%2Fmt7622&id=linksys_e8450-ubi
2.Download the sysupgrade ubi file.
3. Use the Luci GUI interface to install it.

1 Like