Belkin RT3200/Linksys E8450 WiFi AX discussion

What is the current recommendation on using wpa2/3 mixed mode (w/ psk sae) wireless for both bands?
I'm currently using wpa2, but I would love to move to 3 with backwards compatibility as an option.

Current Partial Config:

root@OpenWrt:/etc/config# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'
	option noscan '1'
#	option local_pwr_constraint '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'secret_24Ghz'
	option disassoc_low_ack '0'
	option encryption 'psk2+ccmp'
	option key 'secret'
	option wpa_disable_eapol_key_retries '1'

Hey all,

I'm using a Belkin RT3200, and I feel like I'm going insane because regardless of what version of Open WRT I'm flashing, it's stuck in this cycle where after starting up successfully, it reboots into recovery mode and loses all its settings.

I tried 22.03.1 and 22.03.2, and after flashing the image the first time it boots it shows that it is running the version I installed. But within 30 minutes it reboots into recovery and is back to 22.03.0.

I've included my logs from /sys/fs/pstore because I do see a crash/error in them, just not sure what to do with it. Any help would be so appreciated, I just want the router to be stable. :sob:

Seems like the main piece of useful information is: Unable to handle kernel NULL pointer dereference at virtual address 0000000000000034 ?

dmesg-ramoops-0

Oops#1 Part1
<6>[   14.390512] mt7530 mdio-bus:00 lan2: configuring for phy/gmii link mode
<6>[   14.400158] 8021q: adding VLAN 0 to HW filter on device lan2
<6>[   14.413189] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[   14.424454] br-lan: port 2(lan2) entered blocking state
<6>[   14.429748] br-lan: port 2(lan2) entered disabled state
<6>[   14.437943] device lan2 entered promiscuous mode
<6>[   14.445646] br-lan: port 2(lan2) entered blocking state
<6>[   14.450885] br-lan: port 2(lan2) entered forwarding state
<6>[   14.456447] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
<6>[   14.491546] mt7530 mdio-bus:00 lan3: configuring for phy/gmii link mode
<6>[   14.499146] 8021q: adding VLAN 0 to HW filter on device lan3
<6>[   14.511406] br-lan: port 3(lan3) entered blocking state
<6>[   14.516731] br-lan: port 3(lan3) entered disabled state
<6>[   14.527583] device lan3 entered promiscuous mode
<6>[   14.540749] mt7530 mdio-bus:00 lan4: configuring for phy/gmii link mode
<6>[   14.550098] 8021q: adding VLAN 0 to HW filter on device lan4
<6>[   14.554670] mt7530 mdio-bus:00 lan4: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[   14.561508] br-lan: port 4(lan4) entered blocking state
<6>[   14.568563] br-lan: port 4(lan4) entered disabled state
<6>[   14.575823] device lan4 entered promiscuous mode
<6>[   14.583071] br-lan: port 4(lan4) entered blocking state
<6>[   14.588349] br-lan: port 4(lan4) entered forwarding state
<6>[   14.604439] mt7530 mdio-bus:00 wan: configuring for phy/gmii link mode
<6>[   14.614860] 8021q: adding VLAN 0 to HW filter on device wan
<6>[   14.619482] mt7530 mdio-bus:00 wan: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[   14.627944] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
<6>[   17.102896] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[   17.110452] br-lan: port 1(lan1) entered blocking state
<6>[   17.115691] br-lan: port 1(lan1) entered forwarding state
<6>[  195.125672] br-lan: port 5(wlan0) entered blocking state
<6>[  195.131066] br-lan: port 5(wlan0) entered disabled state
<6>[  195.136616] device wlan0 entered promiscuous mode
<6>[  195.144737] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[  195.151305] br-lan: port 5(wlan0) entered blocking state
<6>[  195.156633] br-lan: port 5(wlan0) entered forwarding state
<6>[  382.339437] device wlan0 left promiscuous mode
<6>[  382.344049] br-lan: port 5(wlan0) entered disabled state
<6>[  382.950363] br-lan: port 5(wlan0) entered blocking state
<6>[  382.955759] br-lan: port 5(wlan0) entered disabled state
<6>[  382.961380] device wlan0 entered promiscuous mode
<6>[  382.966286] br-lan: port 5(wlan0) entered blocking state
<6>[  382.971659] br-lan: port 5(wlan0) entered forwarding state
<6>[  382.980005] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[  384.309943] br-lan: port 6(wlan1) entered blocking state
<6>[  384.315313] br-lan: port 6(wlan1) entered disabled state
<6>[  384.320890] device wlan1 entered promiscuous mode
<6>[  384.325703] br-lan: port 6(wlan1) entered blocking state
<6>[  384.331109] br-lan: port 6(wlan1) entered forwarding state
<6>[  384.339926] br-lan: port 6(wlan1) entered disabled state
<6>[  385.054371] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[  385.061072] br-lan: port 6(wlan1) entered blocking state
<6>[  385.066414] br-lan: port 6(wlan1) entered forwarding state
<6>[  476.275610] device wlan0 left promiscuous mode
<6>[  476.280256] br-lan: port 5(wlan0) entered disabled state
<6>[  476.318174] device wlan1 left promiscuous mode
<6>[  476.322769] br-lan: port 6(wlan1) entered disabled state
<6>[  476.826761] br-lan: port 5(wlan0) entered blocking state
<6>[  476.832117] br-lan: port 5(wlan0) entered disabled state
<6>[  476.837695] device wlan0 entered promiscuous mode
<6>[  476.842547] br-lan: port 5(wlan0) entered blocking state
<6>[  476.847990] br-lan: port 5(wlan0) entered forwarding state
<6>[  476.882728] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[  477.179993] br-lan: port 6(wlan1) entered blocking state
<6>[  477.185318] br-lan: port 6(wlan1) entered disabled state
<6>[  477.191045] device wlan1 entered promiscuous mode
<6>[  477.195890] br-lan: port 6(wlan1) entered blocking state
<6>[  477.201326] br-lan: port 6(wlan1) entered forwarding state
<6>[  477.387089] br-lan: port 6(wlan1) entered disabled state
<6>[  477.986435] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[  477.993170] br-lan: port 6(wlan1) entered blocking state
<6>[  477.998568] br-lan: port 6(wlan1) entered forwarding state
<6>[  535.428028] device wlan0 left promiscuous mode
<6>[  535.432599] br-lan: port 5(wlan0) entered disabled state
<6>[  535.980159] br-lan: port 5(wlan0) entered blocking state
<6>[  535.985508] br-lan: port 5(wlan0) entered disabled state
<6>[  535.991172] device wlan0 entered promiscuous mode
<6>[  535.996081] br-lan: port 5(wlan0) entered blocking state
<6>[  536.001498] br-lan: port 5(wlan0) entered forwarding state
<6>[  536.037065] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[ 1681.985003] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 1681.990319] br-lan: port 2(lan2) entered disabled state
<6>[ 1684.240141] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 1684.247774] br-lan: port 2(lan2) entered blocking state
<6>[ 1684.253010] br-lan: port 2(lan2) entered forwarding state
<1>[ 1750.543391] Unable to handle kernel NULL pointer dereference at virtual address 0000000000000034
<1>[ 1750.552321] Mem abort info:
<1>[ 1750.555446]   ESR = 0x96000005
<1>[ 1750.558510]   EC = 0x25: DABT (current EL), IL = 32 bits
<1>[ 1750.563820]   SET = 0, FnV = 0
<1>[ 1750.567030]   EA = 0, S1PTW = 0
<1>[ 1750.570185] Data abort info:
<1>[ 1750.573072]   ISV = 0, ISS = 0x00000005
<1>[ 1750.576937]   CM = 0, WnR = 0
<1>[ 1750.579909] user pgtable: 4k pages, 39-bit VAs, pgdp=0000000042b5c000
<1>[ 1750.586374] [0000000000000034] pgd=0000000000000000, p4d=0000000000000000, pud=0000000000000000
<0>[ 1750.595337] Internal error: Oops: 96000005 [#1] SMP
<7>[ 1750.600314] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c hwmon crc_ccitt compat seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
<7>[ 1750.659322] CPU: 0 PID: 1992 Comm: hostapd Tainted: G S                5.10.146 #0
<7>[ 1750.666885] Hardware name: Linksys E8450 (UBI) (DT)
<7>[ 1750.671763] pstate: 00000005 (nzcv daif -PAN -UAO -TCO BTYPE=--)
<7>[ 1750.677766] pc : 0xffffffc010800a2c
<7>[ 1750.681249] lr : 0xffffffc010800f50
<7>[ 1750.684732] sp : ffffffc01180b870
<7>[ 1750.688041] x29: ffffffc01180b870 x28: ffffff8000e04380 
<7>[ 1750.693355] x27: ffffffc01180bdf0 x26: 0000000000000000 
<7>[ 1750.698668] x25: ffffffc010ab6ec0 x24: ffffffc0088b6050 
<7>[ 1750.703982] x23: ffffffc01180ba98 x22: 0000000000000002 
<7>[ 1750.709294] x21: ffffffc01180ba30 x20: ffffff80025ac8d0 
<7>[ 1750.714608] x19: ffffff80021683a0 x18: 0000000000000000 
<7>[ 1750.719921] x17: 0000000000000000 x16: 0000000000000000 
<7>[ 1750.725234] x15: 0000007f807681a0 x14: 0000a4270000a403 
<7>[ 1750.730547] x13: 0081010102f25000 x12: 0000000000000040 
<7>[ 1750.735860] x11: ffffff800042d240 x10: ffffff800042d242 
<7>[ 1750.741173] x9 : 0000000000000000 x8 : ffffff800150b9b0 
<7>[ 1750.746485] x7 : 0000000000000000 x6 : 000000000000003f 
<7>[ 1750.751798] x5 : ffffffc0088b7d70 x4 : 4000000000000000 
<7>[ 1750.757112] x3 : 4000000000000000 x2 : ffffff8000e04380 
<7>[ 1750.762425] x1 : 4000000000000000 x0 : 4000000000000000 
<7>[ 1750.767738] Call trace:
<7>[ 1750.770182]  0xffffffc010800a2c
<7>[ 1750.773318]  0xffffffc010800f50
<7>[ 1750.776454]  0xffffffc010800f94
<7>[ 1750.779605]  0xffffffc008895884 [cfg80211@000000002925bf50+0x44000]
<7>[ 1750.785866]  0xffffffc0106bf15c
<7>[ 1750.789002]  0xffffffc0106bf500
<7>[ 1750.792139]  0xffffffc0106be358
<7>[ 1750.795275]  0xffffffc0106bead4
<7>[ 1750.798411]  0xffffffc0106bdb84
<7>[ 1750.801547]  0xffffffc0106bde10
<7>[ 1750.804684]  0xffffffc01062ec30
<7>[ 1750.807819]  0xffffffc010631f88
<7>[ 1750.810956]  0xffffffc010632054
<7>[ 1750.814092]  0xffffffc0106320c0
<7>[ 1750.817228]  0xffffffc010010f30
<7>[ 1750.820364]  0xffffffc010010ffc
<7>[ 1750.823501]  0xffffffc0107fdae4
<7>[ 1750.826636]  0xffffffc0107fdf00
<7>[ 1750.829772]  0xffffffc0100025c8
<0>[ 1750.832917] Code: a94153f3 a9425bf5 a8c87bfd d65f03c0 (b9403401) 
<4>[ 1750.839006] ---[ end trace 523ca7a24917f315 ]---

dmesg-ramoops-1

Panic#2 Part1
<6>[   14.424454] br-lan: port 2(lan2) entered blocking state
<6>[   14.429748] br-lan: port 2(lan2) entered disabled state
<6>[   14.437943] device lan2 entered promiscuous mode
<6>[   14.445646] br-lan: port 2(lan2) entered blocking state
<6>[   14.450885] br-lan: port 2(lan2) entered forwarding state
<6>[   14.456447] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
<6>[   14.491546] mt7530 mdio-bus:00 lan3: configuring for phy/gmii link mode
<6>[   14.499146] 8021q: adding VLAN 0 to HW filter on device lan3
<6>[   14.511406] br-lan: port 3(lan3) entered blocking state
<6>[   14.516731] br-lan: port 3(lan3) entered disabled state
<6>[   14.527583] device lan3 entered promiscuous mode
<6>[   14.540749] mt7530 mdio-bus:00 lan4: configuring for phy/gmii link mode
<6>[   14.550098] 8021q: adding VLAN 0 to HW filter on device lan4
<6>[   14.554670] mt7530 mdio-bus:00 lan4: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[   14.561508] br-lan: port 4(lan4) entered blocking state
<6>[   14.568563] br-lan: port 4(lan4) entered disabled state
<6>[   14.575823] device lan4 entered promiscuous mode
<6>[   14.583071] br-lan: port 4(lan4) entered blocking state
<6>[   14.588349] br-lan: port 4(lan4) entered forwarding state
<6>[   14.604439] mt7530 mdio-bus:00 wan: configuring for phy/gmii link mode
<6>[   14.614860] 8021q: adding VLAN 0 to HW filter on device wan
<6>[   14.619482] mt7530 mdio-bus:00 wan: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[   14.627944] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
<6>[   17.102896] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[   17.110452] br-lan: port 1(lan1) entered blocking state
<6>[   17.115691] br-lan: port 1(lan1) entered forwarding state
<6>[  195.125672] br-lan: port 5(wlan0) entered blocking state
<6>[  195.131066] br-lan: port 5(wlan0) entered disabled state
<6>[  195.136616] device wlan0 entered promiscuous mode
<6>[  195.144737] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[  195.151305] br-lan: port 5(wlan0) entered blocking state
<6>[  195.156633] br-lan: port 5(wlan0) entered forwarding state
<6>[  382.339437] device wlan0 left promiscuous mode
<6>[  382.344049] br-lan: port 5(wlan0) entered disabled state
<6>[  382.950363] br-lan: port 5(wlan0) entered blocking state
<6>[  382.955759] br-lan: port 5(wlan0) entered disabled state
<6>[  382.961380] device wlan0 entered promiscuous mode
<6>[  382.966286] br-lan: port 5(wlan0) entered blocking state
<6>[  382.971659] br-lan: port 5(wlan0) entered forwarding state
<6>[  382.980005] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[  384.309943] br-lan: port 6(wlan1) entered blocking state
<6>[  384.315313] br-lan: port 6(wlan1) entered disabled state
<6>[  384.320890] device wlan1 entered promiscuous mode
<6>[  384.325703] br-lan: port 6(wlan1) entered blocking state
<6>[  384.331109] br-lan: port 6(wlan1) entered forwarding state
<6>[  384.339926] br-lan: port 6(wlan1) entered disabled state
<6>[  385.054371] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[  385.061072] br-lan: port 6(wlan1) entered blocking state
<6>[  385.066414] br-lan: port 6(wlan1) entered forwarding state
<6>[  476.275610] device wlan0 left promiscuous mode
<6>[  476.280256] br-lan: port 5(wlan0) entered disabled state
<6>[  476.318174] device wlan1 left promiscuous mode
<6>[  476.322769] br-lan: port 6(wlan1) entered disabled state
<6>[  476.826761] br-lan: port 5(wlan0) entered blocking state
<6>[  476.832117] br-lan: port 5(wlan0) entered disabled state
<6>[  476.837695] device wlan0 entered promiscuous mode
<6>[  476.842547] br-lan: port 5(wlan0) entered blocking state
<6>[  476.847990] br-lan: port 5(wlan0) entered forwarding state
<6>[  476.882728] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[  477.179993] br-lan: port 6(wlan1) entered blocking state
<6>[  477.185318] br-lan: port 6(wlan1) entered disabled state
<6>[  477.191045] device wlan1 entered promiscuous mode
<6>[  477.195890] br-lan: port 6(wlan1) entered blocking state
<6>[  477.201326] br-lan: port 6(wlan1) entered forwarding state
<6>[  477.387089] br-lan: port 6(wlan1) entered disabled state
<6>[  477.986435] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[  477.993170] br-lan: port 6(wlan1) entered blocking state
<6>[  477.998568] br-lan: port 6(wlan1) entered forwarding state
<6>[  535.428028] device wlan0 left promiscuous mode
<6>[  535.432599] br-lan: port 5(wlan0) entered disabled state
<6>[  535.980159] br-lan: port 5(wlan0) entered blocking state
<6>[  535.985508] br-lan: port 5(wlan0) entered disabled state
<6>[  535.991172] device wlan0 entered promiscuous mode
<6>[  535.996081] br-lan: port 5(wlan0) entered blocking state
<6>[  536.001498] br-lan: port 5(wlan0) entered forwarding state
<6>[  536.037065] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[ 1681.985003] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 1681.990319] br-lan: port 2(lan2) entered disabled state
<6>[ 1684.240141] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 1684.247774] br-lan: port 2(lan2) entered blocking state
<6>[ 1684.253010] br-lan: port 2(lan2) entered forwarding state
<1>[ 1750.543391] Unable to handle kernel NULL pointer dereference at virtual address 0000000000000034
<1>[ 1750.552321] Mem abort info:
<1>[ 1750.555446]   ESR = 0x96000005
<1>[ 1750.558510]   EC = 0x25: DABT (current EL), IL = 32 bits
<1>[ 1750.563820]   SET = 0, FnV = 0
<1>[ 1750.567030]   EA = 0, S1PTW = 0
<1>[ 1750.570185] Data abort info:
<1>[ 1750.573072]   ISV = 0, ISS = 0x00000005
<1>[ 1750.576937]   CM = 0, WnR = 0
<1>[ 1750.579909] user pgtable: 4k pages, 39-bit VAs, pgdp=0000000042b5c000
<1>[ 1750.586374] [0000000000000034] pgd=0000000000000000, p4d=0000000000000000, pud=0000000000000000
<0>[ 1750.595337] Internal error: Oops: 96000005 [#1] SMP
<7>[ 1750.600314] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c hwmon crc_ccitt compat seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
<7>[ 1750.659322] CPU: 0 PID: 1992 Comm: hostapd Tainted: G S                5.10.146 #0
<7>[ 1750.666885] Hardware name: Linksys E8450 (UBI) (DT)
<7>[ 1750.671763] pstate: 00000005 (nzcv daif -PAN -UAO -TCO BTYPE=--)
<7>[ 1750.677766] pc : 0xffffffc010800a2c
<7>[ 1750.681249] lr : 0xffffffc010800f50
<7>[ 1750.684732] sp : ffffffc01180b870
<7>[ 1750.688041] x29: ffffffc01180b870 x28: ffffff8000e04380 
<7>[ 1750.693355] x27: ffffffc01180bdf0 x26: 0000000000000000 
<7>[ 1750.698668] x25: ffffffc010ab6ec0 x24: ffffffc0088b6050 
<7>[ 1750.703982] x23: ffffffc01180ba98 x22: 0000000000000002 
<7>[ 1750.709294] x21: ffffffc01180ba30 x20: ffffff80025ac8d0 
<7>[ 1750.714608] x19: ffffff80021683a0 x18: 0000000000000000 
<7>[ 1750.719921] x17: 0000000000000000 x16: 0000000000000000 
<7>[ 1750.725234] x15: 0000007f807681a0 x14: 0000a4270000a403 
<7>[ 1750.730547] x13: 0081010102f25000 x12: 0000000000000040 
<7>[ 1750.735860] x11: ffffff800042d240 x10: ffffff800042d242 
<7>[ 1750.741173] x9 : 0000000000000000 x8 : ffffff800150b9b0 
<7>[ 1750.746485] x7 : 0000000000000000 x6 : 000000000000003f 
<7>[ 1750.751798] x5 : ffffffc0088b7d70 x4 : 4000000000000000 
<7>[ 1750.757112] x3 : 4000000000000000 x2 : ffffff8000e04380 
<7>[ 1750.762425] x1 : 4000000000000000 x0 : 4000000000000000 
<7>[ 1750.767738] Call trace:
<7>[ 1750.770182]  0xffffffc010800a2c
<7>[ 1750.773318]  0xffffffc010800f50
<7>[ 1750.776454]  0xffffffc010800f94
<7>[ 1750.779605]  0xffffffc008895884 [cfg80211@000000002925bf50+0x44000]
<7>[ 1750.785866]  0xffffffc0106bf15c
<7>[ 1750.789002]  0xffffffc0106bf500
<7>[ 1750.792139]  0xffffffc0106be358
<7>[ 1750.795275]  0xffffffc0106bead4
<7>[ 1750.798411]  0xffffffc0106bdb84
<7>[ 1750.801547]  0xffffffc0106bde10
<7>[ 1750.804684]  0xffffffc01062ec30
<7>[ 1750.807819]  0xffffffc010631f88
<7>[ 1750.810956]  0xffffffc010632054
<7>[ 1750.814092]  0xffffffc0106320c0
<7>[ 1750.817228]  0xffffffc010010f30
<7>[ 1750.820364]  0xffffffc010010ffc
<7>[ 1750.823501]  0xffffffc0107fdae4
<7>[ 1750.826636]  0xffffffc0107fdf00
<7>[ 1750.829772]  0xffffffc0100025c8
<0>[ 1750.832917] Code: a94153f3 a9425bf5 a8c87bfd d65f03c0 (b9403401) 
<4>[ 1750.839006] ---[ end trace 523ca7a24917f315 ]---
<0>[ 1750.858454] Kernel panic - not syncing: Oops: Fatal exception
<2>[ 1750.864203] SMP: stopping secondary CPUs
<0>[ 1750.868124] Kernel Offset: disabled
<0>[ 1750.871610] CPU features: 0x00000002,04002004
<0>[ 1750.875960] Memory Limit: none

So to decode this stacktrace we need the matching debugging information. As it is kernel version 5.10.146 it probably belongs to 22.03.2 release, right?
I've manually decoded the stacktrace using kernel-debug.tar.zst and aarch64-openwrt-linux-addr2line from the toolchain. The result doesn't make too much sense, however...

0xffffffc010800a2c linux-5.10.146/net/core/dev.c:11422
0xffffffc010800f50 linux-5.10.146/arch/arm64/kernel/entry-common.c:73
0xffffffc010800f94 linux-5.10.146/arch/arm64/kernel/entry-common.c:70 (discriminator 8)
0xffffffc008895884 [cfg80211@000000002925bf50+0x44000]
0xffffffc0106bf15c linux-5.10.146/./include/linux/list.h:840
0xffffffc0106bf500 linux-5.10.146/./include/linux/rhashtable.h:199
0xffffffc0106be358 linux-5.10.146/net/netlink/af_netlink.c:1744
0xffffffc0106bead4 linux-5.10.146/net/netlink/af_netlink.c:1623
0xffffffc0106bdb84 linux-5.10.146/net/netlink/af_netlink.c:2358
0xffffffc0106bde10 linux-5.10.146/net/netlink/af_netlink.c:835
0xffffffc01062ec30 linux-5.10.146/drivers/nvmem/core.c:380
0xffffffc010631f88 linux-5.10.146/net/socket.c:3378
0xffffffc010632054 linux-5.10.146/./include/asm-generic/bitops/non-atomic.h:106
0xffffffc0106320c0 linux-5.10.146/./arch/arm64/include/asm/uaccess.h:72
0xffffffc010010f30 linux-5.10.146/./arch/arm64/include/asm/current.h:19
0xffffffc010010ffc linux-5.10.146/arch/arm64/kernel/syscall.c:195
0xffffffc0107fdae4 linux-5.10.146/drivers/mtd/nand/mtk_bmt_nmbm.c:162
0xffffffc0107fdf00 linux-5.10.146/drivers/mtd/nand/mtk_bmt_nmbm.c:1718
0xffffffc0100025c8 linux-5.10.146/arch/arm64/kernel/entry.S:690

All this involvement of mtk_bmt_nmbm in the very beginning is really weird. You are using the UBI variant, right? Because if so, we can be 100% sure that I have now failed decoding this stack trace, because nmbm isn't used when using the UBI variant of this device.

1 Like

Thank you for the help! I've never had to debug one of these, so apologies for the missing information.

The last version I had flashed it with was 22.03.2, and I am using the UBI variant, so I'm not sure what is going on either. :\

Where is the other relevant debugging information located? I dug around the system but nothing seemed to be written in /sys/kernel/debug.

To allow reproducing the issue it would be great if you can share your configuration, esp. network, firewall, wed_enable=Y/N, wireless. Of course, remove passwords and sensitive information.

Thank you!

WED is not enabled.
Currently running: 22.03.2 - r19803-9a599fee93
Only command in my run on startup is:

echo schedutil > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor

Network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdde:ee5c:bc3d::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

Firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

Wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key '*******'
	option ssid ' SkyNet-2g'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'SkyNet'
	option encryption 'psk2'
	option key '*******'

ubootenv

config ubootenv
	option dev '/dev/ubi0_0'
	option offset '0x0'
	option envsize '0x1f000'
	option secsize '0x1f000'
	option numsec '1'

config ubootenv
	option dev '/dev/ubi0_1'
	option offset '0x0'
	option envsize '0x1f000'
	option secsize '0x1f000'
	option numsec '1'

System

config system
	option hostname 'OpenWrt'
	option timezone 'UTC'
	option ttylogin '0'
	option log_size '64'
	option urandom_seed '0'

config timeserver 'ntp'
	option enabled '1'
	option enable_server '0'
	list server '0.openwrt.pool.ntp.org'
	list server '1.openwrt.pool.ntp.org'
	list server '2.openwrt.pool.ntp.org'
	list server '3.openwrt.pool.ntp.org'

config led 'led_wan'
	option name 'WAN'
	option sysfs 'inet:blue'
	option trigger 'netdev'
	option mode 'link tx rx'
	option dev 'wan'

If there is more than one router/access point wpa3 basically requires fast roaming (802.11r) for seamless hand-over, e.g while on a VoWIFI call.
Fast Roaming has a long standing kernel problem (discussed here:
Daemon.err hostapd: nl80211: kernel reports: key addition failed - is this a problem? - #52 by andybjackson ),
Hence I'm still on wpa2.
Once fast roaming is fixed I'll give wpa3 another try.

@umayer, in my recent experience, WPA3 & WPA2 are the same with respect to the nl80211 kernel problem you reference. I have therefore switched to WPA3 for the enhanced security it offers.

It was stable for 4 hours last night, then crashed once I had gone to bed. The odd thing is the error in the /sys/fs/pstore logs looks different.

dmesg-ramoops-0

Oops#1 Part1
<6>[   15.013342] br-lan: port 5(wlan1) entered blocking state
<6>[   15.018748] br-lan: port 5(wlan1) entered disabled state
<6>[   15.024298] device wlan1 entered promiscuous mode
<6>[   15.069852] br-lan: port 6(wlan0) entered blocking state
<6>[   15.075208] br-lan: port 6(wlan0) entered disabled state
<6>[   15.080790] device wlan0 entered promiscuous mode
<6>[   15.085690] br-lan: port 6(wlan0) entered blocking state
<6>[   15.091002] br-lan: port 6(wlan0) entered forwarding state
<6>[   15.125480] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[   15.871530] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[   15.878161] br-lan: port 5(wlan1) entered blocking state
<6>[   15.883488] br-lan: port 5(wlan1) entered forwarding state
<6>[ 1061.597432] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 1061.602727] br-lan: port 2(lan2) entered disabled state
<6>[ 1063.868744] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 1063.876563] br-lan: port 2(lan2) entered blocking state
<6>[ 1063.881850] br-lan: port 2(lan2) entered forwarding state
<6>[ 1064.644439] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 1064.649432] br-lan: port 2(lan2) entered disabled state
<6>[ 1066.841309] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 1066.848915] br-lan: port 2(lan2) entered blocking state
<6>[ 1066.854154] br-lan: port 2(lan2) entered forwarding state
<6>[ 2128.303168] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 2128.308109] br-lan: port 2(lan2) entered disabled state
<6>[ 2130.592091] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 2130.599676] br-lan: port 2(lan2) entered blocking state
<6>[ 2130.604920] br-lan: port 2(lan2) entered forwarding state
<6>[13160.595563] device wlan0 left promiscuous mode
<6>[13160.600151] br-lan: port 6(wlan0) entered disabled state
<6>[13160.701252] device wlan1 left promiscuous mode
<6>[13160.705875] br-lan: port 5(wlan1) entered disabled state
<6>[13161.495378] br-lan: port 5(wlan1) entered blocking state
<6>[13161.500858] br-lan: port 5(wlan1) entered disabled state
<6>[13161.506483] device wlan1 entered promiscuous mode
<6>[13161.511325] br-lan: port 5(wlan1) entered blocking state
<6>[13161.516708] br-lan: port 5(wlan1) entered forwarding state
<6>[13161.653429] br-lan: port 5(wlan1) entered disabled state
<6>[13162.356261] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[13162.362871] br-lan: port 5(wlan1) entered blocking state
<6>[13162.368247] br-lan: port 5(wlan1) entered forwarding state
<6>[13169.328486] br-lan: port 6(wlan0) entered blocking state
<6>[13169.333919] br-lan: port 6(wlan0) entered disabled state
<6>[13169.339497] device wlan0 entered promiscuous mode
<6>[13169.371403] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13169.377970] br-lan: port 6(wlan0) entered blocking state
<6>[13169.383316] br-lan: port 6(wlan0) entered forwarding state
<6>[13288.899600] device wlan0 left promiscuous mode
<6>[13288.904296] br-lan: port 6(wlan0) entered disabled state
<6>[13289.394273] br-lan: port 6(wlan0) entered blocking state
<6>[13289.399620] br-lan: port 6(wlan0) entered disabled state
<6>[13289.405303] device wlan0 entered promiscuous mode
<6>[13289.410174] br-lan: port 6(wlan0) entered blocking state
<6>[13289.415542] br-lan: port 6(wlan0) entered forwarding state
<6>[13289.931934] br-lan: port 6(wlan0) entered disabled state
<6>[13290.839702] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13290.846288] br-lan: port 6(wlan0) entered blocking state
<6>[13290.851607] br-lan: port 6(wlan0) entered forwarding state
<6>[13320.382987] device wlan0 left promiscuous mode
<6>[13320.387537] br-lan: port 6(wlan0) entered disabled state
<6>[13322.296087] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13390.258052] br-lan: port 6(wlan0) entered blocking state
<6>[13390.263441] br-lan: port 6(wlan0) entered disabled state
<6>[13390.268997] device wlan0 entered promiscuous mode
<6>[13390.273857] br-lan: port 6(wlan0) entered blocking state
<6>[13390.279171] br-lan: port 6(wlan0) entered forwarding state
<6>[13390.781181] br-lan: port 6(wlan0) entered disabled state
<6>[13391.734615] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13391.741275] br-lan: port 6(wlan0) entered blocking state
<6>[13391.746599] br-lan: port 6(wlan0) entered forwarding state
<1>[15538.962538] Unable to handle kernel NULL pointer dereference at virtual address 0000000000000070
<1>[15538.971324] Mem abort info:
<1>[15538.974108]   ESR = 0x96000006
<1>[15538.977153]   EC = 0x25: DABT (current EL), IL = 32 bits
<1>[15538.982454]   SET = 0, FnV = 0
<1>[15538.985498]   EA = 0, S1PTW = 0
<1>[15538.988628] Data abort info:
<1>[15538.991498]   ISV = 0, ISS = 0x00000006
<1>[15538.995324]   CM = 0, WnR = 0
<1>[15538.998284] user pgtable: 4k pages, 39-bit VAs, pgdp=0000000042b09000
<1>[15539.004713] [0000000000000070] pgd=0000000042b49003, p4d=0000000042b49003, pud=0000000042b49003, pmd=0000000000000000
<0>[15539.015321] Internal error: Oops: 96000006 [#1] SMP
<7>[15539.020189] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c hwmon crc_ccitt compat seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
<7>[15539.079075] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G S                5.10.146 #0
<7>[15539.086547] Hardware name: Linksys E8450 (UBI) (DT)
<7>[15539.091417] pstate: 20000085 (nzCv daIf -PAN -UAO -TCO BTYPE=--)
<7>[15539.097416] pc : 0xffffffc01016f4c0
<7>[15539.100894] lr : 0xffffffc010170088
<7>[15539.104372] sp : ffffffc010b2b200
<7>[15539.107677] x29: ffffffc010b2b200 x28: 0000000000000000 
<7>[15539.112982] x27: ffffff8002560cf0 x26: 0000000000000056 
<7>[15539.118286] x25: 000000000000204e x24: 0000000000000000 
<7>[15539.123590] x23: 0000000000000a20 x22: ffffff8000025a00 
<7>[15539.128894] x21: fffffffeffee0380 x20: ffffff801febd4d0 
<7>[15539.134199] x19: 4000000000000000 x18: ffffff8002251360 
<7>[15539.139503] x17: 0000000000000000 x16: 0000000000000001 
<7>[15539.144807] x15: ffffff80021c90a6 x14: 0000000000000014 
<7>[15539.150111] x13: 0000000000000014 x12: b7f1415221f8b04a 
<7>[15539.155416] x11: 75deb72e69b03c76 x10: c22feb17684ed44a 
<7>[15539.160720] x9 : 380ea245d1ff10c0 x8 : ffffff8003a365f0 
<7>[15539.166024] x7 : 00000000fffffffe x6 : 0000000000000000 
<7>[15539.171328] x5 : fffffffeffee03a0 x4 : 0000000000000000 
<7>[15539.176632] x3 : 0000000000000000 x2 : 0000000000000000 
<7>[15539.181936] x1 : 0000000000000070 x0 : 000000000192ee44 
<7>[15539.187240] Call trace:
<7>[15539.189678]  0xffffffc01016f4c0
<7>[15539.192809]  0xffffffc010170088
<7>[15539.195940]  0xffffffc01063be4c
<7>[15539.199071]  0xffffffc0106450d8
<7>[15539.202202]  0xffffffc010710a24
<7>[15539.205332]  0xffffffc0107bd8dc
<7>[15539.208463]  0xffffffc0107bd374
<7>[15539.211594]  0xffffffc010659afc
<7>[15539.214724]  0xffffffc010659bc0
<7>[15539.217857]  0xffffffc010659fe0
<7>[15539.220987]  0xffffffc01065ab14
<7>[15539.224118]  0xffffffc01065b0e0
<7>[15539.227249]  0xffffffc0107cb450
<7>[15539.230379]  0xffffffc0107cb5d0
<7>[15539.233510]  0xffffffc0107cb6b8
<7>[15539.236641]  0xffffffc0107cb960
<7>[15539.239772]  0xffffffc0107c7cd4
<7>[15539.242903]  0xffffffc01065a510
<7>[15539.246034]  0xffffffc01065af00
<7>[15539.249165]  0xffffffc01065b0e0
<7>[15539.252296]  0xffffffc01076b5a8
<7>[15539.255427]  0xffffffc01076d1a8
<7>[15539.258557]  0xffffffc01076d350
<7>[15539.261688]  0xffffffc01076d440
<7>[15539.264818]  0xffffffc01076c428
<7>[15539.267950]  0xffffffc01076de80
<7>[15539.271080]  0xffffffc01076e0c0
<7>[15539.274211]  0xffffffc01076e8f8
<7>[15539.277342]  0xffffffc01065c0b8
<7>[15539.280474]  0xffffffc01065c2a4
<7>[15539.283604]  0xffffffc01065c7a8
<7>[15539.286735]  0xffffffc01065d318
<7>[15539.289867]  0xffffffc01065d914
<7>[15539.292998]  0xffffffc0106a3a60
<7>[15539.296129]  0xffffffc01065cb04
<7>[15539.299260]  0xffffffc01065cdd4
<7>[15539.302391]  0xffffffc010000924
<7>[15539.305522]  0xffffffc01002eb98
<7>[15539.308653]  0xffffffc01007d9f0
<7>[15539.311784]  0xffffffc0103fa23c
<7>[15539.314915]  0xffffffc0100023c8
<7>[15539.318046]  0xffffffc010801708
<7>[15539.321178]  0xffffffc01005c014
<7>[15539.324309]  0xffffffc01005c1f4
<7>[15539.327441]  0xffffffc010801e68
<7>[15539.330571]  0xffffffc0109808d4
<7>[15539.333702]  0xffffffc010980d64
<0>[15539.336838] Code: f9400293 b4000373 b9402ac1 f9400680 (f8616a61) 
<4>[15539.342922] ---[ end trace 1d080256a0e270b4 ]---

dmesg-ramoops-1

Panic#2 Part1
<6>[   15.075208] br-lan: port 6(wlan0) entered disabled state
<6>[   15.080790] device wlan0 entered promiscuous mode
<6>[   15.085690] br-lan: port 6(wlan0) entered blocking state
<6>[   15.091002] br-lan: port 6(wlan0) entered forwarding state
<6>[   15.125480] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[   15.871530] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[   15.878161] br-lan: port 5(wlan1) entered blocking state
<6>[   15.883488] br-lan: port 5(wlan1) entered forwarding state
<6>[ 1061.597432] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 1061.602727] br-lan: port 2(lan2) entered disabled state
<6>[ 1063.868744] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 1063.876563] br-lan: port 2(lan2) entered blocking state
<6>[ 1063.881850] br-lan: port 2(lan2) entered forwarding state
<6>[ 1064.644439] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 1064.649432] br-lan: port 2(lan2) entered disabled state
<6>[ 1066.841309] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 1066.848915] br-lan: port 2(lan2) entered blocking state
<6>[ 1066.854154] br-lan: port 2(lan2) entered forwarding state
<6>[ 2128.303168] mt7530 mdio-bus:00 lan2: Link is Down
<6>[ 2128.308109] br-lan: port 2(lan2) entered disabled state
<6>[ 2130.592091] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 2130.599676] br-lan: port 2(lan2) entered blocking state
<6>[ 2130.604920] br-lan: port 2(lan2) entered forwarding state
<6>[13160.595563] device wlan0 left promiscuous mode
<6>[13160.600151] br-lan: port 6(wlan0) entered disabled state
<6>[13160.701252] device wlan1 left promiscuous mode
<6>[13160.705875] br-lan: port 5(wlan1) entered disabled state
<6>[13161.495378] br-lan: port 5(wlan1) entered blocking state
<6>[13161.500858] br-lan: port 5(wlan1) entered disabled state
<6>[13161.506483] device wlan1 entered promiscuous mode
<6>[13161.511325] br-lan: port 5(wlan1) entered blocking state
<6>[13161.516708] br-lan: port 5(wlan1) entered forwarding state
<6>[13161.653429] br-lan: port 5(wlan1) entered disabled state
<6>[13162.356261] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[13162.362871] br-lan: port 5(wlan1) entered blocking state
<6>[13162.368247] br-lan: port 5(wlan1) entered forwarding state
<6>[13169.328486] br-lan: port 6(wlan0) entered blocking state
<6>[13169.333919] br-lan: port 6(wlan0) entered disabled state
<6>[13169.339497] device wlan0 entered promiscuous mode
<6>[13169.371403] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13169.377970] br-lan: port 6(wlan0) entered blocking state
<6>[13169.383316] br-lan: port 6(wlan0) entered forwarding state
<6>[13288.899600] device wlan0 left promiscuous mode
<6>[13288.904296] br-lan: port 6(wlan0) entered disabled state
<6>[13289.394273] br-lan: port 6(wlan0) entered blocking state
<6>[13289.399620] br-lan: port 6(wlan0) entered disabled state
<6>[13289.405303] device wlan0 entered promiscuous mode
<6>[13289.410174] br-lan: port 6(wlan0) entered blocking state
<6>[13289.415542] br-lan: port 6(wlan0) entered forwarding state
<6>[13289.931934] br-lan: port 6(wlan0) entered disabled state
<6>[13290.839702] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13290.846288] br-lan: port 6(wlan0) entered blocking state
<6>[13290.851607] br-lan: port 6(wlan0) entered forwarding state
<6>[13320.382987] device wlan0 left promiscuous mode
<6>[13320.387537] br-lan: port 6(wlan0) entered disabled state
<6>[13322.296087] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13390.258052] br-lan: port 6(wlan0) entered blocking state
<6>[13390.263441] br-lan: port 6(wlan0) entered disabled state
<6>[13390.268997] device wlan0 entered promiscuous mode
<6>[13390.273857] br-lan: port 6(wlan0) entered blocking state
<6>[13390.279171] br-lan: port 6(wlan0) entered forwarding state
<6>[13390.781181] br-lan: port 6(wlan0) entered disabled state
<6>[13391.734615] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[13391.741275] br-lan: port 6(wlan0) entered blocking state
<6>[13391.746599] br-lan: port 6(wlan0) entered forwarding state
<1>[15538.962538] Unable to handle kernel NULL pointer dereference at virtual address 0000000000000070
<1>[15538.971324] Mem abort info:
<1>[15538.974108]   ESR = 0x96000006
<1>[15538.977153]   EC = 0x25: DABT (current EL), IL = 32 bits
<1>[15538.982454]   SET = 0, FnV = 0
<1>[15538.985498]   EA = 0, S1PTW = 0
<1>[15538.988628] Data abort info:
<1>[15538.991498]   ISV = 0, ISS = 0x00000006
<1>[15538.995324]   CM = 0, WnR = 0
<1>[15538.998284] user pgtable: 4k pages, 39-bit VAs, pgdp=0000000042b09000
<1>[15539.004713] [0000000000000070] pgd=0000000042b49003, p4d=0000000042b49003, pud=0000000042b49003, pmd=0000000000000000
<0>[15539.015321] Internal error: Oops: 96000006 [#1] SMP
<7>[15539.020189] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c hwmon crc_ccitt compat seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
<7>[15539.079075] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G S                5.10.146 #0
<7>[15539.086547] Hardware name: Linksys E8450 (UBI) (DT)
<7>[15539.091417] pstate: 20000085 (nzCv daIf -PAN -UAO -TCO BTYPE=--)
<7>[15539.097416] pc : 0xffffffc01016f4c0
<7>[15539.100894] lr : 0xffffffc010170088
<7>[15539.104372] sp : ffffffc010b2b200
<7>[15539.107677] x29: ffffffc010b2b200 x28: 0000000000000000 
<7>[15539.112982] x27: ffffff8002560cf0 x26: 0000000000000056 
<7>[15539.118286] x25: 000000000000204e x24: 0000000000000000 
<7>[15539.123590] x23: 0000000000000a20 x22: ffffff8000025a00 
<7>[15539.128894] x21: fffffffeffee0380 x20: ffffff801febd4d0 
<7>[15539.134199] x19: 4000000000000000 x18: ffffff8002251360 
<7>[15539.139503] x17: 0000000000000000 x16: 0000000000000001 
<7>[15539.144807] x15: ffffff80021c90a6 x14: 0000000000000014 
<7>[15539.150111] x13: 0000000000000014 x12: b7f1415221f8b04a 
<7>[15539.155416] x11: 75deb72e69b03c76 x10: c22feb17684ed44a 
<7>[15539.160720] x9 : 380ea245d1ff10c0 x8 : ffffff8003a365f0 
<7>[15539.166024] x7 : 00000000fffffffe x6 : 0000000000000000 
<7>[15539.171328] x5 : fffffffeffee03a0 x4 : 0000000000000000 
<7>[15539.176632] x3 : 0000000000000000 x2 : 0000000000000000 
<7>[15539.181936] x1 : 0000000000000070 x0 : 000000000192ee44 
<7>[15539.187240] Call trace:
<7>[15539.189678]  0xffffffc01016f4c0
<7>[15539.192809]  0xffffffc010170088
<7>[15539.195940]  0xffffffc01063be4c
<7>[15539.199071]  0xffffffc0106450d8
<7>[15539.202202]  0xffffffc010710a24
<7>[15539.205332]  0xffffffc0107bd8dc
<7>[15539.208463]  0xffffffc0107bd374
<7>[15539.211594]  0xffffffc010659afc
<7>[15539.214724]  0xffffffc010659bc0
<7>[15539.217857]  0xffffffc010659fe0
<7>[15539.220987]  0xffffffc01065ab14
<7>[15539.224118]  0xffffffc01065b0e0
<7>[15539.227249]  0xffffffc0107cb450
<7>[15539.230379]  0xffffffc0107cb5d0
<7>[15539.233510]  0xffffffc0107cb6b8
<7>[15539.236641]  0xffffffc0107cb960
<7>[15539.239772]  0xffffffc0107c7cd4
<7>[15539.242903]  0xffffffc01065a510
<7>[15539.246034]  0xffffffc01065af00
<7>[15539.249165]  0xffffffc01065b0e0
<7>[15539.252296]  0xffffffc01076b5a8
<7>[15539.255427]  0xffffffc01076d1a8
<7>[15539.258557]  0xffffffc01076d350
<7>[15539.261688]  0xffffffc01076d440
<7>[15539.264818]  0xffffffc01076c428
<7>[15539.267950]  0xffffffc01076de80
<7>[15539.271080]  0xffffffc01076e0c0
<7>[15539.274211]  0xffffffc01076e8f8
<7>[15539.277342]  0xffffffc01065c0b8
<7>[15539.280474]  0xffffffc01065c2a4
<7>[15539.283604]  0xffffffc01065c7a8
<7>[15539.286735]  0xffffffc01065d318
<7>[15539.289867]  0xffffffc01065d914
<7>[15539.292998]  0xffffffc0106a3a60
<7>[15539.296129]  0xffffffc01065cb04
<7>[15539.299260]  0xffffffc01065cdd4
<7>[15539.302391]  0xffffffc010000924
<7>[15539.305522]  0xffffffc01002eb98
<7>[15539.308653]  0xffffffc01007d9f0
<7>[15539.311784]  0xffffffc0103fa23c
<7>[15539.314915]  0xffffffc0100023c8
<7>[15539.318046]  0xffffffc010801708
<7>[15539.321178]  0xffffffc01005c014
<7>[15539.324309]  0xffffffc01005c1f4
<7>[15539.327441]  0xffffffc010801e68
<7>[15539.330571]  0xffffffc0109808d4
<7>[15539.333702]  0xffffffc010980d64
<0>[15539.336838] Code: f9400293 b4000373 b9402ac1 f9400680 (f8616a61) 
<4>[15539.342922] ---[ end trace 1d080256a0e270b4 ]---
<0>[15539.354813] Kernel panic - not syncing: Oops: Fatal exception in interrupt
<2>[15539.361682] SMP: stopping secondary CPUs
<0>[15539.365599] Kernel Offset: disabled
<0>[15539.369079] CPU features: 0x00000002,04002004
<0>[15539.373426] Memory Limit: none

You configuration looks innocent and almost identical to what I'm using here. No PPPoE, no flow offloading, no VLANs, ...
To know more, maybe try to build OpenWrt from source and enable kernel debug symbols. If you want, I can provide ready-made binaries for you. This will make the stack trace more understandable...

2 Likes

I do not disagree.
I'm using wpa2 because it has one round trip less in key exchange
(see https://wlan1nde.wordpress.com/2018/09/14/wpa3-improving-your-wlan-security/

WPA3-Personal Connection Establishment
The main difference to the WPA2 connection flow chart are the two extra authentication frames.

802.11r would reduce the handshake for transitions between APs to even less than the standard WPA2 key exchange, also for WPA3.

My experience in my environment is that the latency for WPA2 hand over without 802.11r is fast enough for most applications. WPA3 is notably worse for me (e.g. dropping calls on roaming).
Turning on 802.11r would alleviate the WPA3 latency issue, but due to the kernel bug the user experience is worse (for me: loosing WiFi connection every now and then)

Yeah, that's why I've been stumped is it feels like I've set up the bare minimum possible yet it keeps having issues. Almost wondering if I have a defective unit or something at this point.

If providing the read-made binaries isn't too much trouble, that would be very appreciated! Trying to eliminate any possibility for user error on my end as much as I can. :sweat_smile:

I can get them installed right away today once I get them from you and will keep an eye on it and report back if (probably when) I get new crash logs.

US price alert: RT3200 is $60 again at Walmart: https://www.walmart.com/ip/Belkin-Dual-Band-AX3200-Wifi-6-Router-3-2-Gbps-White-RT3200/103632882 Still haven't got your partner a holiday gift? Well, no excuses now! :upside_down_face:

1 Like

It was at 40£ last week at amazon.co.uk
(I bough one)
https://uk.camelcamelcamel.com/product/B08L4PJKKB?active=price_amazon&context=home_top_drops

1 Like

Back up to £75!

hi everybody i would like a mesh but i can't this is my config

1FISRT ROUTER ipaddr 192.168.2.1

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'myssidmesh1'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '**********'
	option wps_pushbutton '1'
	option network 'lan'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'myssidmesh2'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '*********'
	option wps_pushbutton '1'
	option network 'lan'

2nd router ipadrr 192.168.2.2

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'myssidmesh1'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '*******'
	option wps_pushbutton '1'
	option network 'lan'



config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mymeshwifi2'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key '********'
	option wps_pushbutton '1'
	option network 'lan'

i has not package mesh ssl but just openssl

do you have idea ??

thanks for all by advance

edit he seems than wlan 1 work only AX not 2.4

Hello @hnyman. I use your build for my Belkin RT3200 which I use as a DUMB Wi-Fi AP connected to an X86 router. I use Qosify on my main router to help me prioritise traffic based on their use case scenario. I'd like to use the bridger app which will mark traffic with DSCP values, but it seems the Linux kernel version used in your builds is not compatible with the bridger app. Do you see yourself including the bridger app for your own use in the future?

You could also just abandon qosify and use simple nftables dscp marking and tc-based dscp restoration from conntrack. That's a very flexible solution and I don't understand what the fuss is about qosify.

1 Like

For me it's simpler, I don't really understand how the prioritization works, or the dscp tables, despite the fact that I have read the contribution of many people, I am not knowledgeable about networks, it is easier to configure than sqm and it gives me the opportunity to configure only by editing 2 files, in my case it works quite well, that's why I prefer it over sqm or another solution that requires more basic knowledge to achieve something similar to quosify.

In essence it makes everything easier for newbies, as is my case, because I don't speak English and the little I understand helps me to configure qosify, I can only thank the quosify developers.

1 Like

I could, but I have learned how to use Qosify and have learned from others in the thread how to set it up to suit my needs. It is a bit like telling a Windows user that Linux is superior. It might be, but people have learned how to use one or the other. I do not know if one or the other is better, just that Qosify makes more sense to my limited knowledge of traffic shaping and prioritisation.