Belkin RT3200/Linksys E8450 WiFi AX discussion

I'll take your word for it on the connection type :+1:

Without going too off topic, my goal is to reduce short range, lie of sight, jitter (for VR streaming). No idea if an upgraded antenna would help but a fun side project either way!

On a unrelated note - it looks like HE160 is working on the latest snapshot! Takes a while to start transmitting after changing htmode so may have been working in earlier releases also.

Link speeds are as expected (1.2Gbit - 2Gbit+) with the only issue being signal and noise detection not working.

$ iw dev wlan1 station dump | grep signal:
signal:         17 [-48, -56, 17, 17] dBm
signal:         17 [-50, -62, 17, 17] dBm
signal:         17 [-44, -46, 17, 17] dBm
signal:         17 [-45, -47, 17, 17] dBm
signal:         17 [-57, -54, 17, 17] dBm

1 Like

In the terms of wifi coverage, the logic say's that bigger or more antennas means better coverage. Also many manufactures home wifi routers are looking like hedgehogs, but in same time their mesh devices and access points doesn't have external antennas at all. Seems, that manufactures are pushing users to use mesh systems, as I have lately tested Huawei AX3 and Asus RT-AX55 wifi6 routers, but despite their big antennas, the coverage was very bad, in the area, where TP-Link C80 (4 external antennas) and Mikrotik cAP (small internal antennas) had full bars, Huawei and Asus lost signal completely.

So I guess, that with bad hardware, external antennas won't help much, if at all?

1 Like

Hello, im new to openwrt, i just bought the e8450 as it says on the device page thats its a supported wifi ax router.
I do understand that its a work in progress and certain risks are involed in flashing aftermarket firmware.
I folloiwed the easy install instructions and compiled my own firmware using the script.. very easy and worked fine, but wifi ax wasnt working so i decided a day or so later to update via auc. the first couple of updates worked fine but one totaly bricked the device, I did try recovery mode but it seemed to have no affect. short of taking it apart and flashing a new firmware directly i didnt know what to do, so i just got replacment router as its was only a few days old.
With the new router i just used the pre generated images, but needed to chance another sysupgrade as my internet is ipv4 over ipv6 so i needed an extra package that required the lastest snapshot kernel to install all went well but ipv6 paassthrough seems to be broken in the current build im using but worked previously ,so id like to upgrade in a day or so to see if its fixed.

Sorry for the long post, my question is does sysupgrade update uboot? ive seen a patch or 2 in the last couple of days that adresses a partion being erased perhaps that was my issue.

Is recovery mode broken on this device in any builds? and is it possible to update the recovery partiton to one that works to avoid a difficult recovery in the furture?

1 Like

OpenWrt does not update bootloaders, nor do official OpenWrt images contain bootloader code. And sysupgrade certainly doesn't do that either.

1 Like

check this that first intstall recovery install firmware upgrade then always ubi sysupgrade.itb

https://forum.openwrt.org/t/how-to-update-kernel-ubi-image-rt3200-belkin/93033/4

1 Like

auc should request the correct image (ie. -ubi variant). It more sounds like the sysupgrade broke UBI somehow, which is very odd (and hence recovery image would also gets corrupted). I'm using auc myself on that device almost daily for more than a month now and didn't encounter that problem. However, I've heard a similar story from another user before.
In any case, recovery using TFTP method should still work

  1. Configure your PC to have IP address 192.168.1.254/24 on it's Ethernet interface and connect it to any of the LAN ports of the E8450.

  2. run TFTP server on your PC and provide openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb

  3. Hold down the RESET button while power on the device.

  4. Once recovery came up, use it to flash openwrt-mediatek-mt7622-linksys_e8450-squashfs-sysupgrade.bin

5 Likes

yes i'm use now only this image update

1 Like

On a general note: Please do not return devices bricked by experimental firmware to stores. This will encourage vendors to lock down things more to prevent this kind of damage. If the idea that "secure-boot leads to less RMA cases" becomes popular, we are all doomed (or at least or lives will become notably harder).
As exceptional bricks or devices with actual bad-blocks are very interesting for development (in order to prevent this thing from happening in the future), please contact me, I happily pay you a new device for you sending the bricked one to me :wink:

21 Likes

Thankyou for the reply and the tftp recovery procedure, I do feel bad about returning the router now sorry that was my bad, other people in the house needed internet fast.
It was also and expensive mistake for me if it was unrecoverable, I live in Japan and have never paid more than 40 bucks for a router, I paid 120 bucks for this one.
It does seem like a good value router tho given the internal specs.

I did try to look up recovery options but the debrick guide only had generic instructions and not device specific. I use Linux and I'm still learning, I did install a tftp server but got a little lost on how to provide the file and didn't know the IP address that the router looks for if it had a tftp client.

Thankyou so much for the tftp recovery how-to perhaps that would be good to add those instructions to the device page.

1 Like

Just a quick note about when auc bricked my device.
I ran auc from my phone over WiFi using the web interface. Perhaps the image got corrupted while uploading from the phone browser. Just a guess

1 Like

Good advice, I did not know until today that it was so EASY to recover the router.

@kaaku3
Even if the sysupgade image got corrupted during download, it should not have ended up in the flash (as checksums then won't match). And even if we somehow did flash a corrupted sysupgrade, that still should not have destroyed the recovery image (and most likely everything in UBI).
I hence believe that this could rather be caused by something else, such as sysupgrade process rebooting the system before write has completed (kernel should complete all pending operations though and even if it didn't, that shouldn't destroy UBI, but only result in corrupted production image).
I guess the only way to find out is to torture my local device with an endless loop of sysupgrade while logging everything until I hit the error.
Ah, and did you have any additional packages installed? (Not likely to be related, but just to be sure...)

2 Likes

Thankyou, the only additional package I had installed was ds-lite

1 Like

For what it's worth I have a second Belkin on the way. I will be able to test the range of the stock firmware vs my current one running openwrt.

4 Likes

Capture d’écran 2021-05-09 à 20.04.42
Uploading: Capture d’écran 2021-05-09 à 20.04.42.png...

new firmware by dangowrt ! enjoy

2 Likes

Got some cheap external antennas with the intention of permanently setting them up.

Close by and through walls, there was only about a ~3db difference so I'm going to pass.

1 Like

Not sure if this is the right place to ask, but i had it working in a previous build with what i think is the current settings.

My internet is native ipv6 (ipv6 over ethernet), ipv4 is via an ipv4 over ipv6 tunnel.
the router does have an ipv6 address and the ipv4 tunnel is working just fine, but i cannot forward the native ipv6 to lan. all ipv6 related setting under the lan dhcp menu are set to relay and while it doesnt show up in the luci web config under DHCPv6 client that interface also has all ipv6 related setting under dhcp server set to relay. (Need change to static address to set up the ipv6 setting then change back to dhcpv6 client). It would be nice for luci to show those setting under dhcpv6 clint menu too.

Anyway this worked before but is not now. Does anybody know if this is broken in recent builds or perhaps a configuration error?

@kaaku3 if you're no longer getting an external IPv6 address, the chances are it's because you're now communicating with a local DHCP server rather than your ISP's provided DHCP.

I'm guessing your router connects to some kind of modem - if that's the case, you'll need to make sure your modem is in "modem only" or "passthrough" mode.

If you think it's a firmware issue, try plugging the same ethernet cable into another device and set the device up as a DHCP client - if you still get a local IP, it's unlikely to be a firmware issue.

1 Like

thankyou for the replay, i know its not an issue with the "modem" i have an onu if i plug the ethernet cable directly into a pc then i get ipv6 only internet automaticaly ipv4 works after setup becuase its ipv4over6 network.
The router is getting a public ipv6 address,(ipv4 wouldnt work without it), is just openwrt is not passing through ipv6 to any other devices.
My guess is if i set up a local dhcpv6 server that would work but i would rather my devices to have a public ipv6 address.
i could have set it up wrong, but i'm quite sure it was working previously with the same settings.

also the onu doesnt not have any setting page, buttons or switches it just a power jack, fibre input and and an ethernet jack