Belkin RT3200/Linksys E8450 WiFi AX discussion

Thanks glad to here will give it another try. Did you use batman or 802.11s? Did you use wpad-mesh-wolfssl?

Thanks I will try harder. Glad to know it works.

2 Likes

This looks like a rather generic problem somewhere in between batman-adv and mac80211.
Maybe @nbd, @ryderlee1110 or @lorenzob can make more sense of the crashdump?

Did you set option mesh_fwding=0 for the 802.11s interface in /etc/config/wireless? Things are known to explode if both 802.11s forwarding and batman-adv are enabled...

Please share your /etc/config/network and /etc/config/wireless (remove identifying information and credentials before pasting!) as well as exact versions of kernel modules and hostapd/wpa_supplicant/wpad.

1 Like

Looks pretty similar as the dump above from @BeauSlim :

Based on those addresses with lots of zeroes, the first guess is that somewhere the value x is used as a pointer instead of the location of the item x, or a certain attribute of item x.

I didn't use anything other than the base image, and the steps I listed. Crazy simple, right? It is my understanding that LUCI shows the mesh as "unencrypted" but that LUCI is incorrect. I may be wrong about that. I think you still need to use BATMAN if you want to use VLANs over the mesh.
I may revisit meshing but having both a mesh link and an AP on the 5GHz meant that the AP was rather slow. My main concern is speed to my AX laptop, so I am currently running my 2 e8450s as wired APs.

Just a off topic question. What are the road blocks to achieve a release candidate for this router. The snapshots are stable enough to use as a production instance.

The problem is that most targets are still on Linux kernel version 5.4 and we are currently already quite busy with the ongoing 21.02 release (rc4 is out these days). Once 21.02 works well, more resources will be available to port remaining targets to Linux kernel version 5.10 and then make a release based on that which will include support for the E8450.

3 Likes

Thanks for the info. Makes total sense.

1 Like

hello @daniel I had a little problem concerning the wifi it was visible but did not work, I have not yet restarted the device if you want me to take a look to do, thank you

Capture d’écran 2021-08-06 à 14.51.07
Capture d’écran 2021-08-06 à 14.47.30
Capture d’écran 2021-08-06 à 14.45.39

edit :

my etc config network and wireless


config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


config wifi-device 'radio0'
	option type 'mac80211'
	option path '*******'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt2.4'
	option encryption 'psk2'
	option key '********'
	option wps_pushbutton '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path ‘*****0'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

edit i have reboot and then 0 problem

1 Like

@daniel

Started with a fresh snapshot about 4-6 days old now. Decided not to use batman but keep it simple and use 802.11s only.

No encryption mesh worked nicely with 2.4Ghz and 5Ghz frequencies.

No success with wpa3 encryption and 2.4Ghz. The 5Ghz radio worked perfectly with wpa3 encryption, but on first connection had kernel oops and is identical on both belkins. However, mesh works nicely after initial kernel oops. The 5Ghz radio the mesh network only works with channel 36, no other channel will work with mesh network on the 5Ghz radio. All error logs are posted below.

Package versions and kernel modules

OpenWrt SNAPSHOT, r17247-022d1fe80f

Linux test 5.10.54 #0 SMP Sun Aug 1 19:13:00 2021 aarch64 GNU/Linux

wpad-mesh-wolfssl - 2021-05-22-b102f19b-29

hostapd v2.10-devel

wpa_supplicant v2.10-devel

module:		/lib/modules/5.10.54/mt76.ko
license:	Dual BSD/GPL
depends:	mac80211,cfg80211
name:		mt76
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/mt7615e.ko
license:	Dual BSD/GPL
depends:	mt7615-common,mt76,mac80211,mt76-connac-lib
name:		mt7615e
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/mt76-connac-lib.ko
license:	Dual BSD/GPL
depends:	cfg80211,mac80211,mt76
name:		mt76_connac_lib
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/mac80211.ko
license:	GPL
depends:	cfg80211,compat
name:		mac80211
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/cfg80211.ko
alias:		net-pf-16-proto-16-family-nl80211
license:	GPL
depends:	compat
name:		cfg80211
vermagic:	5.10.54 SMP mod_unload aarch64

working wireless config for both belkins with radio1. No working mesh with radio0.

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option cell_density '0'
	option htmode 'HE80'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'meshnet'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key 'password'
	option network 'lan'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'guest2'
	option key 'password'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option ieee80211w '1'
	option encryption 'psk2'
	option network 'lan'

network config only difference is the ipaddr between the two belkins.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2c:6824:6df6::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.20.41'
	option gateway '192.168.20.1'
	option netmask '255.255.255.0'

Error from with wpa3 encryption and 2.4Ghz radio and no connection. Searched on internet for this error was not very helpful for me. Way over my head. Below is a link. The link did discuss that some people had mesh working only with 5Ghz radio.

https://github.com/libremesh/lime-packages/issues/837

daemon.notice wpa_supplicant[1484]: wlan0: Avoiding join because we already joined a mesh group
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: CTRL_IFACE: Detach monitor that cannot receive messages: /var/run/iwinfo-wlan0-1371\x00
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-BLOCKED addr=ef:9f:8f:ef:ff:ff duration=300
daemon.notice wpa_supplicant[1484]: wlan0: new peer notification for 7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-BLOCKED addr=7f:df:9f:bf:cf:ff duration=300

kernel oops that occurs after initial connection but connection works on 5Ghz radio with wpa3 encryption.

[ 1089.998659] ------------[ cut here ]------------
[ 1090.003293] WARNING: CPU: 0 PID: 1103 at __skb_flow_dissect+0x1ac/0x12a0
[ 1090.009984] Modules linked in: pppoe ppp_async iptable_nat xt_state xt_nat xt_conntrack xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_multiport xt_mark xt_mac xt_limit xt_comment xt_TCPMSS xt_LOG slhc nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 iptable_mangle iptable_filter ip_tables hwmon crc_ccitt compat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
[ 1090.065143] CPU: 0 PID: 1103 Comm: napi/phy1-7 Tainted: G S                5.10.54 #0
[ 1090.072962] Hardware name: Linksys E8450 (UBI) (DT)
[ 1090.077833] pstate: 40000005 (nZcv daif -PAN -UAO -TCO BTYPE=--)
[ 1090.083831] pc : __skb_flow_dissect+0x1ac/0x12a0
[ 1090.088440] lr : __skb_get_hash+0x78/0x220
[ 1090.092527] sp : ffffffc010e6b980
[ 1090.095833] x29: ffffffc010e6b980 x28: ffffffc010e6bce8 
[ 1090.101138] x27: 0000000000000000 x26: ffffff8002773618 
[ 1090.106444] x25: ffffffc010a887c8 x24: 0000000000000070 
[ 1090.111749] x23: ffffffc010e6bb00 x22: 000000000000ffba 
[ 1090.117055] x21: ffffffc010a89590 x20: ffffff80017d9f00 
[ 1090.122361] x19: 0000000000000000 x18: 00000000000e0000 
[ 1090.127666] x17: 0000000000540000 x16: 000000000000036c 
[ 1090.132971] x15: 00000000000001a8 x14: 0000000000000000 
[ 1090.138276] x13: 0000ff3a20000000 x12: 0000000000000001 
[ 1090.143581] x11: 0000000000000020 x10: 000000000000000b 
[ 1090.148887] x9 : 0000000000000000 x8 : 0000000000000000 
[ 1090.154192] x7 : 0000000000000000 x6 : 0000000000000000 
[ 1090.159497] x5 : 0000000000000000 x4 : 0000000000000000 
[ 1090.164802] x3 : ffffffc010e6bb00 x2 : 0000000000000000 
[ 1090.170107] x1 : 0000000000000000 x0 : 0000000000000000 
[ 1090.175413] Call trace:
[ 1090.177853]  __skb_flow_dissect+0x1ac/0x12a0
[ 1090.182115]  __skb_get_hash+0x78/0x220
[ 1090.185879]  ieee80211_schedule_txq+0x758/0x9a0 [mac80211]
[ 1090.191367]  ieee80211_schedule_txq+0x948/0x9a0 [mac80211]
[ 1090.196854]  ieee80211_tx_pending+0x124/0x2e0 [mac80211]
[ 1090.202160]  tasklet_action_common.isra.16+0x168/0x178
[ 1090.207290]  tasklet_action+0x24/0x30
[ 1090.210944]  _stext+0x124/0x268
[ 1090.214077]  do_softirq.part.15+0x60/0x70
[ 1090.218079]  __local_bh_enable_ip+0x80/0x88
[ 1090.222257]  napi_threaded_poll+0x90/0xe8
[ 1090.226261]  kthread+0x120/0x128
[ 1090.229482]  ret_from_fork+0x10/0x18
[ 1090.233047] ---[ end trace a933ba879ab96bc0 ]---

Mesh connection wifi and ethernet nodes. Mesh devices were about 40 cm apart.

$ iperf -c wifi_mesh_node.lan -w 512K
------------------------------------------------------------
Client connecting to wifi_mesh_node.lan, TCP port 5001
TCP window size:  416 KByte (WARNING: requested  512 KByte)
------------------------------------------------------------
[  3] local 192.168.20.20 port 37788 connected with 192.168.20.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   713 MBytes   598 Mbits/sec

$ iperf -c ethernet_mesh_node.lan -w 512K
------------------------------------------------------------
Client connecting to ethernet_mesh_node.lan, TCP port 5001
TCP window size:  416 KByte (WARNING: requested  512 KByte)
------------------------------------------------------------
[  3] local 192.168.20.20 port 54116 connected with 192.168.20.41 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.08 GBytes   927 Mbits/sec

Any other info needed or wanted please let me know!

1 Like

You report is quite complete and describes the symptom very well. Please file a bug report with everything you also wrote in this post on https://github.com/openwrt/mt76/issues
Make sure to also mention the fact that this is MT7622BV + MT7915E (it's obvious in this thread, but may not be obvious for mt76 devs when posting there)

2 Likes

Well do.

Thanks!

Update done.

If anyone wants to follow this is the link.
Mesh network wpa3 problems for MT7622BV + MT7915E

3 Likes

Hi All,

I am a new E8450 user who flashed openwrt recently. Not sure if this is the right place to put this question. I haven't been on snapshot release before so it's a bit confusing upgrading the snapshot. Can this be done through System>Software>Update list>Updates or do I need to reflash a new snapshot image and restore config? Also when I tried to add vlan package it's showing me other dependencies which can be upgraded through system software updates page but not the kernel. So I assume that I have to re-flash the new snapshot image? Sorry for the noob questions.

No.

Yes.

3 Likes

Thanks for the reply. I have one more question, if I setup 5ghz AX network, will it be backward compatible with 5Ghz AC? I tried setting up AX but it only shows up as Wifi 6 and my AC clients cannot connect to it. I thought AX will be backward compatible with AC, is that not the case?

It should be (==is, on my non-rt3200 device).

1 Like

So you're saying that you can connect an AC only device to AX network? How does the wireless config look like to get that working?

Some clients can not handle PMF required, even older need PMF disabled

1 Like

I need to test this. Will let you know after that.

Your best bet is to use luci-app-attendedsysupgrade. It uses an external service (chef.libremesh.org) to get the latest build, and include your installed packages in the base firmware (e.g. luci). Internally it uses the OpenWrt Image Builder.

It's a great tool if you have a fixed set of packages that you want to keep on updates and resets.

3 Likes

Thanks for the info.