Belkin RT3200/Linksys E8450 WiFi AX discussion

Sorry, I had moved the device (unplugged it) before seeing your reply and I see nothing under /sys/fs/pstore. But I now know better for next time.

hello @daniel
my colleague has the same router as me but he lost the openwrt wifi on his router, he uses sqm for the video game and suddenly found himself in moderate nat,

instead of nat open, but with the difference that this time the router did not go back to the original blue interface as in the past, it disconnected 10SEC and reconnected, and the wifi came back, this problem could it be recurrent thank you?

ps I don't have the version of its software

The best would be if you manage to extract the logs from /sys/fs/pstore next time it happens, so we will be able to reproduce the cause (I didn't manage to crash it even once, but that can well be related to the behavior of wifi clients; on MT7620 there were problems which could only be triggered by WiFi action frames emitted by an Xbox.... you get the idea...).
If you that is not an option for you and you just want crashes to silently reboot the router and keep things functional, you can also disable the PSTORE feature in the U-Boot environment (see above).

Ah well seen Daniel he is on PS5, not Xbox I told him to unplug in case, like you for the moment mine has no problem :+1:

Where is the best place for uploading pstore files? I have a couple. The device boots into recovery frequently. Finally read this thread about pstore files and how to clear them. Good stuff.

I have two Belkin RT3200 can't get mesh working. I just played around using the tutorial that I used in the past without success. Could someone post a working config to help me, please. The openwrt tutorial has worked in the past with other devices but does not work with the Belkin RT3200. I used the network/wireless setup and the command line examples. Using latest snapshot with wpad-mesh-wolfssl.

iw dev mesh0 station dump
iw dev mesh0 mpath dump

With the above two command there is no output. Log file looks like the mesh0 interface is created. Not sure if it is a belkin problem or something that I am doing wrong. Probably the later.

The tutorial that I have followed is https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s

I have looked at other tutorials also but no positive results.

Maybe this helps you:

2 Likes

good evening everyone does upnp work on rt3200 it does not seem to want to make it work because i have xbox and ps5 several machines, thanks in advance

1 Like

This guide got mine going:

3 Likes

anyone can say if you are done upnp on linksys e8450 rt3200 doesnt work at my home for the moment

thanks

1 Like

Thanks for the links @elan and @smileys29 and I actually followed all the tutorials you listed before my previous post, the last article posted is excellent. I guess I should have listed all the links I reviewed. I think there is a bigger problem. I been using trying belkin rt3200 to another belkin rt3200 and mesh setup won't work even a simple setup. Decided to try Belkin rt3200 to Netgear r7800 and mesh network came up on the first try. Exact same setup. Will try Batman mesh with the Belkin to Netgear r7800 to see if that works. I have to try to figure this out. I am stumped after several days. Will try to turn on some debugging output to get more information.

Noted kernel crash when bringing the network/wifi up and down.

Pstore shows this.

Unable to handle kernel NULL pointer dereference at virtual address 000000000000000c
<1>[ 1827.151352] Mem abort info:
<1>[ 1827.154139]   ESR = 0x96000005
<1>[ 1827.157186]   EC = 0x25: DABT (current EL), IL = 32 bits
<1>[ 1827.162488]   SET = 0, FnV = 0
<1>[ 1827.165532]   EA = 0, S1PTW = 0
<1>[ 1827.168663] Data abort info:
<1>[ 1827.171533]   ISV = 0, ISS = 0x00000005
<1>[ 1827.175359]   CM = 0, WnR = 0
<1>[ 1827.178318] user pgtable: 4k pages, 39-bit VAs, pgdp=0000000041858000
<1>[ 1827.184747] [000000000000000c] pgd=0000000000000000, p4d=0000000000000000, pud=0000000000000000
<0>[ 1827.193443] Internal error: Oops: 96000005 [#1] SMP
<7>[ 1827.198310] Modules linked in: xt_connlimit pppoe ppp_async nf_conncount iptable_nat batman_adv xt_state xt_nat xt_helper xt_conntrack xt_connmark xt_connbytes xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table nf_conntrack_netlink nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_recent xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY slhc sch_cake nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables hwmon crc_ccitt compat sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet
<7>[ 1827.198480]  ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 nfsv4 nfsd nfs nfs_ssc ifb rpcsec_gss_krb5 auth_rpcgss oid_registry lockd sunrpc grace dns_resolver dm_mirror dm_region_hash dm_log dm_crypt dm_mod dax sha1_generic seqiv md5 des_generic libdes cts usb_storage leds_gpio xhci_plat_hcd fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug cbc encrypted_keys trusted tpm rng_core
<7>[ 1827.338782] CPU: 1 PID: 930 Comm: ubusd Tainted: G S                5.10.54 #0
<7>[ 1827.345994] Hardware name: Linksys E8450 (UBI) (DT)
<7>[ 1827.350864] pstate: 60000085 (nZCv daIf -PAN -UAO -TCO BTYPE=--)
<7>[ 1827.356866] pc : account_kernel_stack+0xa0/0x114
<7>[ 1827.361474] lr : put_task_stack+0x5c/0xbc
<7>[ 1827.365473] sp : ffffffc01171bbf0
<7>[ 1827.368778] x29: ffffffc01171bbf0 x28: 0000000000000000 
<7>[ 1827.374082] x27: 0000000000000000 x26: 0000000000000000 
<7>[ 1827.379386] x25: ffffff8000d25650 x24: ffffff8000b85228 
<7>[ 1827.384689] x23: 0000000000000000 x22: 0000000000000080 
<7>[ 1827.389994] x21: ffffff80002fe300 x20: ffffff80016c4e00 
<7>[ 1827.395298] x19: 0000000000000000 x18: 0000000000000000 
<7>[ 1827.400601] x17: 0000000000000000 x16: 0000000000000000 
<7>[ 1827.405905] x15: 0000000000000000 x14: 0000000000000000 
<7>[ 1827.411209] x13: 00000000000000db x12: 0000000000000000 
<7>[ 1827.416512] x11: ffffffc010a38540 x10: 0000000000000820 
<7>[ 1827.421816] x9 : ffffff801fed2510 x8 : fffffffeffead008 
<7>[ 1827.427120] x7 : ffffffc00f49a000 x6 : 0000000000000000 
<7>[ 1827.432423] x5 : 0000000000000000 x4 : 0000000000000000 
<7>[ 1827.437726] x3 : ffffff80002feb18 x2 : 00000000fffffff0 
<7>[ 1827.443030] x1 : 0000000000000060 x0 : 0000000000000004 
<7>[ 1827.448334] Call trace:
<7>[ 1827.450772]  account_kernel_stack+0xa0/0x114
<7>[ 1827.455033]  put_task_stack+0x5c/0xbc
<7>[ 1827.458689]  finish_task_switch+0xe4/0x134
<7>[ 1827.462778]  __schedule+0x1f8/0x454
<7>[ 1827.466257]  schedule+0x44/0xcc
<7>[ 1827.469391]  schedule_hrtimeout_range_clock+0x110/0x120
<7>[ 1827.474607]  schedule_hrtimeout_range+0x10/0x20
<7>[ 1827.479132]  do_epoll_wait+0x4d0/0x564
<7>[ 1827.482873]  __arm64_sys_epoll_pwait+0x54/0xc4
<7>[ 1827.487309]  el0_svc_common.constprop.0+0x60/0x100
<7>[ 1827.492090]  do_el0_svc+0x18/0x20
<7>[ 1827.495396]  el0_svc+0x10/0x20
<7>[ 1827.498441]  el0_sync_handler+0xa8/0xac
<7>[ 1827.502268]  el0_sync+0x148/0x180
<0>[ 1827.505578] Code: 17fffff3 d503201f d2800c01 d50342df (f9400401) 
<4>[ 1827.511663] ---[ end trace e8144481bd796d18 ]---

Thanks for replying.

Update. Finally got a ping going with mesh and this is what happened on both belkin rt3200 after pinging the netgear. All three routers crashed.

[  568.970407] WARNING: CPU: 0 PID: 1104 at __skb_flow_dissect+0x1a4/0x1130
[  568.977098] Modules linked in: xt_connlimit pppoe ppp_async nf_conncount iptable_nat batman_adv xt_state xt_nat xt_helper xt_conntrack xt_connmark xt_connbytes xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table nf_conntrack_netlink nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_recent xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY slhc sch_cake nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables hwmon crc_ccitt compat sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet
[  568.977271]  ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 nfsv4 nfsd nfs nfs_ssc ifb rpcsec_gss_krb5 auth_rpcgss oid_registry lockd sunrpc grace dns_resolver dm_mirror dm_region_hash dm_log dm_crypt dm_mod dax sha1_generic seqiv md5 des_generic libdes cts usb_storage leds_gpio xhci_plat_hcd fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug cbc encrypted_keys trusted tpm rng_core
[  569.117578] CPU: 0 PID: 1104 Comm: napi/phy0-5 Tainted: G S                5.10.54 #0
[  569.125397] Hardware name: Linksys E8450 (UBI) (DT)
[  569.130266] pstate: 40000005 (nZcv daif -PAN -UAO -TCO BTYPE=--)
[  569.136266] pc : __skb_flow_dissect+0x1a4/0x1130
[  569.140874] lr : __skb_get_hash+0x70/0x130
[  569.144960] sp : ffffffc010d6b980
[  569.148265] x29: ffffffc010d6b980 x28: ffffff8002399280 
[  569.153570] x27: 0000000000000008 x26: 0000000000000000 
[  569.158873] x25: ffffff8001839a18 x24: 000000000000009c 
[  569.164177] x23: ffffffc010d6bb00 x22: 000000000000ffbe 
[  569.169481] x21: ffffffc010a49580 x20: 0000000000000000 
[  569.174785] x19: ffffff80018aa800 x18: ffffffc010de0410 
[  569.180089] x17: 0000000000000080 x16: 000000000000096c 
[  569.185394] x15: 0000000000000000 x14: 0000000000000000 
[  569.190697] x13: 02ff000000040300 x12: 0000c2d8008f0001 
[  569.196001] x11: 00000205003a1600 x10: ffffff80018aa300 
[  569.201305] x9 : ffffff80034a08c0 x8 : ffffff8000b9d800 
[  569.206608] x7 : 0000000000000000 x6 : 0000000000000000 
[  569.211912] x5 : 0000000000000000 x4 : 0000000000000000 
[  569.217216] x3 : ffffffc010d6bb00 x2 : 000000000000ffd6 
[  569.222519] x1 : 0000000000000000 x0 : 0000000000000000 
[  569.227823] Call trace:
[  569.230263]  __skb_flow_dissect+0x1a4/0x1130
[  569.234524]  __skb_get_hash+0x70/0x130
[  569.238289]  ieee80211_schedule_txq+0x794/0xb8c [mac80211]
[  569.243776]  ieee80211_schedule_txq+0xb24/0xb8c [mac80211]
[  569.249262]  ieee80211_tx_pending+0xdc/0x240 [mac80211]
[  569.254480]  tasklet_action_common.constprop.0+0x15c/0x170
[  569.259957]  tasklet_action+0x24/0x30
[  569.263609]  _stext+0x124/0x294
[  569.266742]  do_softirq+0x74/0x80
[  569.270047]  __local_bh_enable_ip+0x88/0x90
[  569.274224]  napi_threaded_poll+0x94/0xf0
[  569.278227]  kthread+0x120/0x124
[  569.281446]  ret_from_fork+0x10/0x18
[  569.285011] ---[ end trace 0c23f40535c1c7fa ]---

Similar on second belking rt3200

[  561.719982] ------------[ cut here ]------------
[  561.724617] WARNING: CPU: 0 PID: 1104 at __skb_flow_dissect+0x1a4/0x1130
[  561.731307] Modules linked in: xt_connlimit pppoe ppp_async nf_conncount iptable_nat batman_adv xt_state xt_nat xt_helper xt_conntrack xt_connmark xt_connbytes xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table nf_conntrack_netlink nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_recent xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY slhc sch_cake nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables hwmon crc_ccitt compat sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet
[  561.731478]  ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 nfsv4 nfsd nfs nfs_ssc ifb rpcsec_gss_krb5 auth_rpcgss oid_registry lockd sunrpc grace dns_resolver dm_mirror dm_region_hash dm_log dm_crypt dm_mod dax sha1_generic seqiv md5 des_generic libdes cts usb_storage leds_gpio xhci_plat_hcd fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug cbc encrypted_keys trusted tpm rng_core
[  561.871781] CPU: 0 PID: 1104 Comm: napi/phy0-5 Tainted: G S                5.10.54 #0
[  561.879599] Hardware name: Linksys E8450 (UBI) (DT)
[  561.884469] pstate: 40000005 (nZcv daif -PAN -UAO -TCO BTYPE=--)
[  561.890468] pc : __skb_flow_dissect+0x1a4/0x1130
[  561.895076] lr : __skb_get_hash+0x70/0x130
[  561.899162] sp : ffffffc010d5b980
[  561.902468] x29: ffffffc010d5b980 x28: ffffff8002311280 
[  561.907772] x27: 0000000000000008 x26: 0000000000000000 
[  561.913076] x25: ffffff8002bd4a18 x24: 0000000000000044 
[  561.918380] x23: ffffffc010d5bb00 x22: 000000000000ffbe 
[  561.923684] x21: ffffffc010a49580 x20: 0000000000000000 
[  561.928988] x19: ffffff8000a74800 x18: ffffffc010ddb4d0 
[  561.934292] x17: 0000000000000080 x16: 000000000000096c 
[  561.939595] x15: 0000000000000000 x14: 0000000000000080 
[  561.944899] x13: 0000000000000070 x12: ffffffc010830610 
[  561.950202] x11: 0000000000000001 x10: 0000000000000001 
[  561.955506] x9 : ffffff8002b928c0 x8 : ffffff8000294200 
[  561.960810] x7 : 0000000000000000 x6 : 0000000000000000 
[  561.966113] x5 : 0000000000000000 x4 : 0000000000000000 
[  561.971417] x3 : ffffffc010d5bb00 x2 : 000000000000ffd6 
[  561.976721] x1 : 0000000000000000 x0 : 0000000000000000 
[  561.982026] Call trace:
[  561.984465]  __skb_flow_dissect+0x1a4/0x1130
[  561.988726]  __skb_get_hash+0x70/0x130
[  561.992493]  ieee80211_schedule_txq+0x794/0xb8c [mac80211]
[  561.997979]  ieee80211_schedule_txq+0xb24/0xb8c [mac80211]
[  562.003465]  ieee80211_tx_pending+0xdc/0x240 [mac80211]
[  562.008684]  tasklet_action_common.constprop.0+0x15c/0x170
[  562.014160]  tasklet_action+0x24/0x30
[  562.017813]  _stext+0x124/0x294
[  562.020945]  do_softirq+0x74/0x80
[  562.024251]  __local_bh_enable_ip+0x88/0x90
[  562.028428]  napi_threaded_poll+0x94/0xf0
[  562.032431]  kthread+0x120/0x124
[  562.035650]  ret_from_fork+0x10/0x18
[  562.039215] ---[ end trace 771e410f6f1a456b ]---

This is the error on the netgear r7800. All of the routers on the mesh crashed. Don't know if this helps but wanted to post it also.

[  101.961765] ------------[ cut here ]------------
[  101.961822] WARNING: CPU: 0 PID: 0 at net/core/flow_dissector.c:960 0xc0782264
[  101.965484] Modules linked in: pppoe ppp_async iptable_nat batman_adv ath10k_pci ath10k_core ath xt_state xt_nat xt_conntrack xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table_hw nf_flow_table nf_conntrack mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_multiport xt_mark xt_mac xt_limit xt_comment xt_TCPMSS xt_LOG slhc nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c iptable_mangle iptable_filter ip_tables crc_ccitt compat ledtrig_usbport nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 crc32c_generic leds_gpio xhci_plat_hcd xhci_pci xhci_hcd dwc3 dwc3_qcom ohci_platform ohci_hcd phy_qcom_ipq806x_usb ahci fsl_mph_dr_of ehci_platform ehci_fsl sd_mod ahci_platform libahci_platform libahci libata scsi_mod ehci_hcd gpio_button_hotplug
[  102.024836] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.4.124 #0
[  102.047043] Hardware name: Generic DT based system
[  102.053037] Function entered at [<c030f854>] from [<c030b870>]
[  102.057634] Function entered at [<c030b870>] from [<c08ffe18>]
[  102.063451] Function entered at [<c08ffe18>] from [<c031e75c>]
[  102.069266] Function entered at [<c031e75c>] from [<c031e7c8>]
[  102.075081] Function entered at [<c031e7c8>] from [<c0782264>]
[  102.080899] Function entered at [<c0782264>] from [<c0783600>]
[  102.086712] Function entered at [<c0783600>] from [<bf1e6bec>]
[  102.092551] Function entered at [<bf1e6bec>] from [<bf1ec360>]
[  102.098347] Function entered at [<bf1ec360>] from [<bf1edd3c>]
[  102.104163] Function entered at [<bf1edd3c>] from [<c03226e0>]
[  102.109977] Function entered at [<c03226e0>] from [<c0302298>]
[  102.115793] Function entered at [<c0302298>] from [<c0322b44>]
[  102.121608] Function entered at [<c0322b44>] from [<c036f830>]
[  102.127426] Function entered at [<c036f830>] from [<c05dcbb4>]
[  102.133242] Function entered at [<c05dcbb4>] from [<c0301a8c>]
[  102.139057] Exception stack(0xc0c01ee0 to 0xc0c01f28)
[  102.144883] 1ee0: 00000000 00000017 1ce50000 dd991a80 dcc58800 00000000 dd990e30 00000017
[  102.150008] 1f00: 00000017 00000000 bd62b2c0 bd57dee0 00000015 c0c01f30 c0730e78 c0730e7c
[  102.158160] 1f20: 80000013 ffffffff
[  102.166312] Function entered at [<c0301a8c>] from [<c0730e7c>]
[  102.169614] Function entered at [<c0730e7c>] from [<c07312c4>]
[  102.175515] Function entered at [<c07312c4>] from [<c034ac4c>]
[  102.181333] Function entered at [<c034ac4c>] from [<c034af5c>]
[  102.187148] Function entered at [<c034af5c>] from [<c0b00db4>]
[  102.193044] ---[ end trace 5e8e6f1b7fce010d ]---

I think I found the reason for going into recovery. Will try something different in the morning.

Hope this helps.

2 Likes

I can confirm that 802.11s mesh was working on a couple e8450s in AP mode when I tried it a week or so ago.

Set all radios to the same frequency.
Add an 802.11s interface to the radio, tied to LAN.
Set security to WPA3-SAE and set the same key.
Done.

3 Likes

Thanks glad to here will give it another try. Did you use batman or 802.11s? Did you use wpad-mesh-wolfssl?

Thanks I will try harder. Glad to know it works.

2 Likes

This looks like a rather generic problem somewhere in between batman-adv and mac80211.
Maybe @nbd, @ryderlee1110 or @lorenzob can make more sense of the crashdump?

Did you set option mesh_fwding=0 for the 802.11s interface in /etc/config/wireless? Things are known to explode if both 802.11s forwarding and batman-adv are enabled...

Please share your /etc/config/network and /etc/config/wireless (remove identifying information and credentials before pasting!) as well as exact versions of kernel modules and hostapd/wpa_supplicant/wpad.

1 Like

Looks pretty similar as the dump above from @BeauSlim :

Based on those addresses with lots of zeroes, the first guess is that somewhere the value x is used as a pointer instead of the location of the item x, or a certain attribute of item x.

I didn't use anything other than the base image, and the steps I listed. Crazy simple, right? It is my understanding that LUCI shows the mesh as "unencrypted" but that LUCI is incorrect. I may be wrong about that. I think you still need to use BATMAN if you want to use VLANs over the mesh.
I may revisit meshing but having both a mesh link and an AP on the 5GHz meant that the AP was rather slow. My main concern is speed to my AX laptop, so I am currently running my 2 e8450s as wired APs.

Just a off topic question. What are the road blocks to achieve a release candidate for this router. The snapshots are stable enough to use as a production instance.

The problem is that most targets are still on Linux kernel version 5.4 and we are currently already quite busy with the ongoing 21.02 release (rc4 is out these days). Once 21.02 works well, more resources will be available to port remaining targets to Linux kernel version 5.10 and then make a release based on that which will include support for the E8450.

3 Likes

Thanks for the info. Makes total sense.

1 Like

hello @daniel I had a little problem concerning the wifi it was visible but did not work, I have not yet restarted the device if you want me to take a look to do, thank you

Capture d’écran 2021-08-06 à 14.51.07
Capture d’écran 2021-08-06 à 14.47.30
Capture d’écran 2021-08-06 à 14.45.39

edit :

my etc config network and wireless


config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


config wifi-device 'radio0'
	option type 'mac80211'
	option path '*******'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt2.4'
	option encryption 'psk2'
	option key '********'
	option wps_pushbutton '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path ‘*****0'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

edit i have reboot and then 0 problem

1 Like

@daniel

Started with a fresh snapshot about 4-6 days old now. Decided not to use batman but keep it simple and use 802.11s only.

No encryption mesh worked nicely with 2.4Ghz and 5Ghz frequencies.

No success with wpa3 encryption and 2.4Ghz. The 5Ghz radio worked perfectly with wpa3 encryption, but on first connection had kernel oops and is identical on both belkins. However, mesh works nicely after initial kernel oops. The 5Ghz radio the mesh network only works with channel 36, no other channel will work with mesh network on the 5Ghz radio. All error logs are posted below.

Package versions and kernel modules

OpenWrt SNAPSHOT, r17247-022d1fe80f

Linux test 5.10.54 #0 SMP Sun Aug 1 19:13:00 2021 aarch64 GNU/Linux

wpad-mesh-wolfssl - 2021-05-22-b102f19b-29

hostapd v2.10-devel

wpa_supplicant v2.10-devel

module:		/lib/modules/5.10.54/mt76.ko
license:	Dual BSD/GPL
depends:	mac80211,cfg80211
name:		mt76
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/mt7615e.ko
license:	Dual BSD/GPL
depends:	mt7615-common,mt76,mac80211,mt76-connac-lib
name:		mt7615e
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/mt76-connac-lib.ko
license:	Dual BSD/GPL
depends:	cfg80211,mac80211,mt76
name:		mt76_connac_lib
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/mac80211.ko
license:	GPL
depends:	cfg80211,compat
name:		mac80211
vermagic:	5.10.54 SMP mod_unload aarch64

module:		/lib/modules/5.10.54/cfg80211.ko
alias:		net-pf-16-proto-16-family-nl80211
license:	GPL
depends:	compat
name:		cfg80211
vermagic:	5.10.54 SMP mod_unload aarch64

working wireless config for both belkins with radio1. No working mesh with radio0.

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option cell_density '0'
	option htmode 'HE80'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'meshnet'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key 'password'
	option network 'lan'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'guest2'
	option key 'password'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option ieee80211w '1'
	option encryption 'psk2'
	option network 'lan'

network config only difference is the ipaddr between the two belkins.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2c:6824:6df6::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.20.41'
	option gateway '192.168.20.1'
	option netmask '255.255.255.0'

Error from with wpa3 encryption and 2.4Ghz radio and no connection. Searched on internet for this error was not very helpful for me. Way over my head. Below is a link. The link did discuss that some people had mesh working only with 5Ghz radio.

https://github.com/libremesh/lime-packages/issues/837

daemon.notice wpa_supplicant[1484]: wlan0: Avoiding join because we already joined a mesh group
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: CTRL_IFACE: Detach monitor that cannot receive messages: /var/run/iwinfo-wlan0-1371\x00
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=ef:9f:8f:ef:ff:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-BLOCKED addr=ef:9f:8f:ef:ff:ff duration=300
daemon.notice wpa_supplicant[1484]: wlan0: new peer notification for 7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-FAILURE addr=7f:df:9f:bf:cf:ff
daemon.notice wpa_supplicant[1484]: wlan0: MESH-SAE-AUTH-BLOCKED addr=7f:df:9f:bf:cf:ff duration=300

kernel oops that occurs after initial connection but connection works on 5Ghz radio with wpa3 encryption.

[ 1089.998659] ------------[ cut here ]------------
[ 1090.003293] WARNING: CPU: 0 PID: 1103 at __skb_flow_dissect+0x1ac/0x12a0
[ 1090.009984] Modules linked in: pppoe ppp_async iptable_nat xt_state xt_nat xt_conntrack xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_multiport xt_mark xt_mac xt_limit xt_comment xt_TCPMSS xt_LOG slhc nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 iptable_mangle iptable_filter ip_tables hwmon crc_ccitt compat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
[ 1090.065143] CPU: 0 PID: 1103 Comm: napi/phy1-7 Tainted: G S                5.10.54 #0
[ 1090.072962] Hardware name: Linksys E8450 (UBI) (DT)
[ 1090.077833] pstate: 40000005 (nZcv daif -PAN -UAO -TCO BTYPE=--)
[ 1090.083831] pc : __skb_flow_dissect+0x1ac/0x12a0
[ 1090.088440] lr : __skb_get_hash+0x78/0x220
[ 1090.092527] sp : ffffffc010e6b980
[ 1090.095833] x29: ffffffc010e6b980 x28: ffffffc010e6bce8 
[ 1090.101138] x27: 0000000000000000 x26: ffffff8002773618 
[ 1090.106444] x25: ffffffc010a887c8 x24: 0000000000000070 
[ 1090.111749] x23: ffffffc010e6bb00 x22: 000000000000ffba 
[ 1090.117055] x21: ffffffc010a89590 x20: ffffff80017d9f00 
[ 1090.122361] x19: 0000000000000000 x18: 00000000000e0000 
[ 1090.127666] x17: 0000000000540000 x16: 000000000000036c 
[ 1090.132971] x15: 00000000000001a8 x14: 0000000000000000 
[ 1090.138276] x13: 0000ff3a20000000 x12: 0000000000000001 
[ 1090.143581] x11: 0000000000000020 x10: 000000000000000b 
[ 1090.148887] x9 : 0000000000000000 x8 : 0000000000000000 
[ 1090.154192] x7 : 0000000000000000 x6 : 0000000000000000 
[ 1090.159497] x5 : 0000000000000000 x4 : 0000000000000000 
[ 1090.164802] x3 : ffffffc010e6bb00 x2 : 0000000000000000 
[ 1090.170107] x1 : 0000000000000000 x0 : 0000000000000000 
[ 1090.175413] Call trace:
[ 1090.177853]  __skb_flow_dissect+0x1ac/0x12a0
[ 1090.182115]  __skb_get_hash+0x78/0x220
[ 1090.185879]  ieee80211_schedule_txq+0x758/0x9a0 [mac80211]
[ 1090.191367]  ieee80211_schedule_txq+0x948/0x9a0 [mac80211]
[ 1090.196854]  ieee80211_tx_pending+0x124/0x2e0 [mac80211]
[ 1090.202160]  tasklet_action_common.isra.16+0x168/0x178
[ 1090.207290]  tasklet_action+0x24/0x30
[ 1090.210944]  _stext+0x124/0x268
[ 1090.214077]  do_softirq.part.15+0x60/0x70
[ 1090.218079]  __local_bh_enable_ip+0x80/0x88
[ 1090.222257]  napi_threaded_poll+0x90/0xe8
[ 1090.226261]  kthread+0x120/0x128
[ 1090.229482]  ret_from_fork+0x10/0x18
[ 1090.233047] ---[ end trace a933ba879ab96bc0 ]---

Mesh connection wifi and ethernet nodes. Mesh devices were about 40 cm apart.

$ iperf -c wifi_mesh_node.lan -w 512K
------------------------------------------------------------
Client connecting to wifi_mesh_node.lan, TCP port 5001
TCP window size:  416 KByte (WARNING: requested  512 KByte)
------------------------------------------------------------
[  3] local 192.168.20.20 port 37788 connected with 192.168.20.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   713 MBytes   598 Mbits/sec

$ iperf -c ethernet_mesh_node.lan -w 512K
------------------------------------------------------------
Client connecting to ethernet_mesh_node.lan, TCP port 5001
TCP window size:  416 KByte (WARNING: requested  512 KByte)
------------------------------------------------------------
[  3] local 192.168.20.20 port 54116 connected with 192.168.20.41 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.08 GBytes   927 Mbits/sec

Any other info needed or wanted please let me know!

1 Like