Belkin RT3200/Linksys E8450 WiFi AX discussion

No and I don't know why not. Because it vastly improves performance.

I am on it.
But having problems to configure wireGuard under openWRT. I had it running in a QNAP NAS.

It was way more quick than other VPN solutions, I almost did not realize or see significant difference in performance connecting through wireGuard VPN with respect to connecing with no VPN at all.

I expect it to work very well in this router, once I get it working.

1 Like

@daniel Would you consider making irqbalance a default package?


I'm currently just using the built in packet steering, but I've used irqbalance and speed was the same (120-140), I'm not sure what the differences are, if any, between the two.

Currently CBC, but speed was about the same the last time I used GCM.

1 Like

sorry for the crosspost on

but I am really in need of some help.
I am stuck with radio0 not working and kernel messages:

[   29.325900] mt7622-wmac 18000000.wmac: Message 80000010 (seq 1) timeout
[   29.332544] mt7622-wmac 18000000.wmac: Failed to get patch semaphore

just tried an update to
OpenWrt SNAPSHOT r18404-236c3ea730 with kernel 5.10.87
but still the radio0 will not activate,
anyone can pls give me some pointer?

Finally retried mesh and looks like 802.11s may be working again. Anyone else using it?

update: mesh is still broken for me

Notice how uplink speed went down to almost zero in second connection above. And I cannot access that mesh point even though it shows up as connected. So that's the same old broken behaviour from earlier.

This is despite @nbd's recent fix above.

So I'll go back to WDS which works better.


I could get these device to work, with 3 VLANS to separate guest, lzn and iot networks.
It seems to work very well, with much more quick wifi than the ISP or previous router, but have not made objetive tests yet.

I had some problems activating wifi transitions (roaming) 802.11r as it seemed to work well with some mobiles andcomputers, but others did not even connect, they failed to connect silently.

I found that if you deactivate the 802.11w management frame protection from the defsult optional setting to disabled, all works corrdctly.

I don't know what frame protection is and whether disabling it can produce other collateral effects.

But now wifi works smoothly and you can roam with no disconnections from one station to another.

Now, let's see if I am able to configure wireGuard in it.


Is that with default 802.11r settings? I needed to set:

Well, yes I have ft over the Air activated instead of the default ft over DS, as in the channel of marconefifty in youtube he says it is much more quick.

A left the reassociation deal line in the default 1000 ms (1 second) as I am not sure what it is for (seems to be the time it will stick to the current AP before checking if it is worth to make a transition).
20 seconds may be a bit long, 1 second be be too short.

What I had to deactivate is this:

As when left as Optional(the default) some device could not connect to the wifi without any error o explanation.

Has anyone had a chance to test throughput w/ SQM on a symmetric gigabit connection?

Hi Everyone,

I've just received my Linksys E8450 and I did backup the mtd files (mtd0, mtd1, mtd2, mtd3) to my computer.

I was on stock firmware initially:

(Using v0.6.1)

  1. Flashed openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb
  2. Login, then navigate to System -> Backup / Flash Firmware and save a copy of each of the mtdblock.
  3. Rebooted the device and was on stock firmware again
  4. Flashed openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb
  5. Waited for the OpenWRT interface to come up
  6. Flashed firmware openwrt-mediatek-mt7622-linksys_e8450-ubi-squashfs-sysupgrade.itb

I then tried to revert to stock firmware:

  1. Flashed openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb

  2. Used WinSCP to copy the mtdx files to /tmp folder

  3. Entered the commands via SSH (putty):
    ubidetach -d 0
    insmod mtd-rw i_want_a_brick=1
    mtd write /tmp/mtd0 /dev/mtd0
    mtd write /tmp/mtd1 /dev/mtd1
    mtd write /tmp/mtd2 /dev/mtd2
    mtd write /tmp/mtd3 /dev/mtd3

  4. Rebooted the device

  5. When I accessed, it is still stuck on recovery (initramfs)

  6. I then tried step 3 again and also uploaded the firmware FW_E8450_1.0.01.101415_prod.img to the /tmp folder

  7. When I tried the ff command in SSH: mtd -p 0x200000 write /dev/mtd3 FW_E8450_1.0.01.101415_prod.img (I'm getting the error below)


Please advise...

Edit: I was able to finally revert to vendor firmware after holding the reset button then plugged in the power cable.

1 Like

Yes, it can sustain the connection (which in my case never exceeded 850Mb/s) with 20% idle CPU. I am using fq_codel with simple.qos.


Great, I have only 300 Mbps, but it is great to know it has plenty of power to grow in the future.

SQM works great in it.

I have SQM, mosquitto, DNS, adsblock, DHCP, 3 VLANS and wireGuard... and the CPU seems to be almost idle all the time.

It is a huge advance with respect to previous router.

Have you activated packet steering?
Does it benefit this router?

Balancing packet management among all CPUs seems a good idea, but documentation says it may higher network speed or degrage it.
In my case it does not seem to make any difference, but I have not done extensive tests to see if it helps or not.

I have irqbalance activated.

Yes, I am using packet steering. No difference for the traffic speed, maybe a little improvement to the CPU usage.

1 Like

The command was wrong in the installer wiki, I have fixed it now. It's supposed to be

mtd -p 0x200000 write FW_E8450_1.0.01.101415_prod.img /dev/mtd3

Did you manage to get the router to request the file via TFTP in this way?
I'm asking because another user didn't manage when trying it this way, hence it would be great to improve documentation on how exactly to achieve this. See also

1 Like

I can't remember exactly when... but I didn't do any TFTP method. After copying the mtd files into the /tmp/ folder and doing the

ubidetach -d 0
insmod mtd-rw i_want_a_brick=1
mtd write /tmp/mtd0 /dev/mtd0
mtd write /tmp/mtd1 /dev/mtd1
mtd write /tmp/mtd2 /dev/mtd2
mtd write /tmp/mtd3 /dev/mtd3

Sometimes, I reboot the router and still the same. So I did the same thing again (transfer the the mtd files to the /tmp), but this time I turned off the router and hold the reset button then plugged in the power cable for about 10-30secs (cant remember how long), then when I open it's back to the linksys stock GUI. I then reset the factory settings and rebooted the router to see if it will still stay in stock (it is still in stock after the reboot).

1 Like

Hi all, downloading the mtdblock files form LuCi is failing for me. Not sure if this is normal. Don't feel comfortable to continue without a solid backup. Any advice would be greatly appreciated :slight_smile:

I just did a speedtest while connected to an AirVPN server with OpenVPN using the CHACHA20-POLY1305 cypher and got 175Mbps download speed. Not bad! :slight_smile: Without VPN my download speed is 300Mbps.

Edit 1:
With AES-128-CBC the highest I got was almost 175Mbps and with AES-256-GCM I got max 114Mbps. So in conclusion, best to use CHACHA20-POLY1305 for OpenVPN with this router!

The CHACHA20-POLY1305 speed of the Belkin RT3200/Linksys E8450 is very good. Even in comparison to my ASUS RT-AC86U with AES hardware accelration. On that one, with AES-256-GCM, I get about 160Mbps.

Edit 2:
Above tests were done while connected via ethernet cable. With WiFi the results are a bit different. Without VPN I'm able to reach 300Mbps (max download speed of internet connection) with both the ASUS and Belkin router on 5Ghz.

However, with VPN on it seems like the ASUS router performs much better. It reaches 163Mbps down whereas the Belkin fluctuates around 100Mbps.

Could it be that the VPN taxes the Belkin so much that it has trouble with WiFi speeds?

1 Like