Belkin RT3200 can’t follow first steps

Hi, I’m new to OpenWRT and just got a Belkin RT3200 to install OpenWRT and replace my ISP supplied wifi router.

I’m having trouble with the very first steps of this tutorial however. https://github.com/dangowrt/owrt-ubi-installer

The first step is to accept the license agreement and cancel the set up wizard. I do this, no problem. The next step is to go to the configuration page, then Administration -> Firmware Upgrade. This is where I get stuck. When I navigate to the configuration page, I get redirected to the login page for a moment, then redirected back to the network status page. I can never get to the step where I’m flashing or running a different firmware.

The only thing I can think of is all the guides seem to assume that you are starting from V1.0.01 of the stock firmware, while mine says it is V1.0.00. Has anyone encountered this before? Should I try connecting the router to the internet and let it upgrade, then downgrade back to 1.0.01? Does anyone have any other suggestions?

You're not running any kind of ad blocker in your browser, are you?

1 Like

Where do you come from for have 1.0.0 ?

Yes, it seems their wizard requires you to connect the router to your cable modem before you can downgrade the firmware and flash openwrt. Very annoying.

FYI, stock firmware version forcing this is 1.0.00 build 082617 AUG 26, 2020.

EDIT: I see these after doing it which suggest it may not have been necessary afterall.

5. Click exactly inside the radio button to confirm the terms and conditions, then abort the wizard.
6. You should then be greeted by the login screen, the stock password is "admin".
2 Likes

Thanks! I wasted about 1 hour trying to figure out why the damned thing would exit back to the login page after showing the configuration page for 1 second until I read this and tried a different browser with no popup blocking!!

1 Like

I thought maybe I had the same issue, but I tried on a chrome setup that allowed pop-ups and site redirects and still got no luck. I also attempted on safari via mac, and nothing. any other ideas?

Im able to go through the wizard, or cancel out of the wizard, but as soon as I try to login again, it flashes the admin screen and then takes me right back to the login screen.

Works in firefox

1 Like