Belkin RT 3200 not working after openwrt installation

Hello
I would like to get help with how to recover my device.
The device is Belkin RT3200-UK, rev. A00.
The stock firmware was 1.0.00 build 082617

I open the stock GUI->Configuration->Administration->Firmware upgrade
Used the file openwrt-23.05.0-rc2-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery.itb
and started upgrading.

After that, I login into LuCI, and the GUI shows "System running in recovery mode, no changes to settings... This mode should only be used to install a firmware upgrade".
I clicked on firmware upgrade, attached a file: openwrt-23.05.0-rc2-mediatek-mt7622-linksys_e8450-ubi-squashfs-sysupgrade.itb
and started upgrading.

I noticed that "network cable unplugged" appeared for my ethernet card and I can not connect to the device anymore. The power led is blinking white. Ethernet ports are down, no led blinking on my workstation ethernet port if the cable is connected to the router.

I tried to use "reset" button. I turn off the router, press and hold the reset button and turn on the device but the power led is blinking white and never turns to orange/yellow.

I have two major questions:

  1. What was done wrong in my actions?
  2. How to recover the device?

Thanks in advance.

This

You would have needed the UBI installer image from @daniel to be flashed first.

Named like this
openwrt-...-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb

1 Like

Is there any chance to recover the device?

https://openwrt.org/toh/linksys/e8450#serial would be your 1st stop.

if you manage to get to the u-boot menu, as posted in https://github.com/dangowrt/owrt-ubi-installer/issues/48#issuecomment-1001066145, via serial, you can pick option 1, boot the correct recovery installer image described by @hnyman, and take it from there.

or use option 2 to flash the Belkin FW again.

3 Likes

Follow thé step of frollic and normally IS good

Suis les étapes de frollic...

thanks, solved

and this video helped me too:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.