Before I buy GL-AR750S-Ex

Hi all,
Im considering to replace my old: TP-Link TL-WR841N/ND v9 with: GL-AR750S-Ex

Does OpenWRT install/upgrade procedure is the same straight forward as on TP-Link TL-WR841N/ND v9? The reason why I am asking is because I am a little bit confused what to do with "NAND"?

If I correctly understand, GL-AR750S-Ex has 2 types of flash memory:

  1. 16 MB of NOR flash. This is default flash memory and OpenWRT firmware is ready for it:

  2. 128 MB of NAND flash. This is optional memory that can used instead of 16 MB NOR but OpenWRT firmware must be first recompiled to enable such functionality.

I would appreciate if someone could give me some clarity on that :slight_smile:

from what /i understand snapshots already support nand

Thanks for this finding.

Can anyone say if my understanding for NOR and NAND flash is correct?

Yes generally that's correct. If I recall correctly, it's a little bit stranger in the sense that the Kernel always gets loaded onto NOR flash, but the actual firmware itself will be loaded to the remaining NOR or NAND depending on how it was built/compiled. So for example, a NOR image will load Kernel + root file system all into NOR, while a NAND image will load Kernel to NOR and root file system to NAND.

Either way as long as you have the correct image everything should work seamlessly. One issue that I have run into is that while the NAND is much larger, if you go to load a NAND image that's compiled to be above 16Mb the U-Boot recovery won't let you do it. That may have changed from when I tried 6 months ago, as I brought the issue up with GL Inet and they acknowledged it.

The work around is either to compile a NAND firmware with just your required packages and then opkg install the rest afterward, OR install a smaller NAND firmware and sysupgrade to the larger NAND image. Either way it's really just an arbitrary U-Boot issue, nothing to do with the device itself.

1 Like

Hi all
I just flashed snapshot openwrt-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin via GL web-gui onto my brandnew GL-AR750S.
I had successfully upgraded to latest GL firmware and successfully configured the box as access point using 'Advanced' Luci. The GUI accepted the image (it refused previously attempted stable openwrt-19.07.7-ar71xx-generic-gl-ar750s-squashfs-sysupgrade.bin by the way). But now the box does not seem to come up properly, only powerled shows and ssh or even ping are no longer possible.
Any similar experience and possible solution? Did I probably brick the box?
I restored latest GL firmware (openwrt-ar750s-3.201-0402.img (19.07.7)) via unbrick method. Next I tried to sysupgrade from ssh shell to 21.02.0 NOR (openwrt-21.02.0-rc2-ath79-nand-glinet_gl-ar750s-nor-squashfs-sysupgrade.bin) but it complains:

root@GL-AR750S:~# sysupgrade -k -v /tmp/openwrt-21.02.0-rc2-ath79-nand-glinet_gl-ar750s-nor-squashfs-sysupgrade.bin 
Invalid sysupgrade file.
Invalid sysupgrade file.
Invalid sysupgrade file.
Invalid sysupgrade file.
Image check failed

Luci also complains but allows me to force upgrade. Should I do so?
Select 'Force upgrade' to flash the image even if the image format check fails. Use only if you are sure that the firmware is correct and meant for your device!

So I decided to sysupgrade from ssh shell to 21.02.0 NOR NAND (openwrt-21.02.0-rc2-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin). This did not receive any complaint, but, just as with the snapshot flash from web-gui, I end up with only powerled and no ping to box possible.

question: has anyone recently flashed OpenWRT to GL-AR750S?

[good news is: I can always unbrick and try whatever one suggests]