BATMAN Node has no internet connectivity

I have two ASUS Lyra (MAP-AC2200) devices with one WAN and one LAN port each. The main node lirael with a ethernet cable to the internet and touchstone with no wired connection as access point. I tried to setup BATMAN based on the wiki page. But my problem is, that the access point and also the wifi network of it has no internet connection. Both devices are seeing each other based on the batctl o output and I can also ssh to both of them. I think there is a problem with the DHCP configuration, but I have no clue how to fix it.

The configuration of lirael:

/etc/config/network
config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'
        list ports 'bat0.1' # Batman VLAN 1
        list ports 'bat0.2' # Batman VLAN 2
        option stp '1'
        option igmp_snooping '1'
        option ipv6 '0'
        option mtu '2304'

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3f:5674:75e0::/48'

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms 1
        option ap_isolation 0
        option bonding 0
        option fragmentation 1
        #option gw_bandwidth '10000/2000'
        option gw_mode 'off'
        #option gw_sel_class 20
        option log_level 0
        option orig_interval 1000
        option bridge_loop_avoidance 1
        option distributed_arp_table 1
        option multicast_mode 1
        option network_coding 0
        option hop_penalty 30
        option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
        option mtu '2304'
        option proto 'batadv_hardif'
        option master 'bat0'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan'
        list ports 'bat0.1'

config bridge-vlan
        option device 'br-lan'
        option vlan '2'
        list ports 'bat0.2'           

config interface 'lan'
        option device 'br-lan.1' # VLAN number 1
        option proto 'static'                        
        option ipaddr '192.168.1.254'
        option netmask '255.255.255.0'                   
        option force_link 'yes'                                      

config interface 'guest'
        option device 'br-lan.2'     
        option proto 'static'                            
        option ipaddr '192.168.2.254'                                
        option netmask '255.255.255.0'
        option force_link 'yes'                       
                     
config interface 'wan'
        option device 'wan'                                          
        option proto 'dhcp'           
   
config interface 'wan6'
        option device 'wan'           
        option proto 'dhcpv6'                                        
/etc/config/wireless
config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/a800000.wifi'
        option channel '100'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wifi'
        option encryption 'psk2+ccmp'
        option key 'password'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/a000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'mesh0'
        option device 'radio1'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_fwding '0'
        option mesh_id 'Mesh'
        option encryption 'psk2+ccmp'
        option key 'password'
/etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

The configuration of touchstone:

/etc/config/network
config device                                            
        option name 'br-lan'                             
        option type 'bridge'                             
        list ports 'lan'                                 
        list ports 'bat0.1' # Batman VLAN 1              
        list ports 'bat0.2' # Batman VLAN 2                      
        option stp '1'                                           
        option igmp_snooping '1'                                 
        option ipv6 '0'                                          
        option mtu '2304'                                        
                                                                 
config interface 'loopback'                                          
        option device 'lo'                                           
        option proto 'static'                                        
        option ipaddr '127.0.0.1'                                    
        option netmask '255.0.0.0'                                   
                                                                     
config globals 'globals'                                             
        option ula_prefix 'fd3f:5674:75e0::/48'                      
                                                                     
config interface 'bat0'                                              
        option proto 'batadv'                                        
        option routing_algo 'BATMAN_IV'                              
        option aggregated_ogms 1                                     
        option ap_isolation 0                                        
        option bonding 0                                             
        option fragmentation 1                                       
        #option gw_bandwidth '10000/2000'                            
        option gw_mode 'off'                                         
        #option gw_sel_class 20                                      
        option log_level 0                                           
        option orig_interval 1000                                    
        option bridge_loop_avoidance 1                               
        option distributed_arp_table 1                               
        option multicast_mode 1                                      
        option network_coding 0                       
        option hop_penalty 30                         
        option isolation_mark '0x00000000/0x00000000' 
                                                      
config interface 'nwi_mesh0'                          
        option mtu '2304'                             
        option proto 'batadv_hardif'                  
        option master 'bat0'                         
                                                     
config bridge-vlan                                   
        option device 'br-lan'                       
        option vlan '1'                              
        list ports 'lan'                             
        list ports 'bat0.1'                          
                                                     
config bridge-vlan                                   
        option device 'br-lan'                       
        option vlan '2'                              
        list ports 'bat0.2'                          
                                                     
config interface 'lan'
        option device 'br-lan.1' # VLAN number 1     
        option proto 'static'                        
        option ipaddr '192.168.1.100'                
        option netmask '255.255.255.0'               
        option force_link 'yes'

config interface 'guest'                                 
        option device 'br-lan.2'                     
        option proto 'static'                        
        option ipaddr '192.168.2.100'                                
        option netmask '255.255.255.0'               
        option force_link 'yes'                                  
                                                                 
config interface 'wan'                               
        option device 'eth0'                         
        option proto 'dhcp'                          
                                                    
config interface 'wan6'                                              
        option device 'eth0'                         
        option proto 'dhcpv6'                                 
/etc/config/wireless
config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/a800000.wifi'
        option channel '100'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wifi'
        option encryption 'psk2+ccmp'
        option key 'password'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/a000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'mesh0'
        option device 'radio1'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_fwding '0'
        option mesh_id 'Mesh'
        option encryption 'psk2+ccmp'
        option key 'password'
/etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Any help would be appreciated!

If you are only dealing with two APs, https://openwrt.org/docs/guide-user/network/wifi/atheroswds would be a much simpler and faster approach.