Batman no internet for OpenWrt but connected clients have?

Hi there again,

I did setup batman adv. from this tutorial.
But now i'm stuck the mesh network works also the ap's and lan ports work perfect even the leds are blinking when connected to the mesh network.

but the problem is that everything except the device itself have internet. i get the internet from the batman interface trough the bt0 device than it goes trough diff interfaces with vlans attached to it.

but now i cant update packages or ping google.com trough the device, all the devices connected to the vlan interfaces can. but openwrt can't i tought i need to setup a static gateway on the batman interface or bt0 device but i cant find the option.

this feels weird because every device connected is fine and does what it suppose to i can reach the luci interface from the dynamic dhcp (bc its setup as a dhcp client) its in the right subnet .255 thats my fully accesable home network. but it cant connect to the internet. i dont know where to search anymore, can someone give me a hint. btw its not the dns server because ping 8.8.8.8 gives error

most of the time i did setup the firewall wrong but this device i disabled the firewall dnsmasq and dhcpd.

root@Redmi2:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable

and if i do opkg update

root@Redmi2:~# opkg update
Downloading https://downloads.openwrt.org/releases/21.02.3/targets/ramips/mt7621/packages/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.3/targets/ramips/mt7621/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/base/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/base/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/luci/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/luci/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/packages/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/routing/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/routing/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/telephony/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.3/targets/ramips/mt7621/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.3/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

here is the network and wireless configs
network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fddb:25ec:312c::/48'

config interface 'gasten'
	option proto 'dhcp'
	option defaultroute '0'
	option device 'br-Gasten'

config interface 'thuis'
	option device 'br-thuis'
	option proto 'dhcp'
	option defaultroute '0'

config interface 'IOT'
	option proto 'dhcp'
	option defaultroute '0'
	option device 'br-IOT'

config interface 'bt0'
	option proto 'batadv'
	option bridge_loop_avoidance '1'
	option hop_penalty '30'
	option defaultroute '0'
	option gw_mode 'off'
	option routing_algo 'BATMAN_IV'

config interface 'batman'
	option proto 'batadv_hardif'
	option master 'bt0'
	option defaultroute '0'
	option mtu '2304'

config device
	option type 'bridge'
	option name 'br-IOT'
	list ports 'bt0.1'

config device
	option type 'bridge'
	option name 'br-Gasten'
	list ports 'bt0.100'

config device
	option type 'bridge'
	option name 'br-thuis'
	list ports 'bt0.255'
	list ports 'eth0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan'

wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '2g'
	option htmode 'HT20'
	option country 'NL'
	option cell_density '0'
	option channel 'auto'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'NL'
	option channel '36'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option dtim_period '3'
	option key
	option ssid 'Gaston'
	option network 'gasten'
	option ieee80211r '1'
	option mobility_domain '0c9d'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option encryption 'psk2'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Casita'
	option dtim_period '3'
	option key
	option network 'thuis'
	option ieee80211r '1'
	option mobility_domain 'd421'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option encryption 'psk2'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Dawn'
	option key 
	option network 'IOT'
	option ieee80211r '1'
	option mobility_domain 'a14a'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option encryption 'psk2'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Gaston'
	option encryption 'psk2'
	option key 
	option network 'gasten'
	option ieee80211r '1'
	option mobility_domain '0c9d'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Casita'
	option encryption 'psk2'
	option key 
	option network 'thuis'
	option ieee80211r '1'
	option mobility_domain 'd421'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet7'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Dawn'
	option encryption 'psk2'
	option key ''
	option network 'IOT'
	option ieee80211r '1'
	option mobility_domain 'a14a'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet6'
	option device 'radio1'
	option encryption 'sae'
	option key ''
	option mode 'mesh'
	option mesh_id 'my-mesh'
	option mesh_rssi_threshold '0'
	option network 'batman'
	option mesh_fwding '0'


1 Like

@Elfje4life1 where you able to solve this? If yes, what did you change in your configuration? Thanks a lot :slight_smile:

Im so sorry jrn for the late response, sickness :$.

I remember that the settings where not the problem but i tought and please correct me if im wrong,
that to make connection the times need to be sync of the batman host and client.
The default option need to be turned on on the client interface.

but its really a long time ago if i still had it up and running i could help u so much better, but just yesterday i ruined my setup :dotted_line_face: and it was my own mistake to update from my own build without including the right proto's

1 Like

I have a similar problem I thought I would share. I have a regular mesh with 4 nodes using C7 v2 and the nodes (other than the root node with the DHCP and internet WAN connection) cannot connect to opkg update nor can they ping 8.8.8.8 - but work normally otherwise providing internet to the LAN and AP's.

I never bothered asking why since it appears to be a built in limitation of 802.11s or a security feature that has persisted from versions 19-22. My work around is to run a connection to the internet via ethernet cable to the node's WAN port to do the opkg update.

It is also not a bad idea to have a spare node anyways to test or configure to swap in. I don't really change the node's installed packages that much so it's not too bad for me. I think of it as a security feature as perhaps it would be difficult for an attacker to install anything on the nodes if I can't even.

HTH

Off topic but you can upload an archive from one node to another - but archives don't include packages. For that you would have to do a sysupgrade but I am reluctant to attempt a sysupgrade across the mesh.

1 Like

Thanks for your reply @Elfje4life1 ! I just made sure that the date/time is in sync on both devices. Unfortunately, I am still not able to ping any outside IP, nor can I run opkg update, exactly how @frank92735 mentioned. Not being able to run opkg update is actually how I discovered that I was not able to ping google.com or similar. Next, I'll have to figure out how to install some packages. Connecting the node directly to the internet won't be as easy as for you @frank92735, since I don't have any WAN interfaces on the node. Where did you find the information that this behavior is a built-in limitation for openWRT 19-22? I couldn't find anything just yet :slight_smile:

Thanks a lot for all your responses! Very much appreciated :slight_smile:

I noticed this when testing and configuring a mesh.

I am not proficient in linux but I assume you can copy packages and transfer them to the nodes - I just never have done it. For me it was just easier to workaround it. Now the customized firmware packages feature makes it easier to just load everything I think I will need.

If you can't get to software update on an extender on batman go to the extenderer LAN and check use default gateway and check Use DNS servers advertised by peer

Then go to diagnostics and try to ping something by name

After you are done with software, set those to settings back to unchecked.

I run a 17 unit mesh on a large farm, for providing GPS correction data to robot lawnmowers and self driving tractors.

I use a 5 gig mesh with 2.4 links for the clients off each extender

Odd number ext use channel 11
Even number ext use channel 6
They are then located to minimize crossing channels

The extenders have an ether port, they also are wireless
I use ip 101-117 for the lan and wireless
I add a thing I call VLAN but its not vlan, and I just bridge it to the same thing the wireless is on, this allows a second ip in the unit just for the ether, it also provides me a backdoor to service the extender wired to my laptop of need be, as the wireless lan is dhcp.

The ext are all leased, additionally, they are named a second time with a different mac id and name, which populated the question marks at bottom of screen where associated are shown

All equipment is on the latest release

On the extenders I disable and stop dnsmasq firewall odhcpd
I also delete all firewalls and and WAN on the ext.

I use
wpad-mesh-wolfssl
kmod-batman-adv

luci-proto-batman-adv_git-22.104.47289-0a762fd_all

on all ext and the router.

I use psk on the 2.4 links that the client connects to
I use sae on the 5 gig mesh

On one ext I can plug in my win 7 server and access those files at up to 10 meg wireless or 24 meg when wired to an ext ether port.

DHCP

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option dhcpv4 'server'
	option start '20'
	option leasetime '2m'
	option limit '20'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option name 'Laptop-W'
	option ip '192.168.2.17'
	option mac '00:22:FB:88:5A:E2'

config host
	option name 'Laptop-E'
	option ip '192.168.2.18'
	option mac '5C:26:0A:0F:9E:C8'

config host
	option name 'monkey-DT'
	option ip '192.168.2.19'
	option mac '00:21:9B:1B:62:85'

config host
	option name 'unit101'
	option ip '192.168.2.101'
	option mac '9C:C9:EB:D3:B8:CD'

config host
	option name 'unit102'
	option ip '192.168.2.102'
	option mac '9C:C9:EB:D3:D2:D1'

config host
	option name 'unit103'
	option ip '192.168.2.103'
	option mac '6C:CD:D6:B3:99:54'

config host
	option name 'unit104'
	option ip '192.168.2.104'
	option mac 'CC:40:D0:38:BD:DA'

config host
	option name 'unit105'
	option ip '192.168.2.105'
	option mac 'BC:A5:11:99:2F:43'

config host
	option name 'unit106'
	option ip '192.168.2.106'
	option mac 'BC:A5:11:AE:E2:D5'

config host
	option name 'unit107'
	option ip '192.168.2.107'
	option mac '3C:37:86:10:11:49'

config host
	option name 'unit108'
	option ip '192.168.2.108'
	option mac 'A0:04:60:15:FC:34'

config host
	option name 'unit109'
	option ip '192.168.2.109'
	option mac '14:59:C0:4E:17:F2'

config host
	option name 'unit110'
	option ip '192.168.2.110'
	option mac 'BC:A5:11:B3:AE:EB'

config host
	option name 'unit111'
	option ip '192.168.2.111'
	option mac '38:94:ED:12:93:2C'

config host
	option name 'unit112'
	option ip '192.168.2.112'
	option mac '3C:37:86:34:DA:99'

config host
	option name 'unit113'
	option ip '192.168.2.113'
	option mac '80:CC:9C:80:57:C0'

config host
	option name 'unit114'
	option ip '192.168.2.114'
	option mac '38:94:ED:18:86:E6'

config host
	option name 'unit115'
	option ip '192.168.2.115'
	option mac '28:80:88:FC:5C:4F'

config host
	option name 'unit116'
	option ip '192.168.2.116'
	option mac 'A0:04:60:0F:5D:A8'

config host
	option name 'unit117'
	option ip '192.168.2.117'
	option mac '38:94:ED:12:D5:C2'

#add the mac that gets associated, and a name, eliminates that ? at bottom of page next to mac on associated

config host
	option name 'router'
	option mac 'EC:AD:E0:2D:3B:8D'

config host
	option name 'unit101'
	option mac '9C:C9:EB:D3:B8:CF'

config host
	option name 'unit102'
	option mac '9C:C9:EB:D3:D2:D3'

config host
	option name 'unit103'
	option mac '6C:CD:D6:B3:99:56'

config host
	option name 'unit104'
	option mac 'CC:40:D0:38:BD:DC'

config host
	option name 'unit105'
	option mac 'BC:A5:11:99:2F:45'

config host
	option name 'unit106'
	option mac 'BC:A5:11:AE:E2:D7'

config host
	option name 'unit107'
	option mac '3C:37:86:10:11:5A'

config host
	option name 'unit108'
	option mac 'A0:04:60:15:FC:36'

config host
	option name 'unit109'
	option mac '14:59:C0:4E:17:F4'

config host
	option name 'unit110'
	option mac 'BC:A5:11:B3:AE:ED'

config host
	option name 'unit111'
	option mac '38:94:ED:12:93:2E'

config host
	option name 'unit112'
	option mac '3C:37:86:34:DA:A1'

config host
	option name 'unit113'
	option mac '80:CC:9C:80:57:C2'

config host
	option name 'unit114'
	option mac '38:94:ED:18:86:E8'

config host
	option name 'unit115'
	option mac '28:80:88:FC:5C:51'

config host
	option name 'unit116'
	option mac 'A0:04:60:0F:5D:AA'

config host
	option name 'unit117'
	option mac '38:94:ED:12:D5:C4'

FIREWALL

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'


NETWORK


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'bat0'
	list ports 'eth0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option stp '1'
	option igmp_snooping '1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.253'
	option force_link '0'
	option delegate '0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option delegate '0'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_V'
	option hop_penalty '30'
	option gw_mode 'server'
	option delegate '0'
	option defaultroute '0'
	option peerdns '0'
	option aggregated_ogms '1'
	option bridge_loop_avoidance '1'
	option fragmentation '0'
	option network_coding '0'

config interface 'batmesh'
	option proto 'batadv_hardif'
	option master 'bat0'
	option mtu '1536'
	option delegate '0'
	option defaultroute '0'
	option peerdns '0'



WIRELESS


config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option txpower '20'
	option country 'US'
	option cell_density '0'
	option htmode 'HT40'
	option noscan '1'
	option channel '3'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '5g'
	option txpower '20'
	option country 'US'
	option cell_density '0'
	option htmode 'VHT80'
	option channel '157'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'mesh'
	option mesh_fwding '0'
	option mesh_rssi_threshold '0'
	option network 'batmesh'
	option mesh_id 'CAMELOT-security-mesh'
	option encryption 'sae'
	option key '792camelot'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option encryption 'psk'
	option key '792camelot'
	option ieee80211r '1'
	option mobility_domain '2b3c'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ssid 'GPS-autonomous-perimeter-drones'
1 Like

PREVIOUS POST WAS THE ROUTER, THIS IS THE EXTENDERS
This ext will dhcp the lan to 192.168.2.110
so the ether port is hard ip to 192.168.2.210

NOTE: IMPORTANT
I turnd off all IP6 everywhere and wack out the IPv6 ULA-Prefix ext and router
HOWEVER

The checkbox Enable IPv6 MUST BE YES ON EXT AND ROUTER BR_LAN DEVICE

Also, the Override MTU on BATMESH must be set to 1536

EXTENDER

DHCP

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'
	option start '0'
	option limit '0'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option name 'router'
	option mac 'EC:AD:E0:2D:3B:8D'

config host
	option name 'unit101'
	option mac '9C:C9:EB:D3:B8:CF'

config host
	option name 'unit102'
	option mac '9C:C9:EB:D3:D2:D3'

config host
	option name 'unit103'
	option mac '6C:CD:D6:B3:99:56'

config host
	option name 'unit104'
	option mac 'CC:40:D0:38:BD:DC'

config host
	option name 'unit105'
	option mac 'BC:A5:11:99:2F:45'

config host
	option name 'unit106'
	option mac 'BC:A5:11:AE:E2:D7'

config host
	option name 'unit107'
	option mac '3C:37:86:10:11:5A'

config host
	option name 'unit108'
	option mac 'A0:04:60:15:FC:36'

config host
	option name 'unit109'
	option mac '14:59:C0:4E:17:F4'

config host
	option name 'unit110'
	option mac 'BC:A5:11:B3:AE:ED'

config host
	option name 'unit111'
	option mac '38:94:ED:12:93:2E'

config host
	option name 'unit112'
	option mac '3C:37:86:34:DA:A1'

config host
	option name 'unit113'
	option mac '80:CC:9C:80:57:C2'

config host
	option name 'unit114'
	option mac '38:94:ED:18:86:E8'

config host
	option name 'unit115'
	option mac '28:80:88:FC:5C:51'

config host
	option name 'unit116'
	option mac 'A0:04:60:0F:5D:AA'

config host
	option name 'unit117'
	option mac '38:94:ED:12:D5:C4'



NETWORK


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'bat0'
	list ports 'eth0'
	option igmp_snooping '1'
	option multicast '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'
	option delegate '0'
	option force_link '1'
	option peerdns '0'
	option defaultroute '0'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_V'
	option fragmentation '0'
	option gw_mode 'off'
	option hop_penalty '30'
	option network_coding '0'
	option delegate '0'
	option multicast_mode '0'
	option force_link '1'
	option defaultroute '0'
	option peerdns '0'

config interface 'batmesh'
	option proto 'batadv_hardif'
	option master 'bat0'
	option mtu '1536'
	option delegate '0'
	option defaultroute '0'
	option peerdns '0'
	option force_link '1'

config interface 'vlan'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'br-lan'
	option ipaddr '192.168.2.210'
	option defaultroute '0'



WIRELESS


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option band '2g'
	option htmode 'HT40'
	option country 'US'
	option cell_density '0'
	option noscan '1'
	option channel '6'
	option txpower '14'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'US'
	option channel '157'
	option txpower '14'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'mesh'
	option mesh_fwding '0'
	option mesh_rssi_threshold '0'
	option network 'batmesh'
	option mesh_id 'CAMELOT-security-mesh'
	option key '792camelot'
	option encryption 'sae'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option encryption 'psk'
	option key '792camelot'
	option ieee80211r '1'
	option mobility_domain '2b3c'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ssid 'GPS-autonomous-perimeter-drones'
2 Likes

Thanks for this, it helped me troubleshoot my regular mesh C7 v2 and now I can opkg update and install on nodes remotely.

I forgot to disable odchpd, firewall, dnsmasq on the nodes (leave the gateway node alone).

Eventually I will try BATMAN.

Thanks for everything u guys, it works now way way better.

Does someone know if the packages:
luci-proto-batman-adv_git-22.104.47289-0a762fd_all

is in the opkg yet?

I don't think it is available just yet, so you'd have to manually upload it and then install it. You can get the package from the developer's github.