BATMAN missing Wifi-Interface

Hi there,

I am experimenting with BATMAN and ran into several problems.

I have three wifi cards that i want to add to bat0

Therefor i have modified /etc/config/network and /etc/config/wireless

The output of

batctl bat0 if
wlan1: active
wlan0: active

show that only two and not all three wifi devices belong to bat0.

I do not find the error in my config files why wlan2 does not show up.

I hope you can help me with that.

EDIT:
I found out that manual adding of wlan2 to bat0 does work. batctl bat0 if add wlan2
For some reason it does not work on boot automatically.

Edit2:
As a workaround I am using rc.local to add the interface at boot time. It works but it is not the right way to do it.
I am clueless why the interface wlan2 is not added by my network and wireless config scripts automatically.

ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-default state UP qlen 1000
    link/ether 10:7b:44:d5:4f:c9 brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-default state DOWN qlen 1000
    link/ether 10:7b:44:d5:4f:cb brd ff:ff:ff:ff:ff:ff
7: br-default: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 10:7b:44:d5:4f:cb brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.233/24 brd 192.168.1.255 scope global br-default
       valid_lft forever preferred_lft forever
    inet 192.168.178.79/24 brd 192.168.178.255 scope global br-default
       valid_lft forever preferred_lft forever

       valid_lft forever preferred_lft forever
8: bat0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-default state UNKNOWN qlen 1000
    link/ether 52:98:1e:0b:b0:a5 brd ff:ff:ff:ff:ff:ff
9: wlan2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 10:7b:44:d5:4f:ca brd ff:ff:ff:ff:ff:ff

       valid_lft forever preferred_lft forever
10: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1560 qdisc noqueue master bat0 state UP qlen 1000
    link/ether 10:7b:44:d5:4f:c8 brd ff:ff:ff:ff:ff:ff

       valid_lft forever preferred_lft forever
11: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master bat0 state UP qlen 1000
    link/ether 10:7b:44:d5:4f:cc brd ff:ff:ff:ff:ff:ff

       valid_lft forever preferred_lft forever
12: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-default state UP qlen 1000
    link/ether 12:7b:44:d5:4f:cc brd ff:ff:ff:ff:ff:ff

       valid_lft forever preferred_lft forever
cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'DE'
        option disabled '0'
        option cell_density '0'
        option htmode 'VHT80'

config wifi-iface 'wmesh5g0'
        option device 'radio0'
        option network 'mesh5g0'
        option mode 'mesh'
        option mesh_id 'MeshCloud'
        option encryption 'sae'
        option key 'Password'
        option mesh_fwding '0'
        option mesh_ttl '1'
        option mcast_rate '24000'
        option disabled '0'
        option mesh_rssi_threshold '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option network 'default'
        option mode 'ap'
        option ssid 'wrt233'
        option encryption 'psk2+aes'
        option key 'Password'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option country 'DE'

config wifi-iface 'wmesh2g'
        option device 'radio1'
        option network 'mesh2g'
        option mode 'mesh'
        option mesh_id 'MeshCloud'
        option encryption 'sae'
        option key 'Password'
        option mesh_fwding '0'
        option mesh_ttl '1'
        option mcast_rate '24000'
        option mesh_rssi_threshold '0'

config wifi-device 'radio2'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option country 'DE'
        option disabled '0'
        option cell_density '0'
        option channel '153'
        option htmode 'VHT80'

config wifi-iface 'wmesh5g2'
        option device 'radio2'
        option network 'mesh5g2'
        option mode 'mesh'
        option mesh_id 'MeshCloud'
        option encryption 'sae'
        option key 'Password'
        option mesh_fwding '0'
        option mesh_ttl '1'
        option mcast_rate '24000'
        option disabled '0'
        option mesh_rssi_threshold '0'

cat /etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-default'
        option type 'bridge'
        list ports 'eth1'
        list ports 'eth0'
        list ports 'bat0'

config interface 'default'
        option device 'br-default'
        option proto 'dhcp'

config interface 'admin'
        option device 'br-default'
        option proto 'static'
        option ipaddr '192.168.1.230'
        option netmask '255.255.255.0'

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_V'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option fragmentation '1'
        option gw_mode 'off'
        #option gw_sel_class '20'
        #option gw_bandwidth '10000/2000'
        option hop_penalty '0'
        option isolation_mark '0x00000000/0x00000000'
        option log_level '0'
        option multicast_mode '1'
        option multicast_fanout '16'
        option network_coding '0'
        option orig_interval '1000'


config interface 'mesh2g'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '1560'

config interface 'mesh5g0'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '1560

config interface 'mesh5g2'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '1560

Found the error.
At the end of the network-config-file there were apostrophe's missing at the mtu line.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.