Batman mesh: penalties for 2.4 ghz networks?

Hi!

I am living in a flat with 2 floors. I can not use cabled connections. Therefore I have build a batman mesh with 6 CUDY WR3000. I am using 2.4 and 5 GHZ wlan to connect the dumb APs accross, since not all routes can be handled with 5ghz network or 5Ghz might be instable after a reboot while the APs have not synched clocks.
However, I recognized that the mesh routing prefers the 2.4 ghz mesh quite often.

Is there a way to add penalties for that route?

Kind regards,
Christian

/etc/config/network:

...
config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option fragmentation '1'
        option gw_mode 'off'
        option log_level '0'
        option orig_interval '1000'
config interface 'nwi_mesh2g'
        option mtu '2304'
        option proto 'batadv_hardif'
        option master 'bat0'

config interface 'nwi_mesh5g'
        option mtu '2304'
        option proto 'batadv_hardif'
        option master 'bat0'
...

/etc/config/wireless

...
config wifi-iface 'mesh2g'
        option device 'radio0'
        option ifname 'mesh2g'
        option mode 'mesh'
        option mesh_id 'mesh-2ghz'
        option key '(REDACTED)'
        option mesh_fwding '0'
        option mesh_rssi_threshold '0'
        option encryption 'sae'
        option network 'nwi_mesh2g'
        option disabled '1'

config wifi-iface 'mesh5g'
        option device 'radio1'
        option ifname 'mesh5g'
        option mode 'mesh'
        option mesh_id 'mesh-5ghz'
        option key '(REDACTED)'
        option mesh_fwding '0'
        option mesh_rssi_threshold '0'
        option encryption 'sae'
        option network 'nwi_mesh5g'
        option disabled '0'
...

would creating a separate bat1 interface solely on the 2.4Ghz connections solve your problem? This would put the 2.4Ghz wifi on its own batman-adv network.

Having said that not sure why you would want to use batman-adv for such a small setup. You could probably achieve better results with just a WDS network and fine-tuning the radios and antennas to give you household coverage.

Thank you! I do have vlans.

you can include VLANs for the bat0 and bat1 interfaces dedicated to each of the 2.4GHz and the 5Ghz radios.

Thanks. This was more the answer to your question, why i use Batman in the first place.

How do you then make sure, that If one bandwith is not available, the other takeover? Currently this is fully managed by the bat0 Interface.

my proposed solution was to keep the 2.4Ghz and 5Ghz channels separated onto their own bat interfaces. I am assuming you are terminating BAT0 at the final wired hop and not meshing all the way to your GW. That theoretically should mean if 5GHz is not available then you will be on the BAT1 interface on the 2.4GHz.

Likewise, if you have multiple wireless hops then you might need to create BAT2, BAT3....etc at each hop so that you terminate the outer most BATx interface at each hop. Caveat here: I have not tried a setup like this so can't tell you if it's going to be successful or not.