BATMAN Mesh Packet loss with 24.10.0

Hi!

Since the update to OpenWRT 24.10.0 I have trouble with my network, especially my android mobile phone, with a lot of packet loss. Android is detecting a Internet connection, but surfing seems to be almost impossible.
Since I also updated (almost during the same time) my opnsense firewall, I thought this is the problem. Maybe it still is...

Here are my issues:

  • Mobile phone is getting a lot of packet loss. (Maybe because I carry it with me in my flat?)
  • My private laptop seems to work nice - but when pinging my main AP, I get sometime errors, specially when on video calls from my work PC.
  • My video calls sometimes stutter

I live in a flat with two floors. Since I can not use cables and as a IT guy I have some equipment (streaming, servers, etc) I need to connect on different ways to the internet or use internally. Therefore I have vlans and that is the reason I use BATMAN and not just MESH.
In total I have 6 WR3000 APs across my flat. One of them is connected to my opnsense firewall which is getting WAN via PPPOE (German Telekom, MTU 1492!).

On my main AP I have a Test Wlan. When connected to this, I do not see any issues.
Also other devices, like my TV, connected via cable to one of the Mesh nodes, work okay, but not fine.
Also - when rebooting all my Mesh APs, I do not see any issue.

I do not know any more angle to analyze this - therefore - anything hints? I know my setup is not the best, but it worked okay with 23.05.XX...

Here is my config:

network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'XXXX'
	option packet_steering '0'

config device
	option name 'switch'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config bridge-vlan 'lan_vlan'
	option device 'switch'
	option vlan '10'
	list ports 'lan1:u*'
	list ports 'bat0.10'

config bridge-vlan 'guest_vlan'
	option device 'switch'
	option vlan '20'
	list ports 'lan2:t'
	list ports 'bat0.20'

config bridge-vlan 'iot_vlan'
	option device 'switch'
	option vlan '30'
	list ports 'lan2:t'
	list ports 'bat0.30'

config bridge-vlan 'manage_vlan'
	option device 'switch'
	option vlan '50'
	list ports 'lan2:t'
	list ports 'lan3:u*'
	list ports 'bat0.50'

config bridge-vlan 'wireguarded_vlan'
	option device 'switch'
	option vlan '66'
	list ports 'lan2:t'
	list ports 'bat0.66'

config interface 'lan'
	option device 'switch.10'
	option proto 'dhcp'

config interface 'guest'
	option device 'switch.20'
	option proto 'static'
	option ipaddr '192.168.222.XXX'
	option netmask '255.255.255.0'
	option defaultroute '0'

config interface 'iot'
	option device 'switch.30'
	option proto 'static'
	option ipaddr '192.168.254.XXX'
	option netmask '255.255.255.0'
	option defaultroute '0'

config interface 'manage'
	option device 'switch.50'
	option proto 'static'
	option ipaddr '192.168.166.XXX'
	option netmask '255.255.255.0'
	option defaultroute '0'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '1'
	option gw_mode 'off'
	option log_level '0'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh2g'
	option mtu '2304'
	option proto 'batadv_hardif'
	option master 'bat0'

config interface 'nwi_mesh5g'
	option mtu '2304'
	option proto 'batadv_hardif'
	option master 'bat0'

config device
	option type 'bridge'
	option name 'br-failsafe'
	option bridge_empty '1'
	list ports 'wan'

config interface 'failsafe_lan'
	option proto 'static'
	option device 'br-failsafe'
	option ipaddr '192.168.X.1'
	option netmask '255.255.255.0'
	option defaultroute '0'

wireless:


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi'
	option channel '6'
	option band '2g'
	option htmode 'HE40'
	option country 'DE'
	option cell_density '0'
	option noscan '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'WLAN'
	option encryption 'sae-mixed'
	option key 'XXXX'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '0'
	option mobility_domain '4f57'
	option ieee80211k '1'
	option time_advertisement '2'
	option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option bss_transition '1'
	option wds '1'

config wifi-iface 'guest_radio0'
	option device 'radio0'
	option network 'guest'
	option mode 'ap'
	option ssid 'WLAN.guest'
	option encryption 'sae-mixed'
	option key 'XXXX'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '0'
	option mobility_domain '8f12'
	option ieee80211k '1'
	option time_advertisement '2'
	option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option bss_transition '1'
	option wds '1'

config wifi-iface 'iot_radio0'
	option device 'radio0'
	option network 'iot'
	option mode 'ap'
	option ssid 'WLAN.iot'
	option encryption 'psk2'
	option key 'XXX'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '0'
	option mobility_domain '1d1f'
	option ieee80211k '1'
	option time_advertisement '2'
	option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option bss_transition '1'
	option wds '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option channel '120'
	option country 'DE'
	option band '5g'
	option htmode 'HE160'
	option cell_density '0'
	option noscan '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'WLAN'
	option encryption 'sae-mixed'
	option key 'XXX'
	option ieee80211r '1'
	option mobility_domain '4f57'
	option ft_over_ds '0'
	option ft_psk_generate_local '0'
	option ieee80211k '1'
	option time_advertisement '2'
	option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option bss_transition '1'
	option wds '1'

config wifi-iface 'mesh2g'
	option device 'radio0'
	option ifname 'mesh2g'
	option mode 'mesh'
	option mesh_id 'mesh-2ghz'
	option key 'YYY'
	option mesh_fwding '0'
	option mesh_rssi_threshold '0'
	option encryption 'sae'
	option network 'nwi_mesh2g'
	option disabled '0'

config wifi-iface 'mesh5g'
	option device 'radio1'
	option ifname 'mesh5g'
	option mode 'mesh'
	option mesh_id 'mesh-5ghz'
	option key 'XXX'
	option mesh_fwding '0'
	option mesh_rssi_threshold '0'
	option encryption 'sae'
	option network 'nwi_mesh5g'
	option disabled '0'

Thank you,
Christian

1 Like

Get rid of this yesterday

Probably not a good idea to try wds and mesh in same adapter.

Thanks for your feedback! Will change the WDS option.
Both settings were during test - for sure I am compliant with the local law. :wink:

However - I had the WDS option also active with 23.05.5 and my Mesh were stable. Do you think a current change might cause a issue here?

Yeah, noscan is compliant, but 40mhz channel is usually slower than 20mhz if in range of competing transmissions.

I have reverted to 23.05.5 and my network is working again. I still have no angle about getting this analyzed.

maybe 23.05.5?

1 Like

You are right. Thanks