Batman mesh MTU configuation

The br-lan interface stays at mtu 1500, but you have to set the MTU on the batman wireless interface. My device and interface config looks like:

config device
    option  name            'bat0'

config interface            'bat0'
    option  proto           'batadv'
    option  routing_algo    'BATMAN_IV'

config interface            'bat0_hardif_mesh0'
    option  proto           'batadv_hardif'
    option  master          'bat0'
    option  mtu             '2304'

config interface            'bat0_hardif_mesh1'
    option  proto           'batadv_hardif'
    option  master          'bat0'
    option  mtu             '2304'

The corresponding /etc/config/wireless sections look like:

config wifi-iface 'mesh0'
    option  disabled    '0'
    option  device      'radio0'
    option  ifname      'mesh0'
    option  network     'bat0_hardif_mesh0'
    option  mode        'mesh'
    option  mesh_fwding '0'
    option  mesh_id     'fde6:a09a:b373::/48'
    option  encryption  'psk2+ccmp'
    option  key         'XXX'

config wifi-iface 'mesh1'
    option  disabled    '0'
    option  device      'radio1'
    option  ifname      'mesh1'
    option  network     'bat0_hardif_mesh1'
    option  mode        'mesh'
    option  mesh_fwding '0'
    option  mesh_id     'fde6:a09a:b373::/48'
    option  encryption  'psk2+ccmp'
    option  key         'XXX'

For a reference, have a look at: https://www.open-mesh.org/projects/batman-adv/wiki/Quick-start-guide

PS: Why 2304? https://en.wikipedia.org/wiki/Maximum_transmission_unit

1 Like