Batman mesh bridged Issue

Hello

I have install openwrt on three devices with snapshot commit f07fe36f22fcf3f3da4e0440dfc5c39516e2cb55 .I have installed kmod-batman-adv and wpad-mesh-wolfssl.
it's working fine but i have some latencies and some instabilities.

I try to install the latest snapshot d49f1acff1a79992c474fceaeac066671f838a2c.
There is no traffic between batman interfaces.

/etc/config/network of primary node

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd00:ca16:4047::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'lan1 lan2'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '1'
	option gw_mode 'off'
	option log_level '0'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
	option mtu '1536'
	option proto 'batadv_hardif'
	option master 'bat0'

config interface 'nwi_mesh1'
	option mtu '1536'
	option proto 'batadv_hardif'
	option master 'bat0'

config interface 'LAN_INTERNE'
	option type 'bridge'
	option stp '1'
	option proto 'dhcp'
	option ifname 'bat0.1 lan3 wan'
	option igmp_snooping '1'

/etc/config/wireless of primary node

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'HT20'
	option cell_density '0'
	option noscan '1'
	option channel '5'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option noscan '1'
	option cell_density '0'
	option channel '48'

config wifi-iface 'mesh_radio0'
	option mode 'mesh'
	option device 'radio0'
	option ifname 'wlan0-mesh'
	option mcast_rate '6000'
	option distance '1000'
	option mesh_fwding '0'
	option mesh_id 'mesh0'
	option encryption 'sae'
	option key '<password>'
	option network 'nwi_mesh0'
	option mesh_rssi_threshold '0'

config wifi-iface 'mesh_radio1'
	option mode 'mesh'
	option device 'radio1'
	option ifname 'wlan1-mesh'
	option mcast_rate '6000'
	option distance '1000'
	option mesh_fwding '0'
	option mesh_id 'mesh0'
	option encryption 'sae'
	option key '<password>'
	option network 'nwi_mesh1'
	option mesh_rssi_threshold '0'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt-primary-br-bat0.1'
	option encryption 'psk-mixed'
	option network 'bat0.1 LAN_INTERNE'
	option hidden '1'
	option key '<password>'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'ap'
	option ssid 'RRE'
	option encryption 'psk-mixed'
	option key '<password>'
	option network 'bat0.1 LAN_INTERNE'
	option ieee80211r '1'
	option mobility_domain '3BCA'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'RRE'
	option encryption 'psk-mixed'
	option key '<password>'
	option network 'bat0.1 LAN_INTERNE'
	option ieee80211r '1'
	option mobility_domain '3BCA'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet6'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt-primary-lan '
	option encryption 'sae-mixed'
	option ieee80211w '1'
	option network 'lan'
	option key '<password>'
	option hidden '1'

config wifi-iface 'wifinet7'
	option device 'radio0'
	option mode 'ap'
	option ssid 'pc-engine'
	option encryption 'psk'
	option hidden '1'
	option key '<password>'
	option network 'LAN_INTERNE'

/etc/config/network of secondary node

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd41:3fda:546b::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'lan1'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '1'
	option gw_mode 'off'
	option log_level '0'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
	option mtu '1536'
	option proto 'batadv_hardif'
	option master 'bat0'

config interface 'nwi_mesh1'
	option mtu '1536'
	option proto 'batadv_hardif'
	option master 'bat0'

config interface 'LAN_INTERNE'
	option proto 'dhcp'
	option type 'bridge'
	option stp '1'
	option ifname 'bat0.1 lan2 lan3'

/etc/config/wireless of secondary node

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'HT20'
	option cell_density '0'
	option noscan '1'
	option channel '5'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt-secondary-lan'
	option ieee80211w '1'
	option encryption 'psk-mixed'
	option hidden '1'
	option key '<password>'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option noscan '1'
	option cell_density '0'
	option channel '48'

config wifi-iface 'mesh_radio0'
	option mode 'mesh'
	option device 'radio0'
	option ifname 'wlan0-mesh'
	option mcast_rate '6000'
	option distance '1000'
	option mesh_fwding '0'
	option mesh_id 'mesh0'
	option encryption 'sae'
	option key '<password>'
	option network 'nwi_mesh0'
	option mesh_rssi_threshold '0'

config wifi-iface 'mesh_radio1'
	option mode 'mesh'
	option device 'radio1'
	option ifname 'wlan1-mesh'
	option mcast_rate '6000'
	option distance '1000'
	option mesh_fwding '0'
	option mesh_id 'mesh0'
	option encryption 'sae'
	option key '<password>'
	option mesh_rssi_threshold '0'
	option network 'nwi_mesh1'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'ap'
	option ssid 'RRE'
	option encryption 'psk-mixed'
	option key '<password>'
	option network 'bat0.1 LAN_INTERNE'
	option ieee80211r '1'
	option mobility_domain '3BCA'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'RRE'
	option encryption 'psk-mixed'
	option key '<password>'
	option network 'bat0.1 LAN_INTERNE'
	option ieee80211r '1'
	option mobility_domain '3BCA'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt-secondary-br-bat0.1'
	option encryption 'psk-mixed'
	option network 'bat0.1 LAN_INTERNE'
	option hidden '1'
	option key '<password>'

Thanks for your help :slight_smile:

When starting out with meshes it is simplest to put the bat interface into the existing br-lan rather than make more networks. The nodes will be basically "dumb APs" but connected by mesh instead of by cables. Turning on stp allows you to also connect by cable for testing without having a problem with a loop.

Don't have more than one network in the option network option in /etc/config/wireless. Setting 'LAN_INTERNE' is sufficient since the network config defines it as the bridge master of bat0.1

And of course when something "doesn't work", check your log file for relevant errors. Additional useful diagnostics are batctl n (requires batctl-full) and iwinfo <mesh radio interface> assoclist.

Hello

Thks for thé Reply.:grinning:

i will test soon.

Regards