Basic VLAN Tagging with Virtual SSID

I've been running a basic set-up on my Netgear R6700v2. There are two SSIDs: one for normal traffic, and the other for IoT devices. The IoT SSID is VLAN tagged so that my pfSense router can isolate the traffic.

After switching to a Linksys E8450, clients can no longer communicate with my router. The "iot" interface can, however, and will be assigned the appropriate IP address if I configure it for DHCP, but not wireless clients. I remember having this issue when setting up the Netgear, but it has been so long.

Anyways, are there any quirks with the E8450, or is it incapable of VLAN tagging traffic like my old Netgear?

Here's my working config for the Netgear:

/etc/network

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'br-iot'
	list ports 'wan.21'

config interface 'iot'
	option proto 'none'
	option device 'br-iot'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '21'
	option name 'wan.21'

/etc/wireless

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option encryption 'sae-mixed'
	option hidden '1'
	option key 'MY PASSWORD'
	option network 'iot'
	option ssid 'IoT'

I'm sorry for any ignorance on my part. This is just a hobby for me.

Edit: I'm running OpenWRT 23.05.0

You've got a mix of DSA and swconfig syntax which won't work. Your device has gone through the DSA transition. Therefore, here's what you need to change...

Start by deleting these stanzas:

Now, add the following bridge-vlans:

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'
	list ports 'wan:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '21'
	list ports 'wan:t'

Now, edit the lan to use device br-lan.1 like this:

config interface 'lan'
	option device 'br-lan.1'
	option proto 'dhcp'

Do the same with the iot interface for br-lan.21:

config interface 'iot'
	option proto 'none'
	option device 'br-lan.21'

Restart and it should work.

1 Like

That worked, thank you. I'll do some reading on that syntax as well.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.