Basic client configuration for second device running OpenWrt

Currently, I have an OpenWrt device, used as an access point, connected to non-wireless appliance serving as a router. Wireless devices are able to connect to the access point, as expected, and access local as well as internet resources.

I am attempting to add a second OpenWrt device of the same hardware, in a mesh configuration, for more comprehensive coverage. The first step, I have come to understand, is to acquire one of the wpad-mesh- packages on the second device (it is not clear to me whether the same is also required on the first device, the one serving as the principle access point).

For the package manager to acquire the target package and all dependencies, it needs internet access. I understand that I can provide it with internet access by joining it to the existing wireless network. However, even after joining the second device to the wireless network provided by the first device, I had no success reaching the package repository.

What do I need to make this initial configuration work, of the second device gaining internet access as a wireless client to the first, other than joining the network in the wireless settings?

The second device currently has a static address, which is accessed (by cable) for administration. Do I need a second IP address for the interface of the joined wireless network? Do I need a static route on the first device? Do I need neither of these but something else entirely?

Will both OpenWrt devices be wired to the network? This is preferable as compared to a wireless backhaul. If so, just configure the new device as a dumb AP.

If you need to go wireless, there are a few ways to do it, but it might be useful to know what hardware you are using?

1 Like

@psherman: Hardware is Cudy x6.

Note I am already past the point explained by the article you have referenced. The difficulty now is the second router having access to the internet by being a client of the one now serving as an access point (which is the same hardware, and is eventually targeted for a mesh pairing).

Ok... so mesh it is. I am actually not the best person to help with this since I don't use mesh. Hopefully someone else can chime in here.

Regarding getting it online so that you can download and install packages -- that is pretty simple following the dumb AP guide and then connecting it via wire to the existing network. As long as you have the DNS, subnet mask, and upstream router/gateway properly defined, the router should be able to access the OpenWrt repos to install packages using the opkg package manager.

@psherman: I understand, Of course other information relating to my overall objectives is also helpful, but the core question of my post was about giving the second device internet access without any cabling.

@psherman: The process was different for me from the one explained in the article, as my experience with the user interface is not well represented by the captures. Use of the interface for me was rather cumbersome, compared to the clean and uncluttered layout shown in the guide. Further, there was no stage in my process relating to creating firewall zones, and I am not sure whether that difference is important.

I am running a firmware image based on "OpenWrt 21.02-SNAPSHOT r15949-b2c9a8741f".

I have 2 Cudy-6 and no problem Cudy-6 <... Wifi 5 GHz ....> Cudy-6

WIFI-1

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option band '5g'
	option cell_density '0'
	option htmode 'HE80'
	option country 'FR'
	option channel 'auto'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'AX-182_5GHz'
	option encryption 'psk2'
	option key '1234567890'
	option wpa_disable_eapol_key_retries '1'
	option wds '1'
	option network 'lan'

WIFI-2

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'

	config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'sta'
	option ssid '182_5GHz'
	option bssid 'E4:67:1E:2D:E0:7A'
	option encryption 'psk2'
	option key '1234567890'
	option wds '1'
	option network 'lan'

Network-1

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.182'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'
	list dns '8.8.8.8'

Network-2

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.183'
	option gateway '192.168.1.1'
	list dns '8.8.8.8'
	list dns '192.168.1.1'

Thanks for the response.

I eventually solved this problem by reinitializing the firmware image and repeating the configuration steps manually.

I suppose either I inadvertently created some unwanted configuration, or the original firmware load was not fully successful.

Thanks for your earlier reply.

I posted further descriptions of my continued adventures running OpenWrt on this device, and would be happy for any constructive responses you have regarding my observations.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.