Bash autocompletion problem in 18.06-rc1

there are some subtle autocompletion problems in bash 4.4.18 in latest rc1 from 18.06:

  1. -. - shortcut for latest argument doesn't work as expected. It should cycle in the last 'n' arguments and it does repeat latest argument
  2. double tab doesn't produce possible-completions ( although -? produce it as expected ).
    There can be possibly more problems, but I report the ones I tested and know how they should work.
1 Like

I have exactly the same problem with the tab key on 18.06.1 r7258-5eb055306f, bash 4.4.18(1). Does anybody know how to fix it?

You are aware that, OpenWrt doesn't use Bash by default?

See: HOME and END keys don't work, replaced Busybox with BASH

Thanks for the reply. I just installed bash via opkg, modified /etc/passwd & then google brought me here.

Should I fill the issue at

I'm not certain of what issue you're having, it was noted that Busybox is used by default. In addition, history is not compiled into the OpenWrt version of Bash.

This was noted at Post No. 18 on the link I provided above:

If your issue is with Bash, you likely have to compile a custom Bash with the features you desire.

Bash history works fine, all my usual favourite history-search-backward/forward settings + Ctrl+r search are ok, for example.

What doesn't work properly is so called possible-completions binding, e.g.:

# cd /
# ls #<=== if I press <TAB> multiple times (after the space)--nothing happens!

If, instead of the TAB, I hit alt+=, then bash indeed prints the completions. This is so bizarre, I've never encountered such a behaviour.

xterm under fedora, mintty from cygwin, cmder under w10--all exibit the same behaviour


# echo $TERM

Your right, TAB not working with bash.
I didn't realize i was testing with busybox/ash

Works for me (18.06.1 tho, not the older rc1 build). Maybe a trouble with the terminal?