Bandwidthd Not tracking HTTP(s) traffic

I have bandwidthd installed on my Banana pi Wifi 6 router.

I have a br-lan (bridge interface) setup that will forward all my LAN and WLAN connections to the internet via wan.

l also have a guest wifi at wlan0-1 which reaches internet directly via wan.

Ideally I want to be able to track bandwidth usage on both br-lan and wlan0-1
But sadly bandwidthd cannot track two dev at once. I have tried enabling promiscous mode and also tried tracking any devices.

I know I'm consuming data because on my mac I can surf the web and consume content while connected to the router. But even with the graph option enabled on bandwidthd I can see barely any usage from my IP.

Please advice on what I might be doing wrong here. I can share my configs if required.

cat /etc/network/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        option igmp_snooping '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option multicast_to_unicast '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'

config interface 'wan'
        option device 'wan'
        option reqopts '33 43 249'
        option vendorid 'dslforum.org'
        option proto 'dhcp'
        option disabled '0'
        option type 'bridge'

config interface 'Guest'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'
 cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/wmac.1'
        option band '2g'
        option htmode 'HE20'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/wmac.2'
        option band '5g'
        option htmode 'HE80'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Fresh24'
        option encryption 'psk'
        option key '******'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'FreshGuest'
        option encryption 'none'
        option network 'Guest'
        option macaddr '62:11:52:A1:A0:CE'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid 'Fresh5'
        option encryption 'psk'
        option key '*******'
        option network 'lan'
ip --br link show

lo               UNKNOWN        00:00:00:00:00:00 <LOOPBACK,UP,LOWER_UP>
eth0             UNKNOWN        d4:77:2b:55:55:55 <BROADCAST,MULTICAST,UP,LOWER_UP>
wan              UP             d4:77:2b:55:55:56 <BROADCAST,MULTICAST,UP,LOWER_UP>
lan1             DOWN           d4:77:2b:55:55:57 <NO-CARRIER,BROADCAST,MULTICAST,UP>
lan2             DOWN           d4:77:2b:55:55:58 <NO-CARRIER,BROADCAST,MULTICAST,UP>
lan3             DOWN           d4:77:2b:55:55:59 <NO-CARRIER,BROADCAST,MULTICAST,UP>
lan4             DOWN           d4:77:2b:55:55:5a <NO-CARRIER,BROADCAST,MULTICAST,UP>
wlan0            UP             f0:11:52:bc:03:c0 <BROADCAST,MULTICAST,UP,LOWER_UP>
br-lan           UP             d4:77:2b:55:55:57 <BROADCAST,MULTICAST,UP,LOWER_UP>
wlan1            UP             64:11:52:3a:bb:46 <BROADCAST,MULTICAST,UP,LOWER_UP>
wlan0-1          UP             62:11:52:a1:a0:ce <BROADCAST,MULTICAST,UP,LOWER_UP>
brctl show

bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.d4772b555557       no              lan4
                                                        lan2
                                                        wlan0
                                                        lan3
                                                        wlan1
                                                        lan1

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

2 Likes

Please post output of

ubus call system board

Here you go

{
        "kernel": "5.10.138",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 1 (v7l)",
        "model": "THG6500-TAX2",
        "board_name": "THG6500-TAX2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "TGP",
                "version": "3.1.0",
                "revision": "r19685-512e76967f",
                "target": "tr6560/generic",
                "description": "TGP 3.1.0 "
        }
}

Yes we are not running the official image of OpenWRT. We built it from this repo here

We tried installing the official image for this board but that doesn't seem to exists? Am I wrong?

not really the BPI Wifi6, is it ?

you're not.

related Bpi-wifi6 git repo

Apologies, got confused with the other router I had. Updated it now.
Here you go.

{
        "kernel": "5.10.138",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 1 (v7l)",
        "model": "THG6500-TAX2",
        "board_name": "THG6500-TAX2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "TGP",
                "version": "3.1.0",
                "revision": "r19685-512e76967f",
                "target": "tr6560/generic",
                "description": "TGP 3.1.0 "
        }
}

np, but it doesn't really change anything ...

So, my only option is to check the firmware from the guys who built this router?
Anyway, thanks!

for now, yes.

do read the thread I posted earlier.

1 Like