I recently got this router and it has been amazing. SQM,adblock all working beautifully.
However I have an issue with Band-Steering. I have a single SSID for 2,4/5Ghz and a single router, no other APs. So I only want devices to change from 1 band to the other on the same device. My phone is a Oneplus 9 Pro and my brother has a Oneplus 6, both support 5ghz and the signal is excellent. Even being on top of the router won't make them switch.
Strangely enough, if I disconnect and reconnect back on the phones, they will connect to 5ghz,however if I reboot them,they will go to 2.4ghz and Never switch to 5ghz.
I have tried DAWN as well as usteer ,but havent had much success.
I haven't been able to add from the guide:
"/etc/config/wireless to each of your SSIDs:
option bss_transition '1'"
The wifi interfaces simply won't start when I do that.
I have tried all sorts of settings but its my first time setting this up so I am not really sure what im doing:
You can take usteer, much easier for small LAN.
wpad-mbedtls (one without -basic-) is needed for measuring parts of kvr.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
root@OpenWrt:~# cat /etc/config/firewall
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT
# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT
# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP
# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp
# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp
### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT
#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
Firewall - default
Dhcp - default
Do you see 5G access point at all, it may happen that radar detection prevents it from running. Try 80MHz for starters, also make sure device country is GB, Europe or US has different channel restrictions than UK, and only least common set of channels can be used.
You will need to remove wpad-basic-mbedtls and replace it with wpad-mbedtls to have roaming protocols supported. Then for dawn you need to enable 11k and 11v via config file, you can skip complexity by removing dawn and installing usteer.
Config/network - OK, nothing strange
system board - latest version, nice
If you need precise guidance on install/uninstall commands give a sign. doing it from wired connection is more forgiving about mistakes.
It was all because of wpad, it wouldnt let me install wpad-mbedtls due to some dependancies, so I had to force remove it, then do a full reboot and install wpad-mbedtls
This showed all the options even in the UI for the wifi interface.
I've installed usteer and at default it didnt work, I changed these:
Band steering interval 20000
Attempting to steer clients to a higher frequency-band every n ms. A value of 0 disables band-steering.
Band steering min SNR -70
Minimal SNR or absolute signal a device has to maintain over band_steering_interval to be steered to a higher frequency
Phones switched automatically after 20 seconds as expected. Beautiful!
You need wpad-mbedtls to support those options, usteer will enable them on the fly if supported. If options are not supported by hostapd (part of wpad) then option to measure signal on other radio or kick clients is very limited.