Banana Pi R4 how to change WAN port to LAN

Hi guys,
I am a noob here with OpenWrt, I bought a Banana Pi R4 with SFP ports and added a wired SFP 10Gb for my Main Wan port, and it is working great, my ISP speeds bumped like 30% or more from my R7800 DDWRT, so happy with the upgrade, but I will like to use the wired 1Gb mark as WAN to an additional LAN port, my old R7800 had 4 ports and I was using all of them and I don't have space to put another switch.

typically it is as simple as removing the port from the wan network interface (or from br-wan) and adding it to br-lan.

To be sure we can guide you to do the right change, let's see the config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network

Here

{
        "kernel": "6.6.73",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 0",
        "model": "Bananapi BPI-R4",
        "board_name": "bananapi,bpi-r4",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r28656-761b244964",
                "target": "mediatek/filogic",
                "description": "OpenWrt SNAPSHOT r28656-761b244964",
                "builddate": "1737499300"
        }
}
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd5:2451:faab::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'sfp-lan'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.11.1/24'
        option delegate '0'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'sfp-wan'
        list ports 'wan'

config device
        option name 'wan'
        option macaddr '72:06:f9:65:85:43'

config device
        option name 'sfp-wan'
        option macaddr '72:06:f9:65:85:43'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcp'

Done
:saluting_face:
Thanks in advance

So assuming you're using the sfp wan port currently, just remove the regular wan port (last line) from br-wan:

Then add it to br-lan like this:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'sfp-lan'
        list ports 'wan'
        option ipv6 '0'

Restart and test. It should work.

1 Like

Thanks @psherman it worked like a charm.
Thanks for the help

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.