Banana Pi R2 Bridge Vlan filtering problem

Hi ,
I am trying to add vlans on Banana Pi R2 OpenWrt 21.02.1, r16325-88151b8303

I configured Bridge Vlan Filtering but vlans not works.
When i added wan port to bridge lan0 and lan1 joined to vlan1 but wan side destroyed even can not ping its gw

Is this known bug?

any help would be apreciated

Here is configs:

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddd:99e7:d28b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'none'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan0'
        list ports 'lan1'

What exactly are you trying to achieve with your configuration? Your lan is unmanaged, so it would be expected that there would be no way for traffic to flow from wan > lan.

my distrubution switch has default vlan1 192.168.20.0/24 network

bpi r2's wan port joins this network as a dhcp client.

I wanna [lan0-lan1] ports join this network and when i plug my pc to this ports they must gain IP address from 20.0/24 network so i selected br-lan unmanaged but not worked.

In the other hand when i added wan port to br-lan lan0 and lan1 joined 20.0/24 network but wan side destroyed even can not ping its gw.

And i will broadcast tagged vlans 100,200,300 through wan port to lan ports.
Can you help to obtain correct network configuration. I did it for RTL8380M dlink-dgs1210-10hp switch but i did not worked on bpi r2.
thanks

Hi , again
Could you some help to create and assign vlans 100,200,300 to ports lan0 lan1 lan2 ?

Here is solution from scratch:

add bridge "br-lan" from Devices tab and add lan0 lan1 lan2 and land to br-lan device
enable Bridge Vlan filtering and then add vlans : 100,200,300
As a result br-lan.100 br-lan.200 and br-lan.300 will occur.

I will get tagged vlans from dist. sw to bananapi with lan0 port so i will tick "t" for lan0 on vlan 100,200,300.
lan1 "u" vlan100
lan2 "u" vlan 200
lan3 "u" vlan 300

I added Interface for all vlan Devices from Interfaces tab with static address as a protocol and gave no ip to them.

I disabled ipv6 for whole interfaces.

As a result it worked now !

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.