Banana Pi BPI-R2 Router MTU Problem Solution

Hi, the device has a problem with the MTU. When I connect this device to another router with the following configuration, it works fine. But when I want to use this device as a PPPOE main router, it not only exceeds 5 Mbps. I would be glad if anyone can help me solve the problem.

this is the setting that works fine:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd47:b8e8:7a36::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan'

config interface 'lan'
	option proto 'dhcp'
	option device 'br-lan'

config device
	option name 'br-wan'
	option type 'bridge'
	list ports 'wan'
	option mtu '1500'
	option mac '46:26:4D:62:EB:20'

config interface 'wan'
	option proto 'dhcp'
	option device 'br-wan'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option name 'eth0'
	option mtu '1500'