B.A.T.M.A.N. problem of fragmentation


I'm trying to create my own mesh using BATMAN on 802.11s.
When I come to check IP reachability through BATMAN, I found problem maybe related to fragmenation.

Currently I'm testing on just 2 nodes for simplicity. One as DHCP server and GW, the other as DHCP client.
The nodes are connected by BATMAN bridge on 5GHz and 2.4GHz 802.11s.

My devices are below:

DHCP Client: Buffalo WXR-2533DHP
OpenWrt 21.02.2 r16495-bf0c965af0
BAT0 IP: 192.168.44.x
Platform: Qualcomm Atheros QCA9880
*seems to have problem

DHCP Server: Buffalo WSR-2533DHP2
OpenWrt SNAPSHOT r18809-5a0975f7ef
Platform: MediaTek MT7622
*seems not to have problem

The problem is, like below.

After WXR-2533DHP booted, I can ping from WXR-2533DHP to WSR-2533DHP2 with more than 1448byte.
However after some amount of packets were transmitted (for example iperf3), ping more than 1448byte no any longer works. While ping 1448byte or less goes well.
It seems fragmentation get stucked.

I tried remove 5GHz or 2.4GHz and use only one wireless band, the problem sill happens.
Swapping server and client role, the problem still happens.
I also have Elecom WRC-2533GST2/MT7621 and when it works with WSR-2533DHP2, there are often packet losses but will soon recovers.

Thus I guess Is it a platform specific problem of QCA9880.
Does anyone know the similar problem?

I tried use wired connection for BATMAN, removed 802.11s mesh.
And with wired connection, WXR-2533DHP can transmit large packets (as fragment) without problem.
iperf3 doesn't stuck this time.

Then the problem seems to be around wireless..
I tried set Fragmentation Threshold of radio0/1 to 1536 but no improve.